RIP(Routing information Protocol)是应用较早、使用较普遍的内部网关协议(Interior Gateway Protocol,简称IGP),适用于小型同类网络,是典型的距离向量(distance-vector)协议。
RIP通过广播UDP报文来交换路由信息,每30秒发送一次路由信息更新。RIP提供跳跃计数(hop count)作为尺度来衡量路由距离,跳跃计数是一个包到达目标所必须经过的路由器的数目。如果到相同目标有二个不等速或不同带宽的路由器,但跳跃计数相同,则RIP认为两个路由是等距离的。RIP最多支持的跳数为15,即在源和目的网间所要经过的最多路由器的数目为15,跳数16表示不可达。
  一般参加CCNA的考试时,会有两道动手的试验题,RIP是必考的内容,版本依题目指定的,可能是V1也可能是V2,仔细看。
实验拓扑:
Router>enable 
Router#config terminal
 Router(config)#hostname Gotha   //Gotha 是路由器名称,按要求输入
Gotha(config)#enable secret TestInside 1  //TestInside1是密码,按题目要求输入
Gotha(config)#line console 0
Gotha(config-line)#password TestInside2   //TestInside2是密码,按题目要求输入
Gotha(config-line)#exit 
Gotha(config)#line vty 0 4
Gotha(config-line)#password TestInside3   //TestInside3是密码,按题目要求输入
Gotha(config-line)#login
Gotha(config-line)#exit 
Gotha(config)#interface fa0/0
Gotha(config-if)#ip address 209.165.202.158 255.255.255.224  //注意看题目要求用第几个地址
Gotha(config-if)#no shutdown
Gotha(config-if)#exit 
Gotha(config)#interface s0/0
Gotha(config-if)#ip address 192.0.2.30 255.255.255.240     //注意看题目要求用第几个地址
Gotha(config-if)#clock rate 64000    //配置串口时钟,事先用sh run查看s0/0/1的时钟,别忘了呀!
Gotha(config-if)#no shutdown
Gotha(config-if)#exit 
Gotha(config)#router rip
Gotha(config-router)#version 2   //注意看题目要求用哪个版本
Gotha(config-router)#network 209.165.201.0   //宣告直连网段,考试时会改变
Gotha(config-router)#network 192.0.2.176     //宣告直连网段,考试时会改变
Gotha(config-router)#no auto-summary    //关闭自动汇总
Gotha(config-router)#end 
Gotha#copy run start       //保存配置
 
全部配完后并保存,先不要急于next,再sh run一下,检查一下配置。确认无误后再做下一道题。
 
  实验并不难,都是常用命令,但还是有人不能PASS,其中原因:一是看题不仔细,二是IP地址计算不准确,三是宣告了错误的网段。