控制路由更新数据流
1被动接口 PASSIVE-INTERFACE
被动接口只接收路由更新但不发送路由更新
该命令可被用于所有内部网关协议(RIP IGRP EIGRP OSPF IS-IS)
必须注意:
passive-interface命令在支持它的不同IP路由选择协议中的工作方式不同。
在OSPF中,被动接口的网络地址在OSPF域中作为一个末节网络出现;OSPF路由信息在一个被动接口上既不被发送也不被接受。
在EIGRP中,路由器在被动接口上不发送HELLO数据包;无法与其他路由建立吡邻关系。

2用发布控制列表过滤路由更新
发布控制列表(DISTRIBUTE-LIST)
在路由协议下面配置
同时需要使用ACL
使用 DISTRIBUTE-LIST命令创建一个路由过滤器,该命令可用于所有的IP路由选择协议
当 应用于进入in的路由更新时,配置一个路由过滤器的命令:
router(config-router)#distribute-list access-list-number in [interface-name]
当 应用于外出out的路由更新时,配置一个路由过滤器的命令:
router(config-router)#distribute-list access-list-number out [interface-name | routing-process | as-number]
使用interface-name会让路由过滤更精确,直接精确到端口。
CISCO IOS 为每个路由进程准许一个入方向的和一个外出方向的全局性发布列表,也可以为一个路由进程所涉及到的每个接口准许一个入方向的和一个外出方向的发布列表。
利用distribute-list命令配置一个被动EIGRP接口
router eigrp 100
network 10.0.0.0
distribute-list 5 out interface s0
exit
access-list 5 deny deny
使用这种配置,路由器可以自由发送EIGRP hello 数据包,并家里吡邻关系。但出S0发送出去的路由不含任何路由。

策略路由POLICY ROUTING
特点:可以手工方式指示路由器不仅根据目的地,还可以根据源地址来选择路由。
策略路由被广泛用于外部网关协议BGP
ROUTER(CONFIG)#route-map map-tag1[permit | deny] [sequence-number]
map-tag=name
sequence-number=number序列号
ROUTER(CONFIG-ROUTE-MAP)#match ip address 1
ROUTER(CONFIG-ROUTE-MAP)#set interface s0
ROUTER(CONFIG)#route-map map-tag2[permit | deny] [sequence-number]
ROUTER(CONFIG-ROUTE-MAP)#match ip address 2
ROUTER(CONFIG-ROUTE-MAP)#set interface s1
路由映射图应用到一个接口
interface e0
ip policy route-map map-tag1
interface e1
ip policy route-map map-tag2
 
使用多种路由选择协议
在路由选择协议之间交换路由信息的过程被称为路由再发布(redistribution)这种发布可以是单向也可以是双向的。
通常路由再发布实现在边界路由器上。
管理距离                 AD
直连接口                 0
从接口外出的静态路由     0
经下一跳的静态路由       1
EIGRP归纳路由            5
EBGP(外部BGP)           20
内部EIGRP                90
IGRP                    100
OSPF                    110
IS-IS                   115
RIP(版本1 版本2)      120
EGP                     140
外部EIGRP               170
IBGP(内部BGP)           200
未知                    255
管理距离的取值范围0-255,管理距离说小,路由选择协议可信度越高。
配置管理距离
RTZ(config)#router ospf 1
RTZ(config-router)#distance 95
distance命令最常被用来未经某个路由进程所学到的所有路由修改管理距离。上面例子中已经把OSPF的AD值从110改为95,但是这个值只对路由器本地有效,其它路由器还是110值。
distance 扩展方法:
1 根据路由源配置管理距离
RTZ(config)#router rip
RTZ(config-router)#distance 105 10.4.0.2 255.255.255.0
2 根据路由源和访问控制列表配置管理距离
RTZ(config)#router rip
RTZ(config-router)#distance 97 10.3.0.1 255.255.255.0  2
RTZ(config-router)#exit
RTZ(config)#access-list 2 permit 192.168.3.0 0.0.0.255

再发布(Redistribution)指南
network的作用:
1标识在那些接口上运行路由选择协议
2指示将那些直连路由包含在网络更新中
路由再分布容易产生的陷进
1路由回馈(环路)路由器有可能会从一个自治系统学到的路由信息发送回同一自治系统。
2路由信息不兼容 因为各路由选择协议采用不同的度量值来决定最佳路径,所以利用再发布的路由信息进行路径可能会导致非最佳路由。
3收敛时间不一致
为了避免这些陷井,必须按照下面这些原则:
1非常熟悉我们的网络和网络数据流量
2不要重叠使用路由选择协议
3在存在多台边界路由器的情况下使用单向再发布
4在单台边界路由器使用双向再发布                                                路由重新发布
R2(config)# router eigrp 100
R2(config-router)# redistribute ospf 10 metric 10000 100 255 1 1500?
将ospf重分发进eigrp
R2(config)# router ospf 10
R2(config-router)# redistribute eigrp 100 subnets  ?
在一个主类网络被划分了子网的情况 下,我们需要使用“subnets”来将由其它路由选择协议所学到的路由再发布到OSPF,如果不使用该关键字,OSPF则只再发布非子网化的主类网络。
将eigrp路由重分发到ospf
R2(config)#router rip
R2(config-router)# redistribute eigrp 100 metric 2
将eigrp路由重分发到rip

再发布直连和静态路由
1配置直连路由的再发布
RTB(config-router)#router eigrp 24
RTB(config-router)#redistribute connected metric 10000 100 255 1 1500
使用CONNECT 关键字,路由再发布将所有直连路由注入到动态路由选择协议的路由更新中,而不需要network命令
1配置静态路由的再发布
RTB(config-router)#router eigrp 24
RTB(config-router)#redistribute static metric 10000 100 255 1 1500
default-metric命令
使用该命令代替在每条redistribute命令语句中都包含相同的种子度量值来简化我们的路由再发布配置。