近期在我的虚拟化群中,有两个问题比较典型:
在比较老的服务器安装新的VMware ESXi 6.7或vCenter Server 6.7出错。
在比较新的服务器安装比较旧的ESXi版本5.5出错。
因为每个人的实验环境不同、条件不同,用不同的服务器做实验,或者为新的服务器、旧的服务器安装操作系统时,如果安装的系统与原来的系统不同,版本跨度不要过大,否则可能由于所安装的操作系统不支持当前硬件而造成安装失败。
我个人的经验,查看当前服务器的生产日期,安装这个时期前后两、三年出的操作系统,应该是可以支持的。例如,出厂日期是2008年的服务器,安装Windows Server 2008、Windows Server 2008 R2、安装VMware ESXi 3.5、ESXi 4.0、ESXi 4.1是可以的,也有可能安装ESXi 5.0,但再往后的版本就不推荐安装了。一是新的系统可能不支持这台服务器的CPU,或者这台服务器当时的配置(2008年),可能8GB、16GB内存就比较大了,但相对于ESXi 6.0来说,8GB才刚起步而己。
在vSphere发行说明中,除了有新功能介绍、修复的bug外,有的还明确提示不再支持某些型号的CPU。不再支持除了是不能在这些服务器上安装ESXi外,还包括不能在这些服务器的虚拟机中安装vCenter Server。
下面是vSphere 6.0、6.5、6.7不支持的CPU。

1 vSphere 6.0发行说明

在vSphere 6.0发行说明(链接地址https://www.vmware.com/cn/support/support-resources/pubs/vsphere-esxi-vcenter-server-6-pubs/vsphere-esxi-vcenter-server-60-release-notes.html)提出,禁止对不支持的 CPU 进行升级和安装。
vSphere 6.0 仅支持在 2006 年 6 月(第三季度)以后推出的处理器。与 vSphere 5.x 所支持的处理器相比较,vSphere 6.0 不再支持以下处理器:
AMD Opteron 12xx 系列
AMD Opteron 22xx 系列
AMD Operton 82xx 系列
在安装或升级过程中,安装程序检查主机 CPU 与 vSphere 6.0 的兼容性。如果您的主机硬件不兼容,将显示包含不兼容性说明消息的紫色屏幕,并且 vSphere 6.0 安装过程会停止。

2 vSphere 6.5不支持的CPU

在vSphere 6.5.0发行说明(链接地址https://docs.vmware.com/cn/VMware-vSphere/6.5/rn/vsphere-esxi-vcenter-server-65-release-notes.html)明确提出,禁止对以下不支持的 CPU 进行升级和安装。
与 vSphere 6.0 所支持的处理器相比较,vSphere 6.5 不再支持以下处理器:
• Intel Xeon 51xx 系列
• Intel Xeon 30xx 系列
• Intel core 2 duo 6xxx 系列
• Intel Xeon 32xx 系列
• Intel core 2 quad 6xxx 系列
• Intel Xeon 53xx 系列
• Intel Xeon 72xx/73xx 系列

3 vSphere 6.7不支持的CPU

vSphere 6.7禁止对不支持的 CPU 进行升级和安装
与 vSphere 6.5 所支持的处理器相比较,vSphere 6.7 不再支持以下处理器:
• Xeon 31xx、33xx、34xx Lynnfield 和 Clarkdale、35xx 和 36xx 系列
• Xeon 52xx、54xx、55xx、56xx 系列
• Xeon 65xx 系列
• Xeon 75xx 和 74xx 系列
• i3/i5 Clarkdale 系列
• i7-620LE 处理器系列
• 各种 i3/i5/i7 Nehalem/Bloomfield/Clarksfield、Lynnfield、Clarkdale/Arrandale、Westmere/Gulftown 系列
• AMD Barcelona、Shanghai、Champlain、Rana、Istanbul、Magny-Cours、Lisbon 系列
• Opteron 13xx、23xx、24xx、41xx、61xx、83xx、84xx 系列
• Athlon-II-X2 Champlain、Athlon-II-X3/X4 Rana 系列
在安装或升级过程中,安装程序检查主机 CPU 与 vSphere 6.7 的兼容性。如果您的主机硬件不兼容,将显示包含不兼容性说明消息的紫色屏幕,并且 vSphere 6.7 安装过程会停止。
以下 CPU 在 vSphere 6.7 版本中受支持,但不一定在将来的 vSphere 版本中受支持。请进行相应的规划:
• Intel Xeon E3-1200 (SNB DT)
• Intel Xeon E7-2800/4800/8800 (WSM EX)

4 在较老的主机安装新的ESXi与vCenter Server出错

现状:DELL刀片服务器XS23-TY3,安装VMware ESXi 6.7出错。当前是ESXi 6.5.0的系统,使用vCenter Server Appliance 6.7.0部署向导,将vCenter Server Appliance 6.7.0部署到ESXi 6.5.0的虚拟机也出错。下面是截图。
(1)DELL主机截图。
错误截图:
vSAN读者交流之1-要为不同时间的服务器选择合适的系统版本
(2)安装ESXi 6.7.0时出错:
vSAN读者交流之1-要为不同时间的服务器选择合适的系统版本
(3)安装vCenter Server Appliance 6.7.0时出错:
vSAN读者交流之1-要为不同时间的服务器选择合适的系统版本
vSAN读者交流之1-要为不同时间的服务器选择合适的系统版本

5 Hp dl560 gen10安装ESXi 5.5出错

HP DL560 Gen10安装ESXi 5.5时找不到硬盘,换成VMware ESXi 5.5 HP OEM版本也不行。用的以下版本。

vSAN读者交流之1-要为不同时间的服务器选择合适的系统版本
如果为DL 560 Gen10定制了新的5.5版本,包括了新的RAID卡、网卡驱动程序应该能安装。

6 专栏介绍

专栏《VMware vSAN中小企业应用案例》,以最新的vSphere 6.7为例,介绍VMware超融合技术vSAN-分布式存储在中小企业中的应用,以7章40篇以上的内容,介绍vSAN基础知识、vSAN产品选型、vSAN应用案例,其中vSAN基础知识、vSAN产品选型各用一章(各5篇文章)进行介绍,另外4章介绍vSAN应用案例,包括单台主机组建vSAN群集(用于实验)、3台主机组成双机热备系统(vSAN延伸群集应用)、标准vSAN群集应用(大多数企业环境的选择)、使用vSAN组成双活数据中心的应用案例。通过本专栏的学习,读者可以掌握为需要3~10台主机、30~200台虚拟服务器的环境,进行产品选择、交换机配置、vSphere安装配置等一系列内容,并能解决vSAN使用中经常遇到的问题。
《VMware vSAN中小企业应用案例》是我近期规划的一本vSphere图书的“精华”内容,为了准备这本图书,我准备了4台主机组成的标准vSAN群集、7台主机组成的万兆全闪存的vSAN群集的实验环境。
《VMware vSAN中小企业应用案例》
vSAN读者交流之1-要为不同时间的服务器选择合适的系统版本