RIPv2 was first described in RFC 1388 and RFC 1723 (1994); the current RFC is 2453, written in November 1998. Although current environments use advanced routing protocols such as OSPF and EIGRP, there still are networks using RIP. The need to use VLSMs and other requirements prompted the definition of RIPv2.
RIPv2 improves upon RIPv1 with the ability to use VLSM, with support for route authentication, and with multicasting of route updates. RIPv2 supports CIDR. It still sends updates every 30 seconds and retains the 15-hop limit; it also uses triggered updates. RIPv2 still uses UDP port 520; the RIP process is responsible for checking the version number. It retains the loop-prevention strategies of poison reverse and counting to infinity. On Cisco routers, RIPv2 has the same administrative distance as RIPv1, which is 120. Finally, RIPv2 uses the IP address 224.0.0.9 when multicasting route updates to other RIP routers. As in RIPv1, RIPv2 will, by default, summarize IP networks at network boundaries. You can disable autosummarization if required.
You can use RIPv2 in small networks where VLSM is required. It also works at the edge of larger networks.

Step1:
Click on the console host, you will get a pop-up screen CLI of Router.
Router>

Configure the new router as per the requirements provided in Lab question
Requirement 1:
Name of
the router is P4S-R2
Step2:
To change the hostname of the router to P4S-R2 follow the below steps
Router>

Router>enable
Router# configure terminal
Router (config)# hostname P4S-R2
P4S-R2(config)#

Requirement 2:
Enable-secret password is pass4sure1
Step3:
To set the enable secret password to pass4sure1 use the following command
P4S-R2(config)#enable secret pass4sure1
Requirement 3:

The password to access user EXEC mode using the console is pass4sure2
Step 4:

We need to configure the line console 0 with the password pass4sure2

Also remember to type login command after setting up the password on line con 0 which allows router to accept logins via console.
P4S-R2(config)# line con 0

P4S-R2(config-line)#password pass4sure2
P4S-R2(config-line)#login
P4S-R2(config-line)# exit
P4S-R2(config)#

Requirement 4:

The password to allow telnet access to the router is pass4sure3
Step 5:
To allow telnet access we need to configure the vty lines 0 4 with the password pass4sure3

Also remember to type login command after setting up the password on line vty 0 4 which allows router to accept logins via telnet.
P4S-R2(config)# line vty 0 4

P4S-R2(config-line)#password pass4sure3
P4S-R2(config-line)#login
P4S-R2(config-line)# exit
P4S-R2(config)#

Requirement 5:
(5.1) Ethernet network 209.165.201.0 /27 – Router has the fourth assignable host
address in subnet.
(5.2) Serial Network is 192.0.2.176 /28 – Router has the last assignable host
address in subnet.
Step 6:
Ethernet network 209.165.201.0 /27 – Router has the fourth assignable host address in subnet.
Ethernet Interface on router P4S-R2 is Fast Ethernet 0/0 as per the exhibit
First we need to identify the subnet mask
Network: 209.165.201.0 /27
Subnet mask: /27: 27 bits = 8 + 8 + 8 + 3
=8(bits).8(bits).8(bits) .11100000 (3bits)
=255.255.255.11100000
=11100000 = 128+64+32+0+0+0+0+0
= 224
Subnet mask: 255.255.255.224
Different subnet networks and there valid first and last assignable host address range for above subnet mask are
Subnet Networks :::::: Valid Host address range :::::: Broadcast address
209.165.201.0 :::::: 209.165.201.1 – 209.165.201.30 ::::: 209.165.201.31
209.165.201.32 :::::: 209.165.201.33 – 209.165.201.62 ::::: 209.165.201.63
209.165.201.64 :::::: 209.165.201.65 – 209.165.201.94 :::::: 209.165.201.95
209.165.201.96 :::::: 209.165.201.97 – 209.165.201.126 :::::: 209.165.201.127
209.165.201.128 :::::: 209.165.201.129 – 209.165.201.158 :::::: 209.165.201.159
209.165.201.160 :::::: 209.165.201.161 – 209.165.201.190 :::::: 209.165.201.191
209.165.201.192 :::::: 209.165.201.193 – 209.165.201.222 :::::: 209.165.201.223
209.165.201.224 :::::: 209.165.201.225 – 209.165.201.254 :::::: 209.165.201.255
Use above table information for network 209.165.201.0 /27 to identify
First assignable host address: 209.165.201.1
Last assignable host address: 209.165.201.30
Fourth assignable host address: 209.165.201.4
This IP address (209.165.201.4) which we need to configure on Fast Ethernet 0/0 of the router using the subnet mask 255.255.255.224
P4S-R2(config)#interface fa 0/0

P4S-R2(config-if)#ip address 209.165.201.4 255.255.255.224

Requirement 6:
To enable interfaces
Use no shutdown command to enable interfaces
P4S-R2(config-if)#no shutdown

P4S-R2(config-if)#exit

Step 7:
Serial Network is 192.0.2.176 /28 – Router has the last assignable host address in subnet.
Serial Interface on P4S-R2 is Serial 0/0/0 as per the exhibit
First we need to identify the subnet mask
Network: 192.0.2.176 /28
Subnet mask: /28: 28bits = 8bits+8bits+8bits+4bits
=8(bits).8(bits).8(bits) .11110000 (4bits)
=255.255.255.11100000
=11100000 = 128+64+32+16+0+0+0+0
= 240
Subnet mask: 255.255.255.240

Different subnet networks and there valid first and last assignable host address range for above subnet mask are
Subnet  Networks ::::: Valid Host address ::::::::::: Broadcast address
192.0.2.0 :::::: 192.0.2.1 – 192.0.2.14 ::::::: 192.0.2.15
192.0.2.16 ::::::: 192.0.2.17 – 192.0.2.30 ::::::: 192.0.2.31
192.0.2.32 :::::::: 192.0.2.33 – 192.0.2.46 :::::: 192.0.2.47
192.0.2.48 :::::: 192.0.2.49 – 192.0.2.62 ::::::: 192.0.2.64
192.0.2.64 ::::::: 192.0.2.65 – 192.0.2.78 ::::::: 192.0.2.79
192.0.2.80 :::::::: 192.0.2.81 – 192.0.2.94 :::::: 192.0.2.95
192.0.2.96 :::::: 192.0.2.97 – 192.0.2.110 ::::::: 192.0.2.111
192.0.2.112 ::::::: 192.0.2.113 – 192.0.2.126 ::::::: 192.0.2.127
192.0.2.128 :::::::: 192.0.2.129 – 192.0.2.142 :::::: 192.0.2.143
192.0.2.144 :::::: 192.0.2.145 – 192.0.2.158 ::::::: 192.0.2.159
192.0.2.160 ::::::: 192.0.2.161 – 192.0.2.174 ::::::: 192.0.2.175
192.0.2.176 :::::::: 192.0.2.177 – 192.0.2.190 :::::: 192.0.2.191
and so on ….
Use above table information for network 192.0.2.176 /28 to identify
First assignable host address: 192.0.2.177

Last
assignable host address: 192.0.2.190
We need to configure Last assignable host address (192.0.2.190) on serial 0/0/0 using the subnet mask 255.255.255.240
P4S-R2(config)#interface serial 0/0/0

P4S-R2(config-if)#ip address 192.0.2.190 255.255.255.240
Requirement 6:
To enable interfaces
Use no shutdown command to enable interfaces
P4S-R2(config-if)#no shutdown

P4S-R2(config-if)#exit

Requirement 7:

Router protocol is RIPv2
Step 8:

Need to enable RIPv2 on router and advertise its directly connected networks
P4S-R2(config)#router rip
To enable RIP v2
routing protocol on router use the command version 2
P4S-R2(config-router)#version 2
Optional: no auto-summary (Since LAB networks do not have discontinuous networks)
RIP v2 is classless, and advertises routes including subnet masks, but it summarizes routes by default.
So the first things we need to do when configuring RIP v2 is turn off auto-summarization with the router command no auto-summary if you must perform routing between disconnected subnets.
P4S-R2 (config-router) # no auto-summary
Advertise the serial 0/0/0 and fast Ethernet 0/0 networks into RIP v2 using network command
P4S-R2(config-router)#network 192.0.2.176

P4S-R2(config-router)#network 209.165.201.0
P4S-R2(config-router)#end

Step 9:
Important please do not forget to save your running-config to startup-config
P4S-R2# copy run start
That is all, hope to helpful for you. Best Luck for ur CCNA 640-802 Exam.