Server:
ip multicast-routing
!
interface FastEthernet0/0
ip address 12.0.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 12.0.0.2
!
!
—————————————————————————-
Multicast router1:
ip multicast-routing
!
interface Loopback0
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 23.0.0.1 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 12.0.0.2 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
router eigrp 100
network 12.0.0.0 0.0.0.255
network 23.0.0.0 0.0.0.255
network 192.168.2.0
no auto-summary
!
ip http server
no ip http secure-server
!
!
ip pim rp-address 192.168.2.1
!
——————————————————————————
Multicast router2:
ip multicast-routing
!
interface Loopback0
ip address 192.168.3.1 255.255.255.0
!
interface Loopback1
ip address 192.168.4.1 255.255.255.0
ip pim sparse-mode
ip igmp join-group 224.2.2.2
!
interface FastEthernet0/0
ip address 34.0.0.1 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 23.0.0.2 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
router eigrp 100
network 23.0.0.0 0.0.0.255
network 192.168.3.0
no auto-summary
!
ip http server
no ip http secure-server
!
!
ip pim rp-address 192.168.2.1
!
——————————————————————————
PC:
ip multicast-routing
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 34.0.0.2 255.255.255.0
ip igmp join-group 224.3.3.3
duplex auto
speed auto
!
ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 34.0.0.1
!
——————————————————————————
Server#p 224.2.2.2
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:
Reply to request 0 from 23.0.0.2, 376 ms
R1#p 224.3.3.3
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.3.3.3, timeout is 2 seconds:
Reply to request 0 from 34.0.0.2, 548 ms