今天遇到一点问题,解决后分享给大家;
注:R1,R2都用F0/1分别接电信与联通两条线。
R1,R2都是通过F0/0分别接到S1,S2
S1,S2之间为channel-group
r1
===========
interface FastEthernet0/0.1
ip address 192.168.1.5 255.255.255.128
standby 1 priorty 200
standby 1 preempt
standby 1 ip 192.168.1.9
standby 1 track f0/1 110
interface FastEthernet0/0.2
p address 192.168.1.135 255.255.255.128
standby 2 preempt
standby 2 ip 192.168.1.137

r2
===========
interface FastEthernet0/0.1
ip address 192.168.1.6 255.255.255.128
standby 1 preempt
standby 1 ip 192.168.1.9

interface FastEthernet0/0.2
ip address 192.168.1.136 255.255.255.128
standby 2 priorty 200
standby 2 preempt
standby 2 ip 192.168.1.137
standby 2 track f0/1 110
下面是R1,R2共同的
ip nat inside source list 1 interface FastEthernet0/1 overload
access-list 1 permit 192.168.1.0 0.0.0.255
在F0/0上配置ip nat inside
在F0/1上配置ip nat outside
在配置dns-server时后面要加上电信与联通提供的DNS地址
如果只加一方,结果就是PC可以PING通外部地址,但打不开网页。