思科IOS,什么叫IOS,其实他相当于微软件操作系统,不过他是运行在思科路由器与交换机上面的一个系统。OS的一些基本功能:运载网络协议和功能,对产生高速流量的设备进行连接,增加网络安全性, 提供网络的可扩展性来简易网络的增长和冗佘问题,可靠的连接网络资源。

一般可以通过三种方法进行IOS:1,路由器的CONSOLE口,用于本地的,也就是说用PC上面的COM口接到路由器上面的控制口。2,还有就是通过MODEM连接aux口,用于远程。
3,还有就是VTY线路来telnet ,一般我们用得最多的就是通过控制台,还有就是telnet。

那么一台路由器从开机要经过那些过程呢,其实跟一台PC差不多,首先加电以后,硬件自检,再是定位并载IOS文件,最后一步是定位并运行配置文件,最后一步完成,那么这个设备就算完成了,可以正常工作了。开机自检不需要说了吧 。那么重点在引导上面,这个在考试中也会考到的。

如果加电自检没有问题,那么IOS存在的话,将从它的闪存(flash memory)查找与加载IOS到ram中(以前的2500系列的不加载到RAM中的,直接从flash运行)。flash是一种电子可擦除只读存储器,如果加载IOS也是成功的,那么他会在非容失性(NVRAM)中查找启动配置文件,startup-config,如果没有找到任何的启动配置文件,那么路由器将进入到setup模式中。setup模式一看名字就知道,是一种安装模式,这种模式可以对路由器进行一些配置,但是一般最好不要用这种配置模式,一般在进入这种模式之前会有提示出现:command-line interface,你输入yes就是进入这种配置模式,如果输入no,那么你就进入了用户模式,在setup模式中,[]代表默认设置,你可以使用ctrl+C随时退出setup模式。

路由器的所有模式如下:

用户模式
特权模式(也可叫特机模式)
全局配置模式(也可叫配置模式)
端口配置模式(也可叫接口模式)
子接口配置模式
线路配置模式
路由配置模式


(用户模式)
我们重点是进入路由器以后,就是一种用户模式
如果你不进入setup模式就是进入了用户模式
Router>
这是用户模式的提示符,。
前面那个router是代表路由器的名字,这个中字随便你那么取
这个名字随便你那么取。
一般在用户模式里面做不了什么很多的操作,

其实这些模式跟LINUX下面的那些模式差不多的
模式不一样,那么权限也是不一样的
如果我们要查看一些配置的话,我们就要进入到特权模式,请注意提示符的变化
router#

(特权模式)
在用户模式中
router>enable
输入enable (可以简写成en)
就会到router#
一般在查看路由器的一些配置,路由信息,都是在这个模式下面查看的

如果要用特权模式中返回到用户模式就用disable
也就是router# disable
就可以返回到用户模式了
那么在用户模式与特权模式退出命令行呢,就输入logout就行了

前面两种模式,对于路由器来说,做不了什么用大的配置
比如说我们要更换主机名这些,都做不了
因为有一种更高级的模式,叫全局配置模式,

(全局配置模式)
在特机模式下输入configure terminal
可以简写为conf t
但是我建议大家在初学阶段尽量打完命令,因为有时候考试可能要你输全命令的
这个全局配置模式的提示符如下
router(config)#
如果大家要退出这种模式就返回到特权模式的话,就输入跟前面那个disable 一样的

(端口模式)
还有一种模式就是接口模式,就是相对于每个接口来说的
比如我要配置以太网口 e0
那么我在全局配置模式下面输入interface ehernet number
interface代表我要进接一个接口。那么ehternet代表我是进入以太网的类型的接口
number代表我要进入到序数为几的那个口
比如我现在要进入以太网0口
那么如下所输入router(config)#interface ehernet 0
也可以简写为int e0
那么提示符又会变成router(config-if)#
这是接口配置模式

(子接口配置模式)
那么还有接口划分逻辑子接口,
他也是在全局配置模式下面进入的
输入命令
router(config)#interface fastehernet 0/0.1
提示符就会变成
router(config-subif)#

(线路配置模式)
还有一种线路配置模式,
也是在特权模式中输入
router(config)#line console 0
代表我要进入控制台这个线路
提示任就会变成
router(config-line)#

(路由配置模式)
还有一种路由配置模式,
也是特权模式下面输入
router(config)#router rip
代表我进入了路由配置模式了
提示任为router(config-router)#
从这些模式中大家可以有几种方式出来
一种是EXIT。另一种是END
IOS的模式也就是这几种,一定要分清楚了,考试中也会考得的

[交换机]

那么我们来看交换机的启动吧:看课件上面的11页,在思科的交换机当中, 1900系列,只有两个10/100自识应端口。其它的都是10M的。而2900的,没有10M的。,全是10/100以上,在交换机启动的时候,所有的指示灯都变成绿色,接下来就是每个端口自检,对应的指示灯也就没有了
如果不通过自检的,那么他对应的指示灯是黄色的,如果有自检失败的话,那么系统指示灯就会变成黄色,系统指示灯上面有标有 system status led ,这个是系统指示灯, 如果自检都没有问题,那么自检过程完成了,自检完成,指示灯都闪亮一下熄灭。 交换机初次启动,会显示一些信息,主要还是一些硬件的信息。

交换机有几种配置方法的:

一种是菜单式,一种是CLI,也就是路由器的命令行,
一般交换机初次启动会出来如下菜单的:[M] Menus,[K] Command Line,IP Configuration。
会要你选扭其中一种方式去配置路由器,M是使用菜单配置交换机,K就是进入命令行,I就是在交换机上利用一个菜单创建基本的IP配置,一般我们都是选K,进行命行配置,在交换机的模式一样的。区别不一落千样的就是交换机的一般初次是没有主机名的。
就比如说:>这就是用户模式,#这是特权模式。而路由器一般前面带有rouer字样子的,他各种模式的转换跟路由器的一是样的。


交换机的所有模式如下:用户模式,特机模式,全局配置模式,端口配置模式,VLAN配置模式。


[命令](只实用于交换机)

一般不管在那种模式上面都可以输入?号,可以查看你可以使用的命令,你可以在不同的模式下面输入?看一下。每一个命令都有区别的, 而用户模式下面是最少的,不管是在路由器还是交换机中我们用得最多的就是查看命令,查看配置我们都是特权模式下面用的 。

比如说show version ,这是查看你的IOS的一些基础信息

show running-config这是查看配置信息

show interface这个查看接口信息

我们在交换机上面用show version看看。能得到如下信息:

Cisco Catalyst 1900/2820 Enterprise Edition Software
Version V8.01.01     written from 171.068.229.225
Copyright (c) Cisco Systems, Inc.  1993-1998
wg_sw_c uptime is 15day(s) 21hour(s) 53minute(s) 11second(s)
cisco Catalyst 1900 (486sxl) processor with 2048K/1024K bytes of memory
Hardware board revision is 5
Upgrade Status: No upgrade currently in progress.
Config File Status: No configuration upload/download is in progress
27 Fixed Ethernet/IEEE 802.3 interface(s)
Base Ethernet Address: 00-50-BD-73-E2-C0

这个版本号是Version V8.01.01  

27 Fixed Ethernet/IEEE 802.3 interface(s)
有27个以太网接口

cisco Catalyst 1900
这是一台1900交换机

其它的无所谓

那我们来输入一个show run

Building configuration...
Current configuration:
!
hostname "wg_sw_c"
!
ip address 10.1.1.33 255.255.255.0
ip default-gateway 10.3.3.3
!
interface Ethernet 0/1

interface Ethernet 0/24
!
Interface Ethernet 0/25
!
interface FastEthernet 0/26
!
interface FastEthernet 0/27

hostname "wg_sw_c"
这是这台交换机的主机名
IP 地址 是10.1.1.33
网关是10.3.3.3

我们来查看一个端口的信息
show interfaces ethernet 0/1
就是表示我要查看0/1这个端口
Ethernet 0/1 is Enabled            
Hardware is Built-in 10Base-T
Address is 0050.BD73.E2C1
MTU 1500 bytes, BW 10000 Kbits
802.1d STP State:  Forwarding     Forward Transitions:  1
Port monitoring: Disabled
Unknown unicast flooding: Enabled
Unregistered multicast flooding: Enabled
Description:
Duplex setting: Half duplex            
Back pressure: Disabled
Ethernet 0/1 is Enabled  
这个端口是开的

Hardware is Built-in 10Base-T
10M的
他的MAC地址是0050.BD73.E2C1
最大传输单远是1500bytes
带宽是10000K
stp状态是转发
Half duplex
是一个半双工接口
因为交换机的IP是针对VLAN来定的

我们要查看交换机的IP是只要在特权模式下面输入show ip
IP Address: 10.5.5.11
Subnet Mask: 255.255.255.0
Default Gateway: 10.5.5.3
Management VLAN:  1
Domain name:  
Name server 1: 0.0.0.0
Name server 2: 0.0.0.0
HTTP server : Enabled
HTTP port :  80
RIP : Enabled
ip 是10.5.5.11
这个IP主针对VLAN1来的

交换机都有一个默认的一个VLAN存在,这个就是VLAN1,是删除不掉的。

如果我要给这个交换机加一个名字,那么我就在特权模式下面输入 (config)#hostane spstar
那么只要一输入hostname 提示符前面就会出现tpstar
tpstar(config)#
给交换机配置一个IP只要输入 IP ADDRESS后现跟IP netmask
比如我要给这台tpstar一个IP
tpstar(config)# ip address 10.5.5.11 255.255.255.0

如果路由器第一次启动,那么它会显示一个初始的配置对话框

--- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]: y

如果你选Y那么你就是按这种模去配置路由的一些基本配置
就是我们昨天说的SETUP配置模式,建议大家不要用这种配置模式,

那么就在后面输入N就行了。退出这个配置模式对话

Continue with configuration dialog? [yes/no]: n  

退出对话框,那么路由器就进入了用户模式,
router>
这些模式昨天也己经说过了

我们一般配置路由的一些参数我们都在特权模式,和全局配置模式。
我们先来看看在特权模式下面能用到那些

我们在特权模式下面输入一个?号就可以看到你可以使用那些命令
wg_ro_c#?
Exec commands:
access-enable    Create a temporary Access-List entry
access-profile   Apply user-profile to interface
access-template  Create a temporary Access-List entry
bfe              For manual emergency modes setting
cd               Change current directory
clear            Reset functions
clock            Manage the system clock
configure        Enter configuration mode
connect          Open a terminal connection
copy             Copy from one file to another
debug            Debugging functions (see also 'undebug')

这只是一部分命令,大家可以用路由器来做下看看

比如说你在配置的时候,突在一个命令不知道那么敲了,那么你输入?号就可以查看到你要使用的那些命令。还有就是如果你只知道那个命令第一个字母。那么你在那个字母后面加一个?也可以得到这个命令。这个?主要是起到一个帮助的作用。

比如?我要在路由器上面设置时间,那么我只知道clock这个单词的第一个字母C

router#c?
clear clock

他会显示两个以C开头的命令,

但是一个CLOCK不是一个完整的命令,
你再在CLOCK后面空格加一个?分,他会提示你可以所带的参数,

router#clock ?
set  set the time and date

他就是说你后面要加一个SET单词,这个SET主要是设计时间与日期的
那么你按他的提示再加上一个SET
如果你不知道,这个命令的完整语句,那么你按回健,确认,
系统就会提示你这个命令不完整

router#clock set
% Incomplete command.

那么你就在后面再加一个?看看,那些不对

router#clock set ?
hh:mm:ss  Current Time

因为你只是说你要设置时间。但是你没有把时间写上去,他会提示你这这种格式把时间写上去,
那么你再写上去,比如说现在是
21点16分30秒

router#clock set 21:16:30

你再按回车的话,那么同样会提示你命令不完整
因为你没有把年月日写上
标准备的一个命令是

router#clock set 21:16:30 13 august 2005

2005年8月13号21点16分30秒

那么如果我们在输入router#cloeck set 21:16:30 13 june 2005 那么会提示这个命令有错误,错误指向cloeck这个e

% Invalid input detected at the '^' marker

所有时候输入命令的时候,如果不正确,要看清楚错识提示,
如果想重复上一个执行的命令,你可以按向上光标健就可以回复到前一次的命令
如果是前面两个,就按二次就行了
你也可以在用户模式下面使用查看你所使用过的命令,

Router> show history

一般是显示10条吧,但是这个10条你可以去设置,可以是20条,15条,
这是根据你的习惯去用的,
特别是有时候你配置出了问题,你可以通过这种方法去查看你做了那些操作,更方便的查出问题

还记得我昨天在交换机上面用show version查看交换机的版本信息吧
同样在路由器一样可以查看得到的

wg_ro_a#show version
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-JS-L), Version 12.0(3), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Mon 08-Feb-99 18:18 by phanguye
Image text-base: 0x03050C84, data-base: 0x00001000

ROM: System Bootstrap, Version 11.0(10c), SOFTWARE
BOOTFLASH: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOFTWARE(fc1)

wg_ro_a uptime is 20 minutes
System restarted by reload
System image file is "flash:c2500-js-l_120-3.bin"
(output omitted)
--More--

这个路由器的IOS文件名是c2500-js-l
版本号是12。0(3)

那么查看路由器的配置情况呢,
因为路由器有两种存放配置信息的地方
一种是ram
一种是nvram
这两种昨天也说过了
保存在ram中的就是当前你运行的配置情况,就好比,你在在保存后的一些配置改动。
而NVRAM就是你己经保存过的配置情况,
路由器重新启动他就会查找NVRAM中的配置信息

查看当前的配置信息是show running-config
也可以简写为show start
如果你配置好一台路由器那么要做好保存,
其实保存就相当于把RAM里面的复制到NVRAM中去
其实保存就相当于把RAM里面的复制到NVRAM中去
就是copy running-config startup-config
路由器还有几种标识的功能,就相当于我们在PC上面取主机名
还有开机的一些显示,
同样在路由器上机也可以做得到的   

路由器的主机名怎么修改
就是在全局配置模式下面输入hostname 路由器名字
Router(config)#hostname tpstar
那么按回键
就会变成tpstar(config)#

那么在路由器一启动的时候,也可以显示一些信息,比如提示我这台路由器主要是用来做什么工作的,
命令就是在全局配置模式下面输入banner modt # #
主注# #之间是你要写的内容

tpstar(config)# banner modt #
welcome to [url]www.cnfan.net#[/url]

那么路由器就会显示welcome to [url]www.cnfan.net[/url]这句话

还有一个是针对端口描述的
主要的作用也是为了方便别人一看这个标识就知道这个接口主要是用来做什么的,连接那里的
这个要进行端口配置模式里里面去
我们在全局配置模式下面进入端口模式大家知道吧 比如我要进入路由器的以太网0口 那么我在全局模式下面输入
int e0
我这是简定了
tpstar(config)#interface ethernet 0
tpstar(config-if)#description cnfan.net
description这个是描述的意思
后面那个cnfan.net就是代示这个端口的是cnfan.net
具体大家可以随便写

路由器有密码配置,
第一种是控制台密码
就是你能过控制台进入路由器也要输入密码
配置方法就是进入线路配置模式,
Router(config)#line console 0
Router(config-line)#login
Router(config-line)#password cisco
在全局模式下面用用line con0进入控制台
再输入一个login
再输入pssaword cisco
我把这台路由器的控制台的密码设为cisco

还有就是虚拟终端密码
也就是我们常用的telnet
如果我们不配置这个密码的话,那么我们是不能telnet到这台路由器上面的,所以大家一定要记住,如果一台路由器不能telnet 去。请查看你一下你的虚拟终端密码有没有配置好
Router(config)#line vty 0 4
Router(config-line)#login
Router(config-line)#password sanjose
line vty 0 4
一般我们telnet到一台路由器上面都是用5个线路,
0 1 2 3 4 这5条
telnet的密码是sanjose

思科还可以在用户模式进入特机模式下面也要输入密码
可以输入两种密码方式
一种是明文的,就是可以看得懂的,另一种是加密码
Router(config)#enable password cisco 这是明文格式
Router(config)#enable secret tpstar  这是加密方式
当两种方式存在的时候,他以加密的方式为主
如果你在特权模式下面用show run
可以看到明文的密码
而你看到的加过密的密码是一堆乱码
建议大家要设密码就设加密的

现在我们来看一个端口那么配置的
配置一个串口
也就是serial
也是我们用得很多的一种串口连接
首先进行进入全局配置模式。
Router#configure term
Router(config)#
再从全局配置模式进入到端口配置模式。
Router(config)#interface serial 0
我要进入串口0上面去
提示符就会变成
Router(config-if)#
因为是串口,大家还记得有DCE DTE之间的区别吧
DCE是要配置时钟表的对不对
那么假如我这个串口是DCE,那么我们人配置时钟
Router(config-if)#clock rate 64000
配置时钟完成以后,我们就要配置ip地址了
因为路由器每一个接口都有一个IP的
Router(config-if)#ip add 10.140.4.2 255.255.255.0
Router(config-if)#ip address 10.140.4.2 255.255.255.0
可以输入ip add后面加IP号与NETMASK就行了
这些配置完成以后, 我们还没有打开这个端口,只是配置好了IP地址与时钟而己
独打开这个端口就是no shutdow
关掉这个端口就是shutdown
那么这个端口我们算是配置完成了
Router(config-if)#no shutdown

在以太口上面不用配置时间。直接配置IP地址与打开就行了
不用配置时钟

如果你的连接没有问题那么只要你一输入no shut
系统就会有提示
%LINK-3-UPDOWN:  Interface Seria0, changed state to up
%LINEPROTO-5-UPDOWN:  Line Protocol on Interface Serial0, changed state to up  
如果你输入shutdown
%LINK-5-CHANGED: Interface Serial0, changed state to administratively down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down  
系统就会提示这个端口关掉了,
changed state to administratively down   这句话表示是管理员关掉的
那么这个端口己经配置好了,我们要查看这个端口的信息就是在特权模式下面输入show int s0
Router#show interface serial 0

Serial0 is up, line protocol is up
  Hardware is HD64570
  Internet address is 10.140.4.2/24
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 1/255
  Encapsulation HDLC, loopback not set, keepalive set (10 sec)
  Last input 00:00:09, output 00:00:04, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bitsCc, 0 packetsCc
  5 minute output rate 0 bitsCc, 0 packetsCc
会显示如下信息
注意看。这里面有两个up
第一个是管理员,边有连接的,
每二个上路由协议的UP
这个端口的IP是10.140.4.2/24
在路由器里面他表示NETMASK是用/24这来种来表示的,
/24 是255。255。255。0
/18 255。255。0。0
那么show interfaces serial 0
只是查看这个端口的信息,我想一起查看其它的端口呢,那么输入
Router#show interfaces  
就会显过这台路由器的所有端口
串口上面,如果线是我们自己接的,我们可以看到连接线上面标有DCE DTE头的,
但是如果不是我们接的,也有时候不方便查看,那个是DTE DCE呢,
我们同样可以用命令可以查看得到的
Router#show controller serial 0
输入这个命令我们可以查看得这个串口是什么类型的
他会有提示如下:
HD unit 0, idb = 0x121C04, driver structure at 0x127078
buffer size 1524  HD unit 0, V.35 DTE cable
V.35 DTE cable  这是一个DTE设备,
那么我们就需要配置时钟