出现java.lang.UnsupportedClassVersionError 错误的原因,是因为我们使用高版本的JDK编译的Java class文件试图在较低版本的JVM上运行,所报的错误。

因为,高版本的JDK生成的class文件使用的格式,可能与低版本的JDK的.class文件格式不同。这样,低版本的JVM无法解释执行这个.class文件,会抛出java.lang.UnsupportedClassVersionError不支持的Class版本错误。

在ubuntu下的解决方法是

在 http://www.oracle.com/technetwork/java/javase/downloads/index.html
这个地址里面下载 jdk-7u67-linux-x64.tar.gz   这个压缩包,然后将其解压缩在
原来安装jdk的目录下,我安装的目录是 /usr/lib/jvm/java 这个目录下
解压缩到这个目录下,如下图1


wKiom1PoVWOjQY49AAFOklzlMvk382.jpg



然后再打开 eclipse  选择 window--> preferences,加入1.7的jre,如下图2


wKioL1PoVqSC0zNDAAJZW99ibCI401.jpg



加载完成后会重新编译一遍eclipse中的项目。再次运行原来的程序,发现已经更新成了1.7的java虚拟机,不会再报上面的错误了