一、交换机
1.二层交换
特性:
基于MAC地址转发数据帧
硬件工作
处理数据效率高,数据传输延时低
转发广播
 
2.三层交换
特性:
提供路由功能
提高安全性
流量管理
 
3.网络方案中交换机的选择
小型网络
层次结构:核心层和接入层
核心层:catalyst 3550/2950
接入层:catalyst 2950
中型网络
层次结构:接入层,分布层,核心层
接入层:catalyst 2950/3550
分布层:catalyst 3550/4003/4006
核心层:catalyst 4003/4006/6506/6509/6006/6009
大型网络
层次结构:接入层,分布层,核心层
接入层:catalyst 3550/4003/4006
分布层:catalyst 4003/4006/6506/6509/6006/6009
核心层:catalyst 6506/6509
 
4.交换机的基本配置
#show flash    =#dir
//查看falsh信息(config.text可破解交换机密码)
#erase startup-config
//清空备份配置文件
#reload
//重启reload
config#enable secret 密码
//设置特权用户密码
给管理vlan配置IP
config#int vlan 1
config-if#ip address ip地址 掩码
config-if#no shutdown
配置端口描述
config-if#description 描述
config-if#no description
配置交换机的网关
config#ip default-gateway 网关IP
配置端口的速率和双工
config-if#speed 10/100/1000/auto
config-if#duplex half/full/auto
原则:
a.千兆端口速率设成1000mbit/s,双工自动协商
b.100Base-T,应该明确指定双工模式为半双工或全双工,将速率设为自动协商
c.10/100/1000端口设定为半双工或全双工时,能支持10/100mbit/s,但如果速率设置为1000mbit/s,就只能以全双工方式工作
d.千兆端口转换器的模块端口只能工作在1000mbit/s
e.100Base-FX端口只能工作在100mbit/s的全双工模式下
//HUB连接的交换机端口要为半双工,因HUBCSMA/CD(载波侦听多路访问冲突检测)协议工作在半双工状态
 
 
二、Vlan
vlan:逻辑划分广播域,提高网络性能
image
广播会导致:带宽问题,延时问题,设备资源占用问题
 
1.特性
不受地理位置/物理位置限制
灵活性flexibility(添加/删除成员比较方便)
安全性
备注:a vlan = a boardcast = a logical network
 
2.VLAN的部署
正确动机
a安全
b灵活
c控制广播
错误动机
部署VLAN可以在一定程度上减轻对路由器的依赖;管理容易
实际情况:VLAN无法消除第三层的工作;网络监控方面的工作在基于VLAN的网络上,比传统网络更困难.因为VLAN的逻辑机构更复杂
 
3.VLAN的规划
image
最常用的: 基于物理位置的本地VLAN,IP子网一一对应
注意:cisco推荐部署本地或基于地理位置的VLAN,而且基于IP子网对网络进行分段
 
4.Vlan协议:VTPVlan Trunking Protocol
功能:传输vtp通告
VTP通告发送机制
a.VLAN信息变化时,立即发送
b.VLAN信息未变,每5分钟发送一次
VTP模式
服务器模式(server
特性:
a.建立,修改,删除Vlan
b.发送/转发VTP通告
c.Vlan信息同步
d.Vlan配置保存在nvram内(start-up config
客户端模式(client
特性:
a.不能建立,修改,删除Vlan
b.发送/转发VTP通告
c.Vlan信息同步
d.Vlan配置不保存在nvram内(running config
透明模式(transparent
a.建立,修改,删除Vlan
b.转发VTP通告
c.Vlan信息不同步
d.Vlan配置保存在nvram内(start-up config
image
VTP模式的配置(两种方式)
config#vtp mode server/client/transparent
#vlan database    //进入vlan数据库模式
vlan#vtp server/client/transparent
VTP默认模式为:server
查看vtp配置:#show vtp status
VTP的裁剪
交换机在向某条链路上发送广播之前,先探察该链路上是否有vlan成员,如果有vlan成员,广播正常在该链路上转发;否则,广播在该链路上被裁减
image
VTP裁剪配置
vlan#vtp pruning
//只需要在vlan服务器上配置
image
VTP验证
vlan#vtp password 密码
VTP
vlan#vtp domain 域名
//客户端只从域内的VTP服务器下载信息,VTP服务器可以有多个,谁先响应就从谁那下载vlan信息
VTP版本
vlan#vtp v2-mode
 
5.Vlan配置
单交换机vlan
步骤:
A.配置vtp模式
vlan#vtp server
B.建立vlan
vlan#vlan vlan name vlan
或者
config#vlan vlan
config-vlan#name lan
//vlan号:
04095为系统保留
1厂商默认
2-1001用于以太网
1002-1005用于令牌环网
1025-4094用于扩展以太网
//vlan名:习惯按照行政机构命名
C.vlan中添加成员
config-if#switchport mode access
//把端口配置为“访问端口”
config-if#switchport access vlan vlan
查看vlan配置:#show vlan
重点提示:
vlan#apply
为了把vlan数据库模式下的配置写入数据库
vlan#abort
放弃vlan数据库模式下的配置
跨交换机vlan配置
A.干线/中继(trunk
传输多vlan信息的链路
B.干线的条件
a.干线端口速率至少是百兆
b.干线介质速率至少是百兆
c.在干线端口上启用“干线功能”
d.在干线端口上配置“干线协议”
C.启用干线功能
a.config-if#switchport mode trunk
//把端口配置为干线端口,并发送DTP帧来声明自己为“干线端口”
DTP:动态干线协议
b.config-if#switchport mode dynamic desirable
//把端口配置为“主动协商端口”(默认模式),如果对方交换机的端口为干线端口,主动协商端口或被动协商端口,则把本端口设置为干线端口
c.config-if#switchport mode dynamic auto
//把端口配置为被动协商端口
端口角色:访问端口和干线端口
D.干线协议
a.ISL:属于cisoc私有属性,不推荐使用
//干线协议在原数据上加vlanID号的头,到达目的vlan在去掉头
image
image
b.802.1Q:通用协议,推荐使用(catalyst 2950默认协议)
image
干线协议的配置
config-if#switchport mode trunk
config-if#switchprot trunk encap dot1q/isl
 
E.跨交换机vlan的具体配置
Vtp服务器的配置
配置vtp
vlan#vtp domain 域名
配置vtp模式
vlan#vtp server
建立vlan
vlan#vlan vlan name vlan
vlan中添加成员
config-if#switchport mode access
config-if#switchport access vlan  vlan
配置干线
config-if#switchport mode trunk
config-if#switchprot trunk encap dot1q/isl
 
Vtp客户端配置
配置vtp
vlan#vtp domain 域名
配置vtp模式
vlan#vtp client
配置干线
config-if#switchport mode trunk
config-if#switchport trunk encap dot1q
vlan添加成员
config-if#switchport mode access
config-if#switchport access vlan vlan
 
6.Vlan间通信
通过物理路由器或三层交换机实现vlan间通信
image
通过路由器实现
路由器配置:
(config)#int f0/0
(config-if)#no shutdown
(config-if)#int f0/0.1
(config-subif)#encap 干线协议 vlan
(config-subif)#ip address ip地址 掩码
//ip地址:子接口IP地址不能在同一网段
子接口IP是其对应vlanPC的网关
子接口IP与其对应vlan内设备IP在同一网段
通过三层交换机实现
(config)#ip routing
(config)#ip cef
(config)#interface vlan vlan
(config-if)#ip address ip地址 掩码
(config-if)#no shutdown
1
image
 
7.Vlan类型
Vlan1
2层设备需要一个vlan作为端口归属
很多2层协议(如BPDUCDPVTPPAGPDTP)需要在一个特定vlan的中间链路上发送信息(以上协议总是通过vlan1传递,不能改变)
默认Vlan:也叫vlan1,默认vlan是交换机出厂时自带vlan
用户vlan:用户自建vlan
本地vlan:用于接收和发送通过中继的,没有打802.1Q标记的数据帧,也叫天然vlan
image
AB想通过中继线路与CD通信,必须设置为天然vlan,如果是普通线路,则可不用设置vlan
配置:switchport trunk native vlan vlan
建议:本地vlan不要用做用户vlan或管理vlan
管理vlan
需要telnetssh登录远端设备,则需要把这些设备放入管理vlan
配置:
(config)#int vlan 1
(config-if)#ip add rip 掩码
(config-if)#no shutdown
建议:管理vlan做成一个单独的vlan,独立于用户vlan,本地vlan

0

收藏

struggle1=1

92篇文章,140W+人气,6粉丝

Ctrl+Enter 发布

发布

取消

扫一扫,领取大礼包

0

6
分享
struggle1=1