在CentOS的LAMP下安装WHMCS程序的时候会出现提示:Site error: the file /***/index.php requires the ionCube PHP Loader ioncube_loader_lin_5.1.so to be installed by the site administrator.

这是为什么呢,因为页面用ioncube loader加密了的缘故。现在越多的人跳出了zend使用ioncube来加密php代码,所以必须得添加它来使我们能够使用我们想要的程序。当然,这也得是自己有能够修改服务器的权限。如自己的服务器,或者***。

首先,为了保险起见,登录root帐号,先执行

uname -a

查看系统是32位还是64位,然后再打开

http://www.ioncube.com/loaders.php

页面根据Linux是32位还是64位下载适当的软件包,比如我的是32位的,执行

cd /usr/local

切换到/usr/local/目录, 然后再下载选择的包

wget http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_x86.tar.gz

再执行

tar zxvf ioncube_loaders_lin_x86.tar.gz

解压软件包。

修改/usr/local/php/etc/php.ini 在文件尾部添加如下代码:



[ionCube Loader]
zend_extension="/usr/local/ioncube/ioncube_loader_lin_5.1.so"

如果以前装有Zend Optimizer,安装ionCube会和Zend Optimizer发生冲突,不过在添加代码的时候,将上面的添加到zend之前就好了。