在思科为中小型企业(SMBs)生产的产品线中,它为大家提供了一个免费的工具Cisco Network Assistant (CNA)来帮助大家配置思科的设备。当然,你可能会认为,这个目标直指中小型企业的工具对你来说并不一定适用,但是,要记住的是在思科的术语中,"中小型企业"可能是一个相当大的企业,至少在我的观点中是这样的。这个工具是免费的,因此,你可以从思科的网站上下载这个工具。从中小型的路由器,到650 0系列的Catalyst 交换机、PIX 防火墙、IP电话以及无线接入点等,CNA都支持。根据思科的意思,CNA对于那些最多有250个用户的企业来说是最理想的。
本人整理一些通过CNA软件来管理配置VLAN,VTP,Ethernet-Channel相关配置,希望给你有点帮助。
环境是:2台Cisco 3550 IOS:c3550-ipbasek9-mz[1].122-40.SE.bin,
要求是:Cisco3550-1是VTP Server,并创建VLAN10,20;Cisco3550-2是VTP Client,学习VLAN信息,并创建以太网通道(fa0/21,fa0/23).

一步:先基于Cisco3550-1 CNA命令行基本配置:(两台设备已经通交叉线相连,并分别给每台交换Vlan配置管理IP)
clip_image004
配置SNMP,设置团体字——test 读/写(一般情况只读权限)
clip_image006
Cisco 3550-2 CNA命令行配置:
clip_image008
clip_image010
二步:安装CNA软件,启动该软件,并在“应用程序”---“团体”,创建一个命令行相同的团体字,
clip_image012clip_image014
clip_image015
clip_image017
clip_image019
用户名:TEST 密码: wuqiang
clip_image021
clip_image023
clip_image025
clip_image026
通过团体字扫描并得到网络拓扑图和设备相关信息(IP地址,MAC地址,主机名)
clip_image028
clip_image030
实验要求是做Ethernet-Channel (以太网通道),链路接口物理特性应该相同(speed 100, duplex full , Trunk );
clip_image032
C3550-1是VTP Server 模式 ,域名是:huayu,创建vlan 10 ,vlan 20
clip_image034
clip_image036
clip_image037
clip_image039
clip_image041
clip_image043
clip_image045
clip_image047
接口速率,传输模式,VTP,VLAN信息配置完后,配置 以太网通道
clip_image049
通过CNA配置完成后,通过show running-config 查看配置信息。
C3550-1#show run
Building configuration...
Current configuration : 3643 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname C3550-1
!
enable password wuqiang
!
no aaa new-model
ip subnet-zero
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode dynamic desirable
!
interface FastEthernet0/1
switchport mode dynamic desirable
!
interface FastEthernet0/2
switchport mode dynamic desirable
!
interface FastEthernet0/3
switchport mode dynamic desirable
!
interface FastEthernet0/4
switchport mode dynamic desirable
!
。。。。。。。。。。。。。。。。。。。。。。。。。。
interface FastEthernet0/20
switchport mode dynamic desirable
!
interface FastEthernet0/21
switchport trunk encapsulation dot1q
switchport mode trunk
speed 100
duplex full
channel-group 1 mode on
!
interface FastEthernet0/22
switchport mode dynamic desirable
!
interface FastEthernet0/23
switchport trunk encapsulation dot1q
switchport mode trunk
speed 100
duplex full
channel-group 1 mode on
!
interface FastEthernet0/24
switchport mode dynamic desirable
!
interface GigabitEthernet0/1
switchport mode dynamic desirable
!
interface GigabitEthernet0/2
switchport mode dynamic desirable
!
interface Vlan1
ip address 192.168.1.2 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
snmp-server community test RO
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps transceiver all
snmp-server enable traps tty
snmp-server enable traps eigrp
snmp-server enable traps cluster
snmp-server enable traps entity
snmp-server enable traps envmon fan shutdown supply temperature status
snmp-server enable traps cpu threshold
snmp-server enable traps power-ethernet group 1
snmp-server enable traps power-ethernet police
snmp-server enable traps vtp
snmp-server enable traps vlancreate
snmp-server enable traps vlandelete
snmp-server enable traps flash insertion removal
snmp-server enable traps port-security
snmp-server enable traps bulkstat collection transfer
snmp-server enable traps config-copy
snmp-server enable traps config
snmp-server enable traps hsrp
snmp-server enable traps bridge newroot topologychange
snmp-server enable traps stpx inconsistency root-inconsistency loop-inconsistency
snmp-server enable traps syslog
snmp-server enable traps errdisable
snmp-server enable traps mac-notification
snmp-server enable traps mac-notification change move threshold
snmp-server enable traps vlan-membership
snmp-server host 192.168.1.254 test
!
control-plane
!
!
line con 0
line vty 0 4
password cisco
login
line vty 5 15
login
!
end
C3550-1#show vtp status
VTP Version : running VTP2
Configuration Revision : 20
Maximum VLANs supported locally : 1005
Number of existing VLANs : 7
VTP Operating Mode : Server
VTP Domain Name : huayu
VTP Pruning Mode : Enabled
VTP V2 Mode : Enabled
VTP Traps Generation : Enabled
MD5 digest : 0x77 0x9B 0x27 0xAF 0xEE 0x1C 0xC4 0xDE
Configuration last modified by 192.168.1.2 at 3-1-93 00:54:56
Local updater ID is 192.168.1.2 on interface Vl1 (lowest numbered VLAN interface found)
C3550-1#show etherchannel 1 port
Ports in the group:
-------------------
Port: Fa0/21
------------
Port state = Up Mstr In-Bndl
Channel group = 1 Mode = On Gcchange = -
Port-channel = Po1 GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = -
Age of the port in the current state: 0d:00h:53m:03s
Port: Fa0/23
------------
Port state = Up Mstr In-Bndl
Channel group = 1 Mode = On Gcchange = -
Port-channel = Po1 GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = -
Age of the port in the current state: 0d:00h:51m:21s
查看C3550-2基本配置信息:
C3550-2#show run
Building configuration...
Current configuration : 3667 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname C3550-2
!
enable password wuqiang
!
no aaa new-model
ip subnet-zero
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode dynamic desirable
!
interface FastEthernet0/1
switchport mode dynamic desirable
!
interface FastEthernet0/2
switchport mode dynamic desirable
!
interface FastEthernet0/3
switchport mode dynamic desirable
!
interface FastEthernet0/4
switchport mode dynamic desirable
。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。
interface FastEthernet0/19
switchport mode dynamic desirable
!
interface FastEthernet0/20
switchport mode dynamic desirable
!
interface FastEthernet0/21
switchport trunk encapsulation dot1q
switchport mode dynamic desirable
speed 100
duplex full
channel-group 1 mode on
!
interface FastEthernet0/22
switchport mode dynamic desirable
!
interface FastEthernet0/23
switchport trunk encapsulation dot1q
switchport mode dynamic desirable
speed 100
duplex full
channel-group 1 mode on
!
interface FastEthernet0/24
switchport mode dynamic desirable
!
interface GigabitEthernet0/1
switchport mode dynamic desirable
!
interface GigabitEthernet0/2
switchport mode dynamic desirable
!
interface Vlan1
ip address 192.168.1.3 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
snmp-server community test RO
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps transceiver all
snmp-server enable traps tty
snmp-server enable traps eigrp
snmp-server enable traps cluster
snmp-server enable traps entity
snmp-server enable traps envmon fan shutdown supply temperature status
snmp-server enable traps cpu threshold
snmp-server enable traps power-ethernet group 1
snmp-server enable traps power-ethernet police
snmp-server enable traps vtp
snmp-server enable traps vlancreate
snmp-server enable traps vlandelete
snmp-server enable traps flash insertion removal
snmp-server enable traps port-security
snmp-server enable traps bulkstat collection transfer
snmp-server enable traps config-copy
snmp-server enable traps config
snmp-server enable traps hsrp
snmp-server enable traps bridge newroot topologychange
snmp-server enable traps stpx inconsistency root-inconsistency loop-inconsistency
snmp-server enable traps syslog
snmp-server enable traps errdisable
snmp-server enable traps mac-notification
snmp-server enable traps mac-notification change move threshold
snmp-server enable traps vlan-membership
snmp-server host 192.168.1.254 test
!
control-plane
!
!
line con 0
line vty 0 4
password cisco
login
line vty 5 15
login
!
end
C3550-2# show vtp status
VTP Version : running VTP2
Configuration Revision : 20
Maximum VLANs supported locally : 1005
Number of existing VLANs : 7
VTP Operating Mode : Client
VTP Domain Name : huayu
VTP Pruning Mode : Enabled
VTP V2 Mode : Enabled
VTP Traps Generation : Enabled
MD5 digest : 0x77 0x9B 0x27 0xAF 0xEE 0x1C 0xC4 0xDE
Configuration last modified by 192.168.1.2 at 3-1-93 00:54:56
C3550-2#show int port-channel 1
Port-channel1 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 000d.bdec.3117 (bia 000d.bdec.3117)
MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, media type is 10/100BaseTX
input flow-control is off, output flow-control is unsupported
Members in this channel: Fa0/21 Fa0/23
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:05, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 1000 bits/sec, 2 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
5625 packets input, 484342 bytes, 0 no buffer
Received 4912 broadcasts (0 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 4903 multicast, 0 pause input
0 input packets with dribble condition detected
1376 packets output, 399834 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out
C3550-2#show por
C3550-2#show port-ch
C3550-2#show int por
C3550-2#show int port-c
C3550-2#show int port-channel ?
<1-64> Port-channel interface number
C3550-2#show int port-channel 1 ?
accounting Show interface accounting
capabilities Show interface capabilities information
controller Show interface status, configuration and controller status
counters Show interface counters
crb Show interface routing/bridging info
dampening Show interface dampening info
debounce Show interface debounce time info
description Show interface description
etherchannel Show interface etherchannel information
fair-queue Show interface Weighted Fair Queueing (WFQ) info
flowcontrol Show interface flowcontrol information
irb Show interface routing/bridging info
mac-accounting Show interface MAC accounting info
mpls-exp Show interface MPLS experimental accounting info
mtu Show interface mtu
precedence Show interface precedence accounting info
private-vlan Show interface private vlan information
pruning Show interface trunk VTP pruning information
random-detect Show interface Weighted Random Early Detection (WRED) info
rate-limit Show interface rate-limit info
stats Show interface packets & octets, in & out, by switching path
status Show interface line status
summary Show interface summary
switchport Show interface switchport information
transceiver Show interface transceiver
trunk Show interface trunk information
vlan Show interface vlan information
| Output modifiers
<cr>
 
C3550-2#show int port-channel 1 status
Port Name Status Vlan Duplex Speed Type
Po1 connected trunk a-full a-100
C3550-2#show int port-channel 1 summary
*: interface is up
IHQ: pkts in input hold queue IQD: pkts dropped from input queue
OHQ: pkts in output hold queue OQD: pkts dropped from output queue
RXBS: rx rate (bits/sec) RXPS: rx rate (pkts/sec)
TXBS: tx rate (bits/sec) TXPS: tx rate (pkts/sec)
TRTL: throttle count
Interface IHQ IQD OHQ OQD RXBS RXPS TXBS TXPS TRTL
-------------------------------------------------------------------------
* Port-channel1 0 0 0 0 1000 2 0 0 0
C3550-2# show etherchannel 1 port-channel
C3550-2# show etherchannel 1 port-channel
Port-channels in the group:
---------------------------
Port-channel: Po1
------------
Age of the Port-channel = 0d:00h:49m:05s
Logical slot/port = 1/0 Number of ports = 2
GC = 0x00000000 HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = -
Port security = Disabled
Ports in the Port-channel:
Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Fa0/21 On 0
0 00 Fa0/23 On 0
Time since last port bundled: 0d:00h:44m:08s Fa0/21
Time since last port Un-bundled: 0d:00h:44m:11s Fa0/23