拓扑图如下:

路由器R0作为设备内网路由器出口 R1为外网路由器

路由器R0的配置如下:

hostname Router
!
!
!
!
ip dhcp excluded-address 192.168.100.1 192.168.100.10
!
ip dhcp pool zxf
 network 192.168.100.0 255.255.255.0
 default-router 192.168.100.1
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.100.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 200.200.200.2 255.255.255.252
 ip nat outside
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 100
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
ip nat pool hello 200.200.200.2 200.200.200.2 netmask 255.255.255.252
ip nat inside source list 1 pool hello overload
ip nat inside source static tcp 192.168.100.3 23 200.200.200.2 23
ip nat inside source static tcp 192.168.100.11 80 200.200.200.2 8080
ip nat inside source static tcp 192.168.100.4 80 200.200.200.2 9999
ip classless
ip route 0.0.0.0 0.0.0.0 200.200.200.1
!
!
access-list 1 permit 192.168.100.0 0.0.0.255
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!

 

路由器R1配置如下:

interface FastEthernet0/0
 ip address 200.200.200.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 100.100.100.100 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 100
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
ip classless
!!!!!!!!!!!!!!

详细配置见附件: