拓扑:
 
R1配置:
 
R1#sh run
Building configuration...
Current configuration : 1099 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!        
!        
!        
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!        
interface Loopback1
 ip address 100.100.100.100 255.255.255.0
!        
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!        
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!        
interface Ethernet0/2
 ip address 192.168.12.1 255.255.255.0
 half-duplex
!        
interface Ethernet0/3
 ip address 192.168.13.1 255.255.255.0
 half-duplex
!        
router eigrp 90
 redistribute ospf 110 metric 10000 100 255 1 1500
 network 1.1.1.0 0.0.0.255
 network 192.168.13.0
 auto-summary
!        
router ospf 110
 log-adjacency-changes
 redistribute eigrp 90 subnets
 network 100.100.100.0 0.0.0.255 area 0
 network 192.168.12.0 0.0.0.255 area 0
!        
ip http server
!        
!        
!        
!        
!        
control-plane
!        
!        
!         
      
!        
!        
!        
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!        
!        
end      
         
 
 
 
R2配置:
R1#sh run
Building configuration...
Current configuration : 1099 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!        
!        
!        
!        
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!        
interface Loopback1
 ip address 100.100.100.100 255.255.255.0
!        
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!        
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!        
interface Ethernet0/2
 ip address 192.168.12.1 255.255.255.0
 half-duplex
!        
interface Ethernet0/3
 ip address 192.168.13.1 255.255.255.0
 half-duplex
!        
router eigrp 90
 redistribute ospf 110 metric 10000 100 255 1 1500
 network 1.1.1.0 0.0.0.255
 network 192.168.13.0
 auto-summary
!        
router ospf 110
 log-adjacency-changes
 redistribute eigrp 90 subnets
 network 100.100.100.0 0.0.0.255 area 0
 network 192.168.12.0 0.0.0.255 area 0
!        
ip http server
!        
!        
!        
!        
!        
control-plane
!        
!        
!         
   
!        
!        
!        
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!        
!        
end      
         
 
 
R3配置:
R3#sh run
Building configuration...
Current configuration : 819 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!

!        
!        
!        
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!        
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!        
interface Ethernet0/1
 ip address 192.168.13.3 255.255.255.0
 half-duplex
!        
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!        
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!        
router eigrp 90
 network 3.3.3.0 0.0.0.255
 network 192.168.13.0
 auto-summary
!        
ip http server
!        
!        
!        
!        
!        
control-plane
!        
!        
!         
   
!        
!        
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!        
!        
end      
 
实验验证:
 
r1上show ip route
 
C    192.168.12.0/24 is directly connected, Ethernet0/2
     1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       1.1.1.0/24 is directly connected, Loopback0
D       1.0.0.0/8 is a summary, 00:13:16, Null0
C    192.168.13.0/24 is directly connected, Ethernet0/3
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/11] via 192.168.12.2, 00:08:10, Ethernet0/2
     100.0.0.0/24 is subnetted, 1 subnets
C       100.100.100.0 is directly connected, Loopback1
D    3.0.0.0/8 [90/409600] via 192.168.13.3, 00:12:48, Ethernet0/3
 
 
r2上:
C    192.168.12.0/24 is directly connected, Ethernet0/1
     1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O E2    1.1.1.0/24 [110/20] via 192.168.12.1, 00:08:38, Ethernet0/1
O E2    1.0.0.0/8 [110/20] via 192.168.12.1, 00:08:38, Ethernet0/1
O E2 192.168.13.0/24 [110/20] via 192.168.12.1, 00:08:38, Ethernet0/1

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     100.0.0.0/32 is subnetted, 1 subnets
O       100.100.100.100 [110/11] via 192.168.12.1, 00:08:38, Ethernet0/1
O E2 3.0.0.0/8 [110/20] via 192.168.12.1, 00:08:38, Ethernet0/1
 
 
r3上:

D EX 192.168.12.0/24 [170/307200] via 192.168.13.1, 00:10:14, Ethernet0/1
D    1.0.0.0/8 [90/409600] via 192.168.13.1, 00:13:36, Ethernet0/1
C    192.168.13.0/24 is directly connected, Ethernet0/1
     2.0.0.0/32 is subnetted, 1 subnets
D EX    2.2.2.2 [170/307200] via 192.168.13.1, 00:10:14, Ethernet0/1
     100.0.0.0/24 is subnetted, 1 subnets
D EX    100.100.100.0 [170/307200] via 192.168.13.1, 00:10:14, Ethernet0/1
     3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C       3.3.3.0/24 is directly connected, Loopback0
D       3.0.0.0/8 is a summary, 00:13:38, Null0
红色即为通过重分布在ospf(eigrp)中看到eigrp(ospf)的路由。