Eclipse Velocity 插件目前比较多,但是已经没有人维护了:

 

http://veloeclipse.googlecode.com/svn/trunk/update/ 

http://veloedit.sourceforge.net/updates/

 

 

Eclipse 4.4发布后,上述的Velocity Plugin均不兼容,报错如下:

 

Java代码  收藏代码

  1. An error occurred while installing the items  

  2. session context was:(profile=epp.package.standard, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]org.apache.velocity 1.7.0, action=).  

  3. Failed to prepare partial IU: [R]org.apache.velocity 1.7.0.  

 

 


 

针对以上错误,基于veloeclipse重新编译了兼容4.x的插件,下载地址如下:

 

http://plugin.tqlab.com/eclipse/velocityeditor/update/

即:update site: http://plugin.tqlab.com/eclipse/velocityeditor/update/


原文出处:http://sculijun.iteye.com/blog/2096051