官方文档要求Linux kernel至少3.8以上,且docker只能运行在64位的系统中。由于RHEL6和CentOS6的内核版本为2.6,因此必须要先升级内核。


一、升级内核(带aufs模块)

1、yum安装带aufs模块的3.10内核

cd /etc/yum.repos.d 

wget http://www.hop5.in/yum/el6/hop5.repo

yum install kernel-ml-aufs kernel-ml-aufs-devel

2、修改grub的主配置文件/etc/grub.conf,设置default=0,表示第一个title下的内容为默认启动的kernel


3、重启系统,这时候你的内核就成功升级了。

[root@localhost ~]# uname -r

3.10.5-3.el6.x86_64

查看内核是否支持aufs:

[root@localhost ~]# grep aufs /proc/filesystems

nodev    aufs



二、安装docker

1、首先关闭selinux:

setenforce 0

sed -i '/^SELINUX=/c\SELINUX=disabled' /etc/selinux/config

2、在Fedora EPEL源中已经提供了docker-io包,下载安装epel:

rpm -ivh http://mirrors.sohu.com/fedora-epel/6/x86_64/epel-release-6-8.noarch.rpm

sed -i 's/^mirrorlist=https/mirrorlist=http/' /etc/yum.repos.d/epel.repo


3、yum安装docker-io:

yum -y install docker-io

4、启动docker:

service docker start

5、查看docker版本:

docker version

   查看docker日志:

cat /var/log/docker


至此docker安装成功