试题一(15分)
阅读以下说明,回答问题1至问题3,将解答填入答题纸对应的解答栏内。
【说明】
某单位有1个总部和6个分部,各个部门都有自己的局域网。该单位申请了6CIP地址202.115.10.0/24~202.115.15.0/24,其中总部与分部4共用一个C类地址。现计划将这些部门用路由器互联,网络拓扑结构如图1-1所示。

1
【问题1】(4分)
该网络采用R1R77台路由器,采用动态路由协议OSPF。由图1-1可见,该网络共划分了3OSPF区域,其主干区域为1,主干区域中,2为区域边界路由器,3为区域内路由器。
【问题2】(7分)
1-1是该系统中路由器的IP地址分配表。

1-1

路由器
端口IP地址
路由器
端口IP地址
路由器
端口IP地址
R1
EO:202.115.10.1/24
R4
EO:202.115.12.1/24
R6
EO:202.115.14.1/24
SO:10.0.0.1/24
SO:10.0.3.2/24
SO:10.0.6.1/24
S1:10.0.1.1/24
S1:10.0.5.1/24
S1:10.0.7.1/24
R2
EO:202.115.11.1/24
R5
EO:202.115.13.1/25
R7
EO:202.115.15.1/24
SO:10.0.0.2/24
SO:10.0.3.1/24
SO:10.0.6.2/24
S1:10.0.2.1/24
SI:10.0.4.1/24
S1:10.0.8.1/24
请根据图1-1完成以下R3路由器的配置:
R3 (config)#interface e0/1
(进入接口e0/1配置模式)
R3 (config-if)#ip address 202.115.13.254
4)(设置IP地址和掩码)
R3(config) # interface s0/0
(进入串口配置模式)
R3(config-if) #ip address
5255.255.255.0(设置IP地址和掩码)
R3(config) # interface s0/1
R3(config-if) #ip address
6255.255.255.0
R3(config) # interface s0/2
R3(config-if) #ip address
7255.255.255.0
R3(config) # interface s0/3
R3(config-if) #ip address
8255.255.255.0
R3(config) # interface s0/4
R3(config-if) #ip address
9255.255.255.0
R3(config) # interface s0/5
R3(config-if) #ip address
10255.255.255.0
【问题3】(4分)
该单位部门4共有110PC机,通过交换机连接路由器R5接入网络。其中一台PCIP地址为202.115.13.5,则其子网掩码应为11,网关地址应为12
试题二(15分)
阅读下列说明,回答问题1至问题6,将解答填入答题纸对应的解答栏内。
【说明】
某公司的两个部门均采用Windows 2003NAT功能共享宽带连接访问Internet其网络结构和相关参数如图2-1所示。ISP为该公司分配的公网IP地址段为202.117.12.32/29

2

【问题1】(2分)
Windows 2003中,1不能实现NAT功能。
备选答案:
A.
终端服务管理器B. Internet连接共享C.路由和远程访问
\
3
【问题2】(4分)

在图2-2所示的窗口中,为部门B的服务器2配置路由和远程访问功能,新增eth0eth1上的网络连接。eth0上的网络连接应该选中图2-3中的2选项进行配置, eth1上的网络连接应该选中图2-3中的3选项进行配置。
2)、(3)备选答案:
A.
专用接口连接到专用网络
B.
公用接口连接到Internet
C.
仅基本防火墙

【问题3】(2分)
部门B中主机PC1的默认网关地址应配置为4才能访问Internet
【问题4】(2分)
在部门B的服务器2中,如果将ISP分配的可用公网IP地址添加到地址池(如图2-4所示),那么服务器1收到来自部门B的数据包的源地址可能是5。如果部门B中两台不同PC机同时发往公网的两个数据包的源地址相同,则它们通过6相互区分。
3
【问题5】(2分)
在服务器2eth1上启用基本防火墙,如果希望将202.117.12.38固定分配给IP为地址192.168.2.10FTP服务器,且使得公网中主机可以访问部门B中的FTP图服务,应该在2-4和图2-5所示的对话框中如何配置?
【问题6】(3分)
为了实现部门A和部门B中主机互相通信,在服务器1和服务器2上都运行了路由和远程访问服务,在图2-6所示的对话框中,两台服务器的静态路由信息应配置为:

主机
接口
目标
网络掩码
网关
跃点数
服务器1
WAN连接
7
8
9
1
服务器2
WAN连接
10
11
12
1
4
2-6
试题三(15分)

阅读以下关于在Linux系统中配置Apache服务器的说明,回答问题1至问题3,将解答填入答题纸对应的解答栏内。
【说明】
Linux系统中采用Apache配置Web服务器。Apache服务器提供了丰富的功能,包括目录索引、目录别名、虚拟主机、HTTP日志报告、CGI程序的SetUID执行等。

【问题1】(6分)
请在(1)、(2)、(3)、(4)空白处填写恰当的内容。
Web
客户机与服务器共同遵守1协议,其工作过程是:Web的客户端程序根据输入的2连接到相应的Web服务器上,并获得指定的Web文档。动态网页以3程序的形式在服务器端处理,并给客户端返回4格式的文件。
1)~(4)的备选项
A. HTML B. ASP C. JSP D. IIS
E. SOAP F. URL G. HTTP H. VGA
【问题2】(7分)
请在(5)~(11)空白处填写恰当的内容。
Apache
的主配置文件为httpd.conf。某Web服务器的httpd.conf文件部分内容如下:
ServerType standalone
ServerRoot “/etc/httpd”
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 15
MinSpareServers 5
MaxSpareServers 20
StartServers 8
MaxClients 150
MaxRequestsPerChild 100
Port 8080
User nobody
Group nobody
ServerAdmin root@webtest.com.cn
ServerName WebTest
DocumentRoot “/home/webtest/jakarta-tomcat/webapps/webtest”
Options FollowSymLinks
AllowOverride None
Options Indexes Includes FollowSymLinks
AllowOverride None
Order allow, deny
Allow from all
DirectoryIndex index.html index.htm index.shtml index.cgi
Alias /doc/ /usr/doc/
order deny, allow
deny from all
allow from localhost
Options Indexes FollowSymLinks
RPM方式安装的Apache服务器,配置文件httpd.conf存储在Linux5目录下。根据上述配置文件,该Web服务器运行在6模式下,其运行效率比在inetd模式下7;当某个Web连接超过8秒没有数据传输时,系统断开连接。
如果客户需要访问Linux服务器上/usr/doc目录,则应在浏览器地址栏中输入9
虚拟主机是指在同一台服务器上实现多个Web站点。虚拟主机可以是基于IP地址的虚拟主机,也可以是基于10的虚拟主机。创建基于10的虚拟主机时,还需要配置11,并在区数据库文件中添加相关记录。
【问题3】(2分)
3-1是配置Apache服务器的一个窗口,选中目录选项ExecCGI,意味着什么?
如果将图3-1所示的目录选项中Indexes相关的选中状态取消,并且虚拟主机目录中也没有Index文件,客户机通过浏览器访问有关的虚拟主机目录时有何后果?
5
试题四(15分)
阅读以下说明,回答问题1至问题4,将解答填入答题纸对应的解答栏内。
【说明】
某公司采用100M宽带接入Internet,公司内部有15PC机,要求都能够上网。另外有2台服务器对外分别提供WebE-mail服务,采用防火墙接入公网,拓扑结构如图4-1所示。

5
【问题1】(2分)
如果防火墙采用NAPT技术,则该单位至少需要申请1个可用的公网地址。
【问题2】(3分)
下面是防火墙接口的配置命令:
fire(config)# ip address outside 202.134.135.98 255.255.255.252
fire(config)# ip address inside 192.168.46.1 255.255.255.0
fire(config)# ip address dmz 10.0.0.1 255.255.255.0
根据以上配置,写出图4-1中防火墙各个端口的IP地址:

e0
2
e1
3
e2
4
【问题3】(4分)
1
ACL默认执行顺序是5,在配置时要遵循6原则、以最靠近受控对象原则、及默认丢弃原则。
5)、(6)备选项
A)最大特权(B)最小特权(C)随机选取
D)自左到右(E)自上而下(F)自下而上
2
.要禁止内网中IP地址为198.168.46.8PC机访问外网,正确的ACL规则是7
Aaccess-list 1 permit ip 192.168.46.0 0.0.0.255 any
access-list 1 deny ip host 198.168.46.8 any
B
access-list 1 permit ip host 198.168.46.8 any
access-list 1 deny ip 192.168.46.0 0.0.0.255 any
C
access-list 1 deny ip 192.168.46.0 0.0.0.255 any
access-list 1 permit ip host 198.168.46.8 any
D
access-list 1 deny ip host 198.168.46.8 any
access-list 1 permit ip 192.168.46.0 0.0.0.255 any
【问题4】(6分)

下面是在防火墙中的部分配置命令,请解释其含义:
global (outside) 1 202.134.135.98-202.134.135.100
8

conduit permit tcp host 202.134.135.99 eq www any
9
access-list 10 permit ip any any
10
试题五(15分)
阅读以下说明,回答问题1至问题3,将解答填入答题纸对应的解答栏内。
【说明】
某公司租用了一段C类地址203.12.11.0/24203.12.14.0/24,如图5-1所示。其网间地址是172.11.5.14/24。要求网内所有PC都能上网。

6
【问题1】(8分)
接入层交换机Switch1的端口24trunk口,其余各口属于vlan11,请解释下列命令并完成交换机的配置。
Switch1#config terminal
Switch1(config)#interface f0/24
(进入端口24配置模式)
Switch1(config-if)# switchport mode trunk
1
Switch1 (config-if)#switchport trunk encapsulation dotlq
2
Switch1(config-if)# switchport trunk allowed all
(允许所有VLAN从该端口交换数据)
Switch1(config-if)#exit
Switch1(config)#exit
Switch1# vlan database
Switch1(vlan)# vlan 11 name lab01
3
Switch1(vlan)#exit
Switch1#config terminal
Switch1(config)#interface f0/9
(进入f0/9的配置模式)
Switch1(config-if)#
4(设置端口为接入链路模式)
Switch1(config-if)#
5(把f0/9分配给VLAN11
Switch1(config-if)#exit
Switch1(config)#exit
【问题2】(3分)
以下两个配置中错误的是6,原因是7
A

Switch0 (config)#interface gigabitEthernet 0/3
Switch0 (config-if)#switchport mode trunk
Switch0 (config-if)#switchport trunk encapsulation dot1q
Switch0(config)#exit
Switch0# vlan database
Switch0(vlan)# vlan 2100 name lab02
B

Switch0 (config)#interface gigabitEthernet 0/3
Switch0 (config-if)#switchport mode trunk
Switch0 (config-if)#switchport trunk encapsulation ISL
Switch0(config)#exit
Switch0# vlan database
Switch0(vlan)# vlan 2100 name lab02
【问题3】(4分)

Switch1
f0/24口接在Switch0f0/2口上,请根据图5-1完成或解释以下Switch0的配置命令。
Switch0(config)# interface
8(进入虚子接口)
Switch0(config-if)# ip address 203.12.12.1 255.255.255.0
(加IP地址)
Switch0(config-if)# no shutdown
9
Switch0(config-if)# standby 1 ip 203.12.12.253
(建HSRP组并设虚IP地址)
Switch0(config-if)# standby 1 priority 110
10
Switch0(config-if)# standby 1 preempt
11