DHCP中继配置

 

1、  实验目的:

通过本次的实验,我们可以掌握通过DHCP中继实现跨网络的DHCP服务。

 

2、  实验拓扑图:

   clip_image002

 

3、  实验内容:

(1)       在路由器R1上配置DHCP服务

   R1config#interface s0/0

   R1config-if#ip address 192.168.12.1 255.255.255.

   R1config-if#no shutdown

R1config#interface g0/0

R1config-if#ip address 192.168.1.1 255.255.255.0

R1config-if#no shutdown

R1config#router rip

R1config-router#version 2

R1config-router#no autosummary

R1config-router#network 192.168.1.0

R1config-router#network 192.168.12.0

R1config#server dhcp 

R1config#no ip dhcp conflict logging  

 

定义第一个地址段

R1config# ip dhcp pool xia1 

R1config#network 192.168.1.0/24  

R1dhcp-config#domain-name benet.com 

R1dhcp-config#default-router 192.168.1.1

R1dhcp-config#netbios-name-server 192.168.1.2

R1dhcp-config#dns server 192.168.1.4 

R1dhcp-config#option 150 ip 192.168.1.3 

R1dhcp-config#lease infinite 

R1config#ip dhcp excluded-address 192.168.1.1 192.168.1.5 

 

定义第二个地址段

R1config# ip dhcp pool xia1 

R1config#network 192.168.2.0/24  

R1dhcp-config#domain-name benet.com 

R1dhcp-config#default-router 192.168.2.1

R1dhcp-config#netbios-name-server 192.168.2.2

R1dhcp-config#dns server 192.168.2.4 

R1dhcp-config#option 150 ip 192.168.2.3 

R1dhcp-config#lease infinite 

R1config#ip dhcp excluded-address 192.168.2.1 192.168.2.5 

 

 

(2)       配置路由器R2

   R2(config)#interface s0/0

   R2(config-if)#ip address 192.168.12.2 255.255.255.0

   R2(config-if)#no shutdown

   R2(config)#interface g0/0

   R2(config-if)#ip address 192.168.2.1 255.255.255.0

   R2(config-if)#ip helper-address 192.168.12.1

   R2(config-if)#no shutdown

   R2(config)#router rip

   R2(config-router)#version 2

   R2(config-router)#no auto-summary

   R2(config-router)#network 192.168.12.0

   R2(config-router)#network 192.168.2.0

 

(3)接下来,我们可以在pc1 pc2 上启用自动获取IP地址,我们可以使用ipconfig/all来查看我们的计算机获取IP地址的情况了。

 

 

 

DHCP命令汇总

命令

作用

Show ip dhcp pool

查看DHCP地址池的信息

Show ip dhcp binding

查看DHCP地址池的绑定信息

Show ip dhcp database

查看DHCP数据库

Show ip Interface

查看接口信息

Debug ip dhcp server events

查看DHCP服务器的事件

Server dhcp

开启dhcp服务

No ip dhcpconflict logging

关闭DHCP冲突日志

Ip dhcp pool

配置dhcp分配的地址池

Network

Dhcp服务器要分配的网络和掩码

Default-router

默认网关

Domain-name

域名

NetBIOS-name-server

Wind服务器

Dns-server

域名服务器

Option 150 ip

ftp服务器

Lease

配置租期

Ip dhcp excluded-address

排除地址段

Ip helper-address

配置dhcp中继的地址