静态和动态NAT的配置

1、  实验目的:

通过本次实验我们可以掌握如下技能

1)        静态NAT的特征   

2)        静态NAT 的基本配置

2、  实验拓扑图:

clip_image002

3、  实验内容:

(1)       路由器R1的配置

R1(config)#interface s0/0

R1(config-if)#ip address 192.168.2.1 255.255.255.0

R1(confiif)#clock rate 128000

R1(config-if)#no shutdown

R1(config)#ip nat inside source static 192.168.1.2 192.168.2.2

R1(config)#ip nat inside source static 192.168.1.3 192.168.2.3

R1(config)#interface s0/0

R1(configif)#ip nat outside

R1(config)#interface g0/0

R1(config-if)#ip nat inside

R1(config)#router rip

R1(config-router)#version 2

R1(config-router)#no auto-summary

R1(config-router)#network 192.168.2.0

 

(2)       路由器R2的配置

R2(config)#interface s0/0

R2(config-if)#ip address 192.168.2.2 255.255.255.0

R2(config-if)#no shutdown

R2(config)#router rip

R2(config-router)#version 2

R2(config-router)#no auto-summary

R2(config-router)#network 192.168.2.0

 

接下来我们就可以使用show ip nat translations来查看我们的配置情况了。

 

 

接下来我们来学习动态NAT的配置。

实验拓扑图和静态的拓扑图一样,我们只介绍一下动态NAT的配置

R1上进行动态NAT的配置如下:

R1config#ip nat pool NAT 192.168.2.1 192.168.2..5 netmask 255.255.255.0

//配置动态NAT转换的地址池

R1config#ip nat inside source list 1 pool nat

//配置动态NAT映射

R1config#access-list permit 192.168.1.0.0.0.0.255

R1config#interface s0/0

R1config-if#ip nat outside

R1config#interface g0/0

R1config-if#ip nat inside

 

 

NAT配置命令汇总

命令

作用

Clear ip nat translations

清除动态NAT

Show ip nat translation

查看NAT

Show ip nat statics

查看NAT的转换信息

Debug ip nat

动态查看NAT的转换工程

Ip nat inside source static

配置静态NAT

Ip nat inside

在内部启用

Ip nat outside

在外边启用

Ip nat pool

配置动态NAT地址池

IP nat inside source list access-list-number pool name

配置动态NAT

Ip nat inside source list access-list-number pool

 Name overload

配置PAT