帧中继上的RIP配置

1、  实验目的:

通过本次是实验,我们可以掌握如下技能

1)        帧中继上路由协议运行的特殊性

2)        水平分割问题

2、  实验拓扑图:

clip_image002

3、  实验步骤:

(1)       根据上一个实验的配置结果,继续进行这次实验,请先访问http://lorna8023.blog.51cto.com/777608/241090

(2)       在帧中继上配置RIP,具体的配置如下:

R1(config)#interface loopback 0

R1(config-if)#ip address 1.1.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#exit

R1(config)#interface serial 0/1

R1(config-if)#ip address 192.168.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config)#router rip

R1(config-router)#network 1.0.0.0

R1(config-router)#network 192.168.1.0

R1(config-router)#

 

 

 

R3(config)#interface loopback 0

R3(config-if)#ip address 3.3.3.3 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#exit

R3(config)#interface serial serial 0/2

R3(config-if)#ip address 192.168.1.2 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#exit

R3(config)#router rip

R3(config-router)#network 3.3.3.0

R3(config-router)#network 192.168.1.0

R3(config-router)#

 

 

R4(config)#interface loopback 0

R4(config-if)#ip address 4.4.4.4 255.255.255.0

R4(config-if)#no shutdown

R4(config-if)#exit

R4(config)#interface serial 0/3

R4(config-if)#ip address 192.168.1.3 255.255.255.0

R4(config-if)#no shutdown

R4(config-if)#exit

R4(config)#router rip

R4(config-router)#network 4.0.0.0

R4(config-router)#net

R4(config-router)#network 192.168.1.0

R4(config-router)#

 

(3)       测试配置情况

查看路由表,结果如下:

R1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     1.0.0.0/24 is subnetted, 1 subnets

C       1.1.1.0 is directly connected, Loopback0

R    3.0.0.0/8 [120/1] via 192.168.1.2, 00:00:19, Serial0/1

R    4.0.0.0/8 [120/1] via 192.168.1.3, 00:00:22, Serial0/1

C    192.168.1.0/24 is directly connected, Serial0/1

R1#

通过RIP学习到了,动态路由。

 

R1#show ip interface serial 0/1

Serial0/1 is up, line protocol is up

  Internet address is 192.168.1.1/24

  Broadcast address is 255.255.255.255

  Address determined by setup command

  MTU is 1500 bytes

  Helper address is not set

  Directed broadcast forwarding is disabled

  Multicast reserved groups joined: 224.0.0.9

  Outgoing access list is not set

  Inbound  access list is not set

  Proxy ARP is enabled

  Security level is default

  Split horizon is disabled   //默认情况下水平分割是关闭的。

  ICMP redirects are always sent

  ICMP unreachables are always sent

  ICMP mask replies are never sent

  IP fast switching is enabled

  IP fast switching on the same interface is enabled

  IP Flow switching is disabled

  IP CEF switching is disabled

  IP Fast switching turbo vector

  IP multicast fast switching is enabled

  IP multicast distributed fast switching is disabled

 --More—

我们可以打开水平分割,我们可以进行如下配置。

R3上打开水平分割,配置命令如下:

R3(config)#interface serial 0/2

R3(config-if)#ip split-horizon

R3#clear ip route

R3#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

R    1.0.0.0/8 [120/1] via 192.168.1.1, 00:00:28, Serial0/2

     3.0.0.0/24 is subnetted, 1 subnets

C       3.3.3.0 is directly connected, Loopback0

R    4.0.0.0/8 [120/2] via 192.168.1.1, 00:00:28, Serial0/2   //R3可以获得R1R4的回环路由。

C   

 

 

OK 本次实验结束!!!!!!!!!!