端口聚合也叫做以太通道(ethernet channel),主要用于交换机之间连接。由于两个交换机之间有多条冗余链路的时候,STP会将其中的几条链路关闭,只保留一条,这样可以避免二层的环路产生。但是,失去了路径冗余的优点,因为STP的链路切换会很慢,在50s左右。使用以太通道的话,交换机会把一组物理端口联合起来,做为一个逻辑的通道,也就是channel-group,这样交换机会认为这个逻辑通道为一个端口。这样有几个优点: 1. 带宽增加,带宽相当于组成组的端口的带宽总和。2. 增加冗余,只要组内不是所有的端口都down掉,两个交换机之间仍然可以继续通信。3. 负载均衡,可以在组内的端口上配置,使流量可以在这些端口上自动进行负载均衡。
  在用的时候要注意:端口要在一个vlan里面,两边的全双工模式要一样,还有就是作用的端口个数不能是3和6,而且不能超过8个,比如:2,4,8。
  交换机端口聚合配置方法:
  实验名称:
  交换机端口聚合。
  实验目的:
  理解交换机端口聚合(IEEE 802.3ad)的原理及配置。
  实现功能:
  增加交换机之间的传输带宽,并实现链路冗余备份。
  实验设备
  锐捷S2126交换机2台(华为S3026),网线4根。
  实验步骤:
  华为交换机上的配置:
  交换机1的配置:
  switch>system    //进入配置模式;
  [Quidway]sysname Switch 1   //给交换机命名;
  [switch1]interface ethernet0/1  //进入e0/1端口;
  [Switch 1-Ethernet0/1]duplex full
  [Switch 1-Ethernet0/1]speed 100
  [Switch 1-Ethernet0/1]port link-type trunk
  [Switch 1-Ethernet0/1]port trunk permit vlan all
  [Switch 1-Ethernet0/1]quit
  [switch1]interface ethernet0/2
  [Switch 1-Ethernet0/2]duplex full
  [Switch 1-Ethernet0/2]speed 100
  [Switch 1-Ethernet0/2]port link-type trunk
  [Switch 1-Ethernet0/2]port trunk permit vlan all
交换机2的配置:
  switch>system
  [Quidway]sysname Switch2
  [Switch2]interface ethernet0/1
  [Switch2-Ethernet0/1]duplex full
  [Switch2-Ethernet0/1]speed 100
  [Switch2-Ethernet0/1]port link-type trunk
  [Switch2-Ethernet0/1]port trunk permit vlan all
  [Switch2-Ethernet0/1]int e0/2
  [Switch2-Ethernet0/2]duplex full
  [Switch2-Ethernet0/2]speed 100
  [Switch2-Ethernet0/2]port link-type trunk
  [Switch2-Ethernet0/2]port trunk permit vlan all
  聚合操作:
  [Switch1]link-aggregation ethernet0/1 to ethernet0/2 both
  [Switch2]link-aggregation ethernet0/1 to ethernet0/2 both
  [Switch1]display link-aggregation ethernet0/1
  [Switch1]undo link-aggregation all
  交换机1上:
  [Switch1]vlan 10
  [Switch1-vlan10]port e0/5
  交换机2上:
  [Switch1]vlan 10
  [Switch1-vlan10]port e0/5
  PCA上:
  [root@PCA root]#ifconfig eth0 192.168.1.1 netmask 255.255.255.0
  [root@PCA root]#route add default gw 192.168.1.254
  PCB上:
  [root@PCA root]#ifconfig eth0 192.168.1.2 netmask 255.255.255.0
  [root@PCA root]#route add default gw 192.168.1.254
  在一台计算机上Ping另一台计算机,看能否Ping通。
  断开交换机上一条线路,在一台计算机上Ping另一台计算机,看能否Ping通。
  合上交换机的这条线路,断开另一条线路,,看能否Ping通。