广域网(WAN)技术,是一种将私有(保留)地址转化为合法IP地址的转换技术,它被广泛应用于各种类型Internet接入方式和各种类型的网络中。原因很简单,NAT不仅完美地解决了lP地址不足的问题,而且还能够有效地避免来自网络外部的***,隐藏并保护网络内部的计算机
 
 三种NAT转发方法:
    一、静态NAT转发:一对一转发
    二、地址池转发:多个公网IP对应多个内网IP转发
    三、重载PER转发:单个内部网段指定外部端口转发
     
    环境:
      接口
        作用
         IP
    F0 /0
        外网
     10.10.10.10
    F0 /1
        内网
     192.168.0.1
     
     
    格式:
    必要要指定网络的出入端口NAT才有效
    注意:要进入指定端口进行配置
    Router(config-if)#ip nat outside
    指定端口为外网
    Router(config-if)#ip nat inside
    指定端口为内网
     
    静态NAT转发格式:
    Router(config)#ip nat inside source static [内网地址] [外网地址]
    把所以端口都映射
    Router(config)#ip nat inside source static [tcp/udp][内网地址] [端口号] [外网地址][端口号]
    把指定端口映射
     
    地址池转发格式:
    Router(config)#ip nat pool [外网池名自起] [外网IP可写多个] netmask [掩码]
    定义一个外网地址池
    Router(config)#access-list [内池代号1-99随便] permit [内网网段] [反掩码]
    定义一个内网地址池
    Router(config)#ip nat inside source list [内池代号] pool [外网池名]
    把内网池映射到外网池
     
    重载PET转发格式:
    Router(config)#access-list [代号自起] permit [内网网段] [反掩码]
    Router(config)#ip nat inside source list [上面定义的代号] interface [指定的外网端口] overload
     
     
     
     
     
    R1上配置
    Router(config)#int f0/0
    Router(config-if)#ip address 10.10.10.10 255.255.255.0
    Router(config-if)#no shutdown
    Router(config-if)#ip nat outside
     
    Router(config)#int f0/1
    Router(config-if)#ip address 192.168.0.1 255.255.255.0
    Router(config-if)#no shutdown
    Router(config-if)#ip nat inside
     
     
    静态NAT转发
    Router(config)#ip nat inside source static 192.168.0.1 10.10.10.10
    Router(config)#ip nat inside source static tcp 192.168.0.1 80 10.10.10.10 80
     
    地址池转发
    Router(config)#ip nat pool kt 10.10.10.1 10.10.10.2 netmask 255.255.255.0
    Router(config)#access-list 1 permit 192.168.0.0 0.0.0.255
    Router(config)#ip nat inside source list 1 pool kt
     
    重载PET转发
    Router(config)#access-list 1 permit 192.168.0.0 0.0.0.255
    Router(config)#ip nat inside source list 1 interface fa0/0 overload
     
    注意:
    主机上一定要配置网关