模型:

 

配置详解:

1) 用户侧的配置
在拨号网络窗口中输入用户名 vpdnuser 和密码Hello 进行拨号。
(2) LAC 侧的配置
在 NAS 上配置:
# 配置各接口的IP 地址(略)。
# 设置用户名及口令。
[LAC] local-user vpdnuser
[LAC-luser-vpdnuser] password simple Hello
[LAC-luser-vpdnuser] service-type ppp
[LAC-luser-vpdnuser] quit
# 在Async1/0 接口上配置IP 地址。
[LAC] interface async 1/0
[LAC-Async1/0] ip address 1.1.1.1 255.255.255.0
[LAC-Async1/0] ppp authentication-mode chap
[LAC-Async1/0] quit
# 启用L2TP 服务。
[LAC] l2tp enable
# 设置一个L2TP 组,并配置相关属性。
[LAC] l2tp-group 1
[LAC-l2tp1] tunnel name LAC
[LAC-l2tp1] start l2tp ip 1.1.2.2 fullusername vpdnuser
# 启用通道验证并设置通道验证密码。
[LAC-l2tp1] tunnel authentication
[LAC-l2tp1] tunnel password simple aabbcc
(3) LNS 侧的配置
# 配置各接口的IP 地址(略)。
# 设置用户名及密码(应与用户侧的设置一致)。
<LNS> system-view
[LNS] local-user vpdnuser
[LNS-luser-vpdnuser] password simple Hello
[LNS-luser-vpdnuser] service-type ppp
[LNS-luser-vpdnuser] quit
# 对*** 用户采用本地验证。
[LNS] domain system
1-17
[LNS-isp-system] authentication ppp local
[LNS-isp-system] ip pool 1 192.168.0.2 192.168.0.100
[LNS-isp-system] quit
# 启用L2TP 服务。
[LNS] l2tp enable
# 配置虚模板Virtual-Template 的相关信息。
[LNS] interface virtual-template 1
[LNS-virtual-template1] ip address 192.168.0.1 255.255.255.0
[LNS-virtual-template1] ppp authentication-mode chap domain system
[LNS-virtual-template1] remote address pool 1
[LNS-virtual-template1] quit
# 设置一个L2TP 组,指定接收呼叫的虚拟接口模板,配置LNS 侧的隧道对端名称。
[LNS] l2tp-group 1
[LNS-l2tp1] tunnel name LNS
[LNS-l2tp1] allow l2tp virtual-template 1 remote LAC
# 启用隧道验证并设置隧道验证密码。
[LNS-l2tp1] tunnel authentication
[LNS-l2tp1] tunnel password simple aabbcc
4. 验证配置结果
通过命令 display l2tp tunnel 可查看建立的L2TP 隧道。
[LNS] dis l2tp tunnel
Total tunnel = 1
LocalTID RemoteTID RemoteAddress Port Sessions RemoteName
1 1 1.1.2.1 1701 1 LAC
通过命令display l2tp session 可查看建立的L2TP 会话。
[LNS] display l2tp session
Total session = 1
LocalSID RemoteSID LocalTID

 

================================

display current-configuration 查看:

version 5.20, Release 2105P31, Standard
#
sysname H3C
#
l2tp enable 启动L2TP-***
#
domain default enable system
#
telnet server enable
#
dar p2p signature-file cfa0:/p2p_default.mtd
#
port-security enable
#
acl number 2000 建立访问控制类表
rule 1 permit source 100.100.100.0 0.0.0.255
rule 2 deny
#
vlan 1
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
ip pool 1 192.168.0.2 192.168.0.254 给L2TP-***分配地址
#
user-group system
#
local-user admin 建立用户名L2TP-***
password simple 123456 密码
service-type ppp 隧道验证
local-user h3c 管理用户
password simple h3c
authorization-attribute level 3 管理权限
service-type telnet terminal
#
l2tp-group 1 建立应用服务
undo tunnel authentication
mandatory-lcp
allow l2tp virtual-template 0
#
interface Aux0
async mode flow
link-protocol ppp

interface Cellular0/0
async mode protocol
link-protocol ppp
#
interface Ethernet0/0
port link-mode route
ip address 100.100.100.188 255.255.255.0
#
interface Ethernet0/1
port link-mode route
nat outbound 2000 允许100段访问外网
ip address 218.24.140.166 255.255.255.0
#
interface Virtual-Template0 建立***需模板
ppp authentication-mode pap domain system 链路验证
remote address pool 1 加载地址池
ip address 192.168.0.254 255.255.255.0
#
interface NULL0
#
ip route-static 0.0.0.0 0.0.0.0 218.24.140.65 静态路由
#
load xml-configuration
#
load tr069-configuration
#
user-interface con 0
user-interface tty 13
user-interface aux 0
user-interface vty 0 4
authentication-mode scheme 用户权限验证
#
return