帧中继(Frame Relay)的介绍:
是一种网络与数据终端设备(DTE)接口标准。由于光纤网比早期的电话网误码率低得多,因此,可以减少X.25的某些差错控制过程,从而可以减少结点的处理时间,提高网络的吞吐量。帧中继就是在这种环境下产生的。帧中继提供的是数据链路层和物理层的协议规范,任何高层协议都独立于帧中继协议, 因此,大大地简化了帧中继的实现。目前帧中继的主要应用之一是局域网互联,特别是在局域网通过广域网进行互联时,使用帧中继更能体现它的低网络时延、低设备费用、高带宽利用率等优点。
帧中继的主要特点是:使用光纤作为传输介质,因此误码率极低,能实现近似无差错传输,减少了进行差错校验的开销,提高了网络的吞吐量;帧中继是一种宽带分组交换,使用复用技术时,其传输速率可高达44.6Mbps。但是,帧中继不适合于传输诸如话音、电视等实时信息,它仅限于传输数据。
 
帧中继术语:
 DTE:客户端设备(CPE),数据终端设备
DCE:数据通信设备或数据电路端接设备
虚电路(VC):通过为每一对DTE设备分配一个连接标识符,实现多个逻辑数据会话在同一条物理链路上进行多路复用。
数字连接识别号(DLCI):用以识别在DTEFR之间的逻辑虚拟电路。
本地管理接口(LMI):是在DTE设备和FR之间的一种信令标准,它负责管理链路连接和保持设备间的状态。
 
 
 
 
实验:配置point-to-point帧中继
首先说明一下DLCI号的分配,R1102R2201;中间路由器模拟帧中继交换机,其它接口信息与IP信息如拓扑所示.
 
 
 
 
具休配置:
 
Frame-Relay(帧中继交换机)
 
Router>
Router>en
Router#conf t
Router(config)#hostname Frame-Relay
Frame-Relay(config)#no ip do lookup
Frame-Relay(config)#line console 0
Frame-Relay(config-line)#exec-timeout 0 0
Frame-Relay(config-line)#logging synchronous
Frame-Relay(config-line)#exit
Frame-Relay(config)#frame-relay switching      --启用帧中继交换机功能
Frame-Relay(config)#interface s1/0
Frame-Relay(config-if)clock rate 64000    --设置时钟
Frame-Relay(config-if)#encapsulation frame-relay      --封装帧中继协议
Frame-Relay(config-if)#frame-relay intf-type dce   
--帧中继接口类型为DCE(数据通讯设备)
Frame-Relay(config-if)#frame-relay lmi-type ansi   
--帧中继本地管理接口类型ansi(美国国家标准协会)
Frame-Relay(config-if)#frame-relay route 102 interface s1/1 201
--对此接口对应的DLCI102S1/1对应的DLCI201进行路由   
Frame-Relay(config-if)#no sh
Frame-Relay(config-if)#int s1/1
Frame-Relay(config-if)clock rate 64000    --设置时钟
Frame-Relay(config-if)#encapsulation frame-relay     --封装帧中继协议
Frame-Relay(config-if)#frame-relay lmi-type ansi
--帧中继本地管理接口类型ansi(美国国家标准协会)
Frame-Relay(config-if)#frame-relay intf-type dce
--帧中继接口类型为DCE(数据通讯设备)
Frame-Relay(config-if)#frame-relay route 201 interface s1/0 102
--对此接口对应的DLCI201S1/1对应的DLCI102进行路由
Frame-Relay(config-if)#no sh
Frame-Relay(config-if)#end
Frame-Relay#
Frame-Relay#
 
查看帧中继路由
 
Frame-Relay#show frame-relay route
/进方向接口    /进方向接口DLCI  /出方向接口  /出方向接口DLCI   /状态
Input Intf      Input Dlci      Output Intf     Output Dlci     Status
Serial1/0       102             Serial1/1       201             active  (活动)
Serial1/1       201             Serial1/0       102             active  (活动)
Frame-Relay#
 
 
 
 
R1;
 
Router>
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R1
R1(config)#no ip do lookup
R1(config)#line console 0
R1(config-line)#exec-timeout  0 0
R1(config-line)#logging synchronous
R1(config-line)#exit
R1(config)#interface s1/0
R1(config-if)#encapsulation frame-relay     --封装帧中继协议
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no sh
R2(config-if)#no frame-relay inverse-arp     --关闭帧中继反向ARP功能
R1(config-if)#frame-relay interface-dlci 102    --指定此接口的DLCI号为102
R1(config-fr-dlci)#exit
R1(config-if)#exit
R1(config)#interface loopback 0
R1(config-if)#ip address 172.16.1.1 255.255.255.0
R1(config-if)#exit
R1(config)#router rip    --启用RIP路由协议
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#network 192.168.1.0
R1(config-router)#network 172.16.1.0
R1(config-router)#end
R1#
 
查看路由表:
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 1 subnets
R       10.1.1.0 [120/1] via 192.168.1.2, 00:00:06, Serial1/0
C    192.168.1.0/24 is directly connected, Serial1/0
R1#
 
验证在R1上以loopback0:172.16.1.1地址拼R2loopback0:10.1.1.1
R1#ping 10.1.1.1 source 172.16.1.1
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 172.16.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/120/232 ms
R1#
R1#
 
 
 
 
R2;
 
Router#conf t
Router(config)#hostname R2
R2(config)#no ip do lo
R2(config)#line console 0
R2(config-line)#exec-timeout 0 0
R2(config-line)#logging synchronous
R2(config-line)#exit
R2(config)#interface s1/0
R2(config-if)#encapsulation frame-relay     --封装帧中继协议
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no sh
R2(config-if)#no frame-relay inverse-arp     --关闭帧中继反向ARP功能
R2(config-if)#frame-relay interface-dlci 201    --指定此接口的DLCI号为201
 
R2(config-fr-dlci)#exit
R2(config-if)#exit
R2(config)#interface loopback 0
R2(config-if)#ip address 10.1.1.1 255.255.255.0
R2(config-if)#exit
R2(config)#router rip    --启用RIP路由协议
R2(config-router)#version 2
R2(config-router)#no auto-summary
R2(config-router)#network 10.1.1.0
R2(config-router)#network 192.168.1.0
R2(config-router)#end
R2#
 
查看路由表:
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     172.16.0.0/24 is subnetted, 1 subnets
R       172.16.1.0 [120/1] via 192.168.1.1, 00:00:14, Serial1/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, Serial1/0
R2#
 
验证在R2上以loopback0:10.1.1.1地址拼R1loopback0:172.1.1.1
 
R2#ping 172.16.1.1 source 10.1.1.1
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/186/296 ms
R2#
 
 
 
下一篇我们配置点到多帧中继.