单臂路由
 
 
 
如上图所示为这次实验的拓扑图。
 
一、实验要求
PC1PC2划分到不同的VLANVLAN10,VLAN20)里,同时两者可以互相通信。
二、实验分析
我们知道不同的VLAN在一般情况下是不能相互通信的,要想使不同VLAN里的主机互访就得使用VLAN间路由技术。在考虑成本的情况下我们一般选择单臂路由,单臂路由需要一台交换机和一台路由器来共同实现。
三、实验过程
 
申明:本实验是通过工大瑞普的模拟器完成。
先看SW1
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#ho SW1
SW1(config)#no ip do lo
SW1(config)#line con 0
SW1(config-line)#no exec-t
SW1(config-line)#logg sy
SW1(config-line)#exit                     以上是基本配置,养成习惯就好(因为是模拟器,我没有配置密码)。
SW1(config)#no ip routing                 关闭路由功能
SW1(config)#vlan 10                       创建VLAN号为10的VLAN
SW1(config-vlan)#name caiwu               将此VLAN命名为caiwu(只起到识别的作用)
SW1(config-vlan)#exit
SW1(config)#vlan 20                       创建VLAN号为20的VLAN
SW1(config-vlan)#name renshi              将此VLAN命名为renshi(只起到识别的作用)
SW1(config-vlan)#exit
SW1(config)#int fa1/11
SW1(config-if)#speed
SW1(config-if)#speed 100
SW1(config-if)#duplex full
SW1(config-if)#no sh                   
SW1(config-if)#switchport mode access     将此端口设置成access模式
SW1(config-if)#switchport access vlan 10  将此端口加入到vlan10
SW1(config-if)#no sh
SW1(config-if)#exit
SW1(config)#int fa1/12
SW1(config-if)#speed 100
SW1(config-if)#duplex full
SW1(config-if)#
*Mar  1 00:06:03.735: %LINK-3-UPDOWN: Interface FastEthernet1/12, changed state to ups

SW1(config-if)#switchport mode access    将此端口设置成access模式
SW1(config-if)#switchport access vlan 20 将此端口加入到vlan20
SW1(config-if)#no sh
SW1(config-if)#end
SW1(config)#int fa1/5
SW1(config-if)#speed
SW1(config-if)#speed 100
SW1(config-if)#duplex full
SW1(config-if)#switchport mode trunk     将此端口设置成trunk模式
SW1(config-if)#switchport trunk encapsulation dot1q   封装方式为dot1q
SW1(config-if)#no sh
SW1(config-if)#end
再看R1
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#ho R1
R1(config)#no ip do lo
R1(config)#line con 0
R1(config-line)#no exec-t
R1(config-line)#logg sy
R1(config-line)#end
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int fa0/0
R1(config-if)#speed 100
R1(config-if)#duplex full
R1(config-if)#no sh
R1(config-if)#int fa0/0.1                            起子接口
R1(config-subif)#encapsulation dot1Q 10              选择封装方式
R1(config-subif)#ip add 192.168.10.1 255.255.255.0
R1(config-subif)#no sh
R1(config-subif)#exit
R1(config)#int fa0/0.2
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip  add 192.168.20.1 255.255.255.0
R1(config-subif)#no sh
R1(config-subif)#end
接下来是PC1
实验中我们用ROUTER模拟PC
Router>en
Router#conf t
Router(config)#ho PC1
PC1(config)#no ip do lo
PC1(config)#line con 0
PC1(config-line)#no exec-t
PC1(config-line)#no logg sy
PC1(config-line)#end
PC1(config)#no ip routing            
PC1(config)#int fa0/0
PC1(config-if)#speed 100
PC1(config-if)#duplex full
PC1(config-if)#ip add 192.168.10.2 255.255.255.0
PC1(config-if)#no sh
PC1(config-if)#exit
PC1(config)#ip default-gateway 192.168.10.1               关键步骤:配置PC的缺省网关
PC1(config)#end
然后是PC2
Router>en
Router#conf t
Router(config)#ho PC2
PC2(config)#no ip do lo
PC2(config)#line con 0
PC2(config-line)#no exec-t
PC2(config-line)#logg sy
PC2(config-line)#end
PC2#conf t
PC2(config)#no ip routing
PC2(config)#int fa0/0
PC2(config-if)#speed 100
PC2(config-if)#duplex full
PC2(config-if)#ip add 192.168.20.2 255.255.255.0
PC2(config-if)#no sh
PC2(config-if)#exit

PC2(config)#ip default-gateway 192.168.20.1          
PC2(config)#end
 
 
最后是测试
PC1#ping 192.168.20.2                                     测试
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/20/32 ms
 
PC2#ping 192.168.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.2, timeout is 2 seconds:
..!!!
Success rate is 60 percent (3/5), round-trip min/avg/max = 12/17/24 ms
PC2#ping 192.168.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/21/32 ms
 
实验完成。