清华万博的
2007-04-27 21:39
1bri基本数据接口
pri
support.microsoft.com 微软错误支持网站
  TAC 思科的
BRIDGE:网桥
SWITCH:交换机
ROUTER:路游
ACCESS SERVER:访问服务器
ISDN SWITCH: ISDN交换机
MULTI-LAYER SWITCH:多层交换机
NETWORK SWITCH:网络交换机
PERSONAL COMPUTER:客户端
FILE SAERVER:文件服务器
DATA SERVICE UNIT:
MODEM:猫
WEB SERVER:网络服务器
WAN:广域网云
vlan:
Hub:
Network cloud or broadcast:
ETHERNET仪态网
窜行电路
3层网络
CORE LAYER核心层:快速数据转发
DISTRIBUTION LAYER分布层:
ACCESS LAYER访问层:所有接点连入
DCE 数据通信设备 提供服务 母头 孔
DTE 数据终端设备 接受服务 公头 针
   端 <--> 交换机 <-> 交换机 <--> 端
MAC           A   B C   D E   F
LAN mac源目:    AB    CD    EF
WAN  
HUB
冲突域:在域内有可能发生冲突。第一次冲突(碰撞):2毫秒+随机数;第二次:4毫秒+随机数;第三次:8毫秒+随机数...
CSMA/CD:带有冲突检测的载波监听多路访问
广播域:发出广播能听到的所有的。

数据链路层
以太网贞:64~1518字节
802.3
字节: 8 6   6   2 variable 4
前导 目标MAC   源MAC   长度 数据   校验序列
交换机
每一个端口都有自己的冲突域
多播地址:224.0.0.7

1T 高速串行端口 256m
A/S 同异步串行端口
干线:没有任何信号的电话线
rollover cable 反转线
配置端口
interface class number
     类型     号码
s:串口
e:以太口
f:
interface class   number
     类型     模块/号码
思科:
2500系列:
单数:以太网
双数:令牌环网
out-of-band 带外
in-of-band 带内

用户模式 >
特许模式 #
1900:
Enterprise Edition Sofrware : 企业版
Ethernet Address:    基本MAC地址,交换机共有端口数+1个MAC地址
PCA Number:    
PCA Serial Number
Model Number
System Serial Number
Power Supply S/N
·用户模式进入特权模式
>enable
·特权模式进入用户模式
#disable
·Global configuration mode   全局配置模式,对设备全局方面的配置
#configure terminal 简写:conf t
·Interface   configuration mode 接口配置模式
#Interface 接口类型/序
·改名
#hostname
·给交换机IP地址
#ip address IP 子网掩码
·设置网关
#ip default-gateway IP
·显示
#/>show
#/>show version 查看版本
#/>show running-configuartion 查看运行的配置
#show interfaces 查看接口
MTU:最大接受包大小
BW:带宽
#/>show ip 查看IP
启动路由器
#enable password 设置密码
#setup   进入设置模式,进入后所有端口都会关闭
#shutdown 关闭
#no shutdown 启动
Enter host name;主机名
Enter enable secret:设置加密密码。级别高于password
Enter enable password:设置密码。
Enter virtual terminal password:设置telnet的密码,如果没有,则禁用telnet。
#/>show ip interface 查看IP
·退出用户模式
>logout
·帮助,查看本权限可用命令
>/#?
命令 ?:查看命令参数
**?:查看以**为首字母所有的命令
·出错信息:^
·把running配置文件复制到startup配置文件
copy running-configuration startup-configuration
配置路由器:
子接口模式:Subinterface
控制模式:Controller
Line模式:Line
路由模式:Router
#hostname <name> 定义路由器名称
#banner motd (定界符,!、#等)内容   内容出现在用户提示符之前
#interface ethernet
#descirtion 解释。
#line console 控制console口
#line vty 0 4 控制虚拟终端,0 4代表范围0~4
#login   进行本地的身份验证
#no login   不进行本地的身份验证
#password <password>   设置密码
#enable password <password> 设置进入特权模式的密码
#enable secret <password>   设置进入特权模式的密码
#logging synchronous 无论来什么消息,输入字符都会显现在最下方
#exec-timeout 0 0   一定时间内无操作,自动退出。前一个0是分钟。后一个0是秒。0 0是永远不
配置串口:
#interface serial 0 进入(全局下)
#clock rate 64000   设置时钟
#bandwidth 64   逻辑上的带宽64k
#enc HDLC 封装成HDRC(串口)
#show controller serial 0   查看线缆是DTE还是DCE
配置以太口
#interface ethernet 2 进入
#media-type 10baset 设置接口类型(基本用不到)
#shutdown    关闭接口
#no shutdown   启动接口(无论是否关闭,全可用)
#ip address ip 子网   配置IP
#show ip interface    看接口配置(可以指定端口)
seriall   物理层
line protocol   数据链路层
#show ip interface brief
       物理层     数据链路层
Operastional   好    up     up
Connection problem 连接性问题   up     down   检测封装、时钟
Intertace problem 接口问题   down     down   线路问题,对方接口管理性down
Disabled   禁止    administratively down down   no shutdown
MTU:最大接受包大小
BW:带宽
DLY 延迟(毫秒)
rely 可靠性
load 负载
encapsulation   封装
loopback 回路
leepalive set (* sec) 隔*秒检测网络对方存在
#
#
#
Cisco Discovery Protocol(CDP)协议
第二层的协议,不需要任何其他协议支持。
Cisco专有协议
工作原理:
每个一定的周期,就将自己的信息发送到周围的邻居
设备标识 Device identifiers
地址列表 Address list
端口标识 Port identifier
能力 Capabilities list
功能 Platform
查看CDP
#show CDP
#show CDP entry * 详尽邻居信息
#show CDP interface 自身接口CDP的状态
#show CDP neighbors 邻居信息
Device ID Local Intrfce   Holdtme Capability Platform Port ID
邻居名   自己连接端口   刷新时间 类型   型号   邻居邻居端口
#show CDP neighbors detail   等同于#show CDP entry *
#show CDP traffic CDP统计状态
#no cdp run   关闭cdp(全局)
#no cdp enable 关闭cdp(某个接口)
#show sessions 查看发出的telnet
#show users   查看谁和自己创建了会话(连接操作和telnet自己的)
telnet中:按下<ctrl+shift+6>,再按x   返回本机
本机#resume <No>   返回telnet <No>中(不写数字,进入*所在的telnet,直接回车也可以)
#disconnect   主动断掉telnet
#clear line 进程号 被动被提掉
#ping   !:成功。.:超时。u:不可达。p:协议不可达
#show ip interface brief 查看交换机接口
#write   保存,等于copy running-configuration startup-configuration
#
#
路由启动过程:
1、加电自检 POST是一段固化的代码 ROM
2、装载运行引导条的代码    ROM
3、查找IOS文件
   1) 查找配置寄存器    NVROM
    0x2102 最后一位0:从ROM monitor启动。1:从Mini IOS。2~F:从NVROM启动
   2) 看NVROM的配置。如果有boot system:文件位置(tftp://ip/文件),从路径启动。没有或找不到文件,向下执行
   3) 从Flash卡的第一个文件启动
   4) 网络启动
   5) RXBOOT 装载Mini IOS 不走第4步
   6) ROMMON 装载ROM Monitor 不走第4步
4、读取IOS文件
5、查找配置文件
6、装载配置文件
7、运行IOS
路由器组成:
1、RAM 随机访问存储器、内存 POST(加电自检)、Bootstrap(引导带)、Mini IOS(紧急救护,软件)、ROM Monitor(紧急救护,硬件)
2、ROM 只读访问存储器
3、Flash 闪存
4、NVROM
5、Interfaces   接口
6、CPU
#show flash   查看IOS
#config-register 0x2102   修改寄存器值 全局下
交换机口令恢复
低端:1900系列(包括2924):
拔下电源,按住more键,插上电源
中端:2905、3550、3548:
拔下电源,按住more键,接电,进入类似ROMMON的界面,>initflash   重命名config.dat
高端:4000以上
开机60s内不需要口令。60s内修改口令
路由器口令恢复
2500系列
关电,加电,ctrl+break, >o/r 0x2142 >i(重启) 是否配置SETUP   >no >en #copy startup-configuration running-configuration #conf t #enable password 密码 #config-reg 0x2102 #wr
1600、1700、2600、36000...等
关电,加电,ctrl+break, Rommon>confreg 0x2142 >reset(重启) 是否配置SETUP >no >en #copy startup-configuration running-configuration   #conf t #enable password 密码 (c)#config-reg 0x2102 #wr

#show flash   显示flash的内容
#copy flash tftp 将flash内的文件复制到tftp服务器上
#copy tftp flash 从tftp复制到flash上
service password-encryption   将下面的密码进行加密
#
#
#
接口下的配置高于全局下配置

任何命令的反命令就是在前面加no
交换机是由硬件完成,网桥是软件完成
交换机功能:
1、地址学习
2、根据所学习到的地址进行转发和过滤
3、环路避免
衡量交换机的标准:转发模式
1、直接转发(几乎没有延迟) 快,但没有检查
2、存储转发(延迟为帧的长度) 效率慢,保证传输的有效性
3、混合转发(思科自有)   只检查前64个字节
   冗余网络的缺点:
1、广播风暴
2、多帧复制
3、MAC地址不稳定
生存树算法
stp协议:生存树协议
选根桥,选根端口
选根桥
桥ID=网桥优先级+MAC
   网桥优先级,缺省为32768,0~65535,越小越高
设备新加入网络:阻塞(20秒)-->听MAC地址(15秒)-->学MAC地址(15秒)-->工作
选根端口
比较开销,越小越高。开销相同比MAC
生存树的收敛
端口状态变化,收敛时间最少1分钟
rstp协议:快速生存树协议
加快网络收敛时间

交换机配置:
1900系列
show spantree   看端口
show vlan
(c)#ip add <IP> <MASK> 配置IP
(c)#ip default-gateway <IP> 配置网关
#show ip 看IP
(c)#interface e 0/1 配置全双工/半双工
     (c-if)duplex
#show mac-address-table 看MAC
(c)#mac-address-ttable permanent MAC ethernet 0/3 MAC绑定端口
(c)#mac-address-ttable restricted static MAC e0/1 e0/2 静态限制地址,只运行e0/2访问
端口安全性
(c-if)#port secure
     (c-if)#port secure max-mac-count 数字
#show mac-address-table security 查看是否启动安全性
#show mac-address-table   查看MAC
(c)#address-violation {suspend暂停|disable禁止|ignore忽略}   配置端口安全性
   suspend暂停 直到下一个安全帧
   disable禁止 关闭
   ignore忽略 关闭安全性
#delete nvram   删除配置

2950系列
show spantree   看端口
show vlan
配置IP
(c)#interface vlan 1
     (c-if)#ip address IP MASK
     (c-if)#ip default-gateway IP 配置网关

#show interface vlan 1 看IP

配置全双工/半双工
(c)#interface fe 0/1
     (c-if)duplex

(c)#mac-address-ttable   MAC ethernet 0/3   MAC绑定端口
(c)#mac-address-ttable secure MAC e0/1 e0/2 静态限制地址,只运行e0/2访问
#show mac-address-table   查看MAC
   端口安全性
(c-if)#port security
     #(c-if)#port security max-mac-count 数字

#erase startup-config 删除配置

全双工是点对点的,没有冲突,关闭冲突检查电路关闭
all 半 = 半
全 全 = 全
自动 全 = 半

VLan
优点:分段、灵活、安全
VMPS
收集MAC的软件:cisco work 2000
Vlan实现方法:
1、802.1Q
Native Vlan:本征Vlan,不加封装
2、ISL(思科特有)
VTP虚拟终端协议
配置Vlan,VTP不是必须的,是必要的
VTP模式:
服务器模式:可以添加、删除、修改、转发、发送广播、同步、保存
客户端模式:转发、同步、不能保存
透明模式:可以添加、删除、修改、转发、保存,不同步,不广播

trunk:骨干,不属于任何vlan
VLAN配置
1、配置VTP
1) VTP域名
2) VTP密码
3) VTP版本(VTP1支持以太网,VTP2支持以太网、令牌环网)
vlan一共1005个,2~1006   1007~1024是保留的
1900:
   (c)#vtp domain   域名
   (c)#vtp password   密码
   #show vtp    查看vtp
2950:
   #vlan database 打开vlan.dat
   (vlan)#vtp
   (vlan)#vtp domain   域名
   (vlan)#vtp password   密码
   #show vtp    查看vtp
2、配置trunk
#config terminal
(c)#interface f0/26
封装vlan
802.1Q
2950: (c-if)#switchport mode trunk
ISL
1900: (c-if)#trunk on
#show trunk a
3、划分Vlan
交换机最多支持64个Vlan
Vlan1被称作管理Vlan,CDP、VTP信息在Vlan1里发送
添加vlan
   1900:
#configure terminal
(c)#vlan 2 name **** (name ***可以不用)
   2950:
#vlan database
(vlan)#vlan 3 name ***
(vlan)#apply
4、把端口指定到Vlan
   1900
(c-if)#vlan-membership static 9
   2950
(c-if)#switchport access vlan 9
#show vlan 查看vlan
核实trunk
1900: #show trunk a
2950: #show interface fa0/2 switchport
查看端口属于哪个vlan
1900: #show vlan-membership
2950: #show vlan brief
看spantree
#show spantree vlan 5

路由
路由器最主要功能:路径选择
协议:
Routed Protocol:被路由协议 IP、IPX、Appletalk
Routing Protocol:使路由协议 RIP、TGRP、OSPF、EIGRP
静态路由:管理员通过手工添加的   用于小型网络
动态路由:通过路由协议学习的   用于大型网络
静态路由:
(c)#ip router network(目标IP) mask   自己的接口IP或对方IP
缺省路由:在末节网络使用。末节网络只有一个出口
(c)#ip router 0.0.0.0 0.0.0.0 自己接口的IP或对方接口IP
#show ip router 查看router
   c:直连 s:静态 *:缺省
动态路由:
自治域系统:按照运营商划分
IGRP:内部路游协议,同一个自制域系统内运行
EGP:外部路游协议,多个自制域系统内运行
BGP:边界网关协议
管理距离
距离向量路由协议
链路状态路由协议
有类路由协议classful
路由条目不带子网掩码
同网段的IP进入时,用接口的MASK。
   例子:192.168.1.0传入192.168.1.129/25
    192.168.1.0的MASK变为192.168.1.0/25
   RIPv1
   IGRP
无类路由协议classless
路由条目带子网掩码,支持变长子网掩码
   RIPv2
   EIGRP
   OSPF
   IS-IS
(c)#ip router 0.0.0.0 0.0.0.0 自己的接口IP或对方IP
(c)#ip classless 为了保证上一条可用
VLAN间的路由
ISO必须有IP Plus
添加子接口
ISL:
(c)#interface fastethernet 0/0
(c-if)#no ip address   使子接口生效
(c-if)#interface fastethernet 0/0.1
(c-if)#ip address IP Mask
(c-if)#encapsulation isl 1   1代表和vlan 1通讯
使子接口失效
(c)#interface fastethernet 0/0
(c-if)#ip address
802.1Q:
(c)#interface fastethernet 0/0
(c-if)#ip address IP MASK
(c-if)#interface fastethernet 0/0.1
(c-if)#ip address IP Mask
(c-if)#encapsulation dot1q

距离向量路由协议
RIP协议   Metrics:最大15跳,16跳为不可达    收敛时间=保持时间180s+周期广播时间30s
IGRP协议 Metrics:带宽、延迟、负载、可靠性、MTU   收敛时间=保持时间270s+周期广播时间90s
解决路由环的方法:
最大计数:16
水平分割:从源学习的路由不再返回给源
毒性路由:把宕掉的端口标识为16跳
毒性反转:NEXT路由将宕掉的16跳信息传回源路由
保持时间:(又叫抑制时间)
触发更新:单项传递不可达的信息。
链路状态路由协议
邻居表:和谁有邻居关系
拓扑表:计算开销得出
路由表:
划分区域目的:减少流量,划分层次
Backbone Area:骨干区域
特点:
1、快速收敛
2、对邻居发送确认并排序
3、网络设计小心
缺点:
1、内存占用大
2、耗费CPU时间
3、网络设计要小心
弊病:
邻居发现时泛洪
内存、CPU极度使用

RIP协议
属于距离向量路由协议
最多可以支持6条线路上负载均衡,默认是4条
每隔30s广播路由表
RIP版本1:有类路由协议,用255.255.255.255进行路由更新
RIP版本2:无类路由协议,用224.0.0.9进行路由更新
配置:
1、选择路由协议
2、指定网络接口
(c)#ip routing   启动IP协议
   发布路由协议
(c)#router RIP
(c-router)#network 主网络号(例子:192.168.1.0)
   查看路由
#show ip protocols
#show ip route 看到学习到的路由
   显示rip协议内容(动态)
#debug ip rip
IGRP协议
最大255条,支持负载均衡,支持不等的负载均衡。默认4条,最多6条
带宽、延迟、负载、可靠性
配置:
(c)#router igrp autonomous-system(自治域系统号)
(c-router)#network 主网络号(例子:192.168.1.0)
(c-router)#variance multiplier   负载均衡条数
(c-router)#traffic-share {blanced (平衡的)| min(按metric自动分配)}
显示igrp协议内容(动态)
#debug ip igrp transactions 看事务
#debug ip igrp event    看事件

EIGRP协议:扩展的IGRP
可以在IP、IPX、APPLETALK
EIGRP Metrics=256*IGRP Metrics
收敛只用3s,有备份路由
为每种协议都创造3张表(邻居、拓扑、路由)。
与IGRP有相同的负载均衡
配置:
(c)#router eigrp autonomous-system(自治域系统号)
(c-router)#network   主网络号(例子:192.168.1.0)
#show ip eigrp topology   看拓扑表
#show ip eigrp neighbors 看邻居表
#show ip route eigrp    看eigrp的路由表
#show ip eigrp interface
#show ip eigrp traffic   看eigrp包的输出输入
#debug ip eigrp   看eigrp
   ext 192.168.3.0 255.255.255.0 M 386560 - 256000 130560 SM 360960 - 256000 104960
       自己的Metrics 带宽 延迟 下一跳Metrics
Enabling OSPF 启动OSPF O:开放。SPF:最短路径优先算法
LSA:链路状态通告。
在所有路由器之间洪泛LSA,建立数据库。用SPF将数据库转成路由表
link:路由器接口
State:
SPF最短路径优先算法:开销相加
DR:指定路由。比优先级高,比ip大(如果有Loopback,只用Loopback,不用物理接口)。
有DR后,新的路由加入时不重新选DR,知道DR死亡或重新选举。
BDR:备份的DR,DR宕掉时代替DR。
Loopback:逻辑端口
特性:
配置:
(c)#router ospf process-id(处理进程号,只对本地有效)
(c-router)#network IP MASK(0代表限制,1代表忽略) area(区域) area-id(区域号)
   123.456.789.123 0.0.1.0 发布123.456.***.123的网络 可以达到精确发布
#show ip protocols
#show ip route
#show ip ospf interface
#show ip ospf neighbor
#debug ip ospf event
#debug ip ospf packet

(c)#ip subnet-zero使用网络号
访问控制列表
应用:
1、允许(Permit)或拒绝(deny)数据包流过路由器
2、允许或拒绝vty访问
3、没有访问控制列表,所以数据包都不被过滤
其他应用:
1、优先级和队列
2、按照需求拨号Dial-on-Demand
3、路由过滤
访问控制列表类型:
1、标准访问控制列表(Standard):只能按源地址过滤
   1~99,1300~1999
2、扩展访问控制列表(Extended):能按源、目标、端口号过滤
   100~199,2000~2699
3、命名访问控制列表(Named)
标准访问控制列表
进入路由器-->和路由表对比-->匹配-->检查送出接口-->查看接口是否有访问控制列表-->有-->匹配访问控制列表-->匹配-->送出
        -->不匹配-->丢弃                 -->没有-->送出                 -->不匹配-->丢弃
通配符掩码:
0:限制。1:忽略
192.168.10.120 0.0.0.0 = host 192.168.10.120
192.168.10.120 255.255.255.255 = 0.0.0.0 255.255.255.255 = any
只允许192.168.16.0/24~192.168.31.0/24 =192.168.16.0 0.0.15.255
配置:
配置细节:
1、访问控制列表的号决定过滤的协议。
2、端口上每端口、每协议、每方向上只能有一个访问控制列表
3、访问控制列表在绑定在端口上要经过严格的测试
4、要将严格的语句放在访问控制列表的上面
5、在最后有一条缺省的deny any。在访问控制列表至少有一条Permit
6、创建完访问控制列表后,将它应用到端口上
7、访问控制列表是过滤流经路由器的流量,不能过滤路由器自身产生的流量
(c)#access-list <access-list-number(访问控制列表号)> {permit | deny } {条件}   定义访问控制列表
(c-if)#{protocol(协议)}access-group access-list-number(访问控制列表号) {in | out } 绑定访问控制列表
(c-if)#no {protocol(协议)}access-group access-list-number(访问控制列表号) {in | out   删除访问控制列表
(c)#access-list access-list-number(访问控制列表号) {permit | deny | remark(解释)} source(条件) [MASK]
例子: (c)#access-list 1 permit 172.16.0.0 0.0.255.255
(c)#interface e0
(c-if)#ip access-group 1 out
(c-if)#interface e1
(c-if)#ip access-group 1 out

扩展访问控制列表
配置:
(c)#access-list (access-list-number 访问控制列表号) {permit | deny} (protocol source source-wildcard 源) [operator port] (destination destination-wildcart 目的) [operator port] 符号 端口
eq:= neq:><   gt:>   lt:<
(c)#access-list 101 deny tcp 172.16.4.0 0.0.0.255 172.16.3.0 0.0.0.255 eq 21
(c)#access-list 101 deny tcp 172.16.4.0 0.0.0.255 any eq 23
命名的访问控制列表
(c)#ip access-list {standart | extended} name
(c-{std|ext}nacl)#{permit | deny} ..
(c-if)#ip access-group name {in | out }
对telnet设置访问控制列表
(c)#access-list 12 192.168.1.1 0.0.0.0 in
(c)#line vty 0 4
(c)#access-class 12 in
#show ip interface e0 看端口e0是否绑定访问控制列表
#show access-list 1   看访问控制列表内容

访问控制列表的应用:网络地址转换(NST)、端口地址转换(PAT)
SP:源端口。DP:目标端口。SA:源地址。DA:目标地址。
地址发布
(c)#ip nat inside source static 内网IP 外网IP
(c-if)#ip nat inside   内网端口
(c-if)#ip nat outside   外网端口
动态转换
(c)#ip nat pool <name> 开始IP 结束IP {mask | MASK长度}
(c)#access-list <access-list-number(访问控制列表号)> 标准访问控制列表
(c)#ip nat inside source list <access-list-number(访问控制列表号)> pool <name>
(C)#ip nat inside list <access-list-number> interface <端口> overload 单ip的
清楚列表
#clear ip nat translation *
#clear ip nat translation inside <内网IP> <外网IP>
#clear ip nat translation outside <内网IP> <外网IP>
#clear ip nat translation protocol inside/outside <外网IP> <外网port> <内网IP> <内网port>
#show ip nat translation 看ip转换表
#debug ip nat   看ip转换过程

广域网
       类型:
租用专线 HDLC(最简单的封装类型)、PPP(点对点,加密、多协议、压缩、身份验证)、SLIP(串行电路协议,基本看不到,只支持TCP/IP、明文、不能压缩)
电路交换 HDLC、PPP、SLIP
包交换 X.25(有固定时间的延迟)、ATM(信元交换)、Frame Relay(帧中继)
DSU数据服务单元、CSU通道服务单元
Demarcation 定界点 最近的电信分局
CO Switch 中央交换
HDLC封装格式
Flag address control Data FCS Flag
标准 地址 控制 数据 帧校验
PPP
是一个协议族
NCP:网络控制协议。支持网络层不同的协议,和上层协议打交道。
LCP:链路控制协议。创建链路连接以及链路协商。
LCP:验证、压缩、错误校验、多链路绑定
建立过程: 1、通讯、2、授权、3、可选。
PAP:明文验证
CHAP:加密验证,周期校验
ppp协议配置: 1、制定路由器名字
   2、设定用户名、密码
   3、验证方法
(c)#username <name> password <pw> 设定用户名、密码
(c-if)#encapsulation ppp 封装PPP
(c-if)#ppp authentication {chap|chap pap|pap chap|pap}
2个路由器进行身份验证,密码必须一致
缺省时,路由器名字为用户名
解决主机名不一致
(c-if)#ppp pap sent-username <name> password <pw>   pap验证:发送<name><pw>送给对方路由器
(c-if)#ppp chap hostname <name>   chap验证:发送<name>送给对方路由器
(c-if)#ppp chap password <pw>   chap验证:发送<pw>送给对方路由器
#debug ppp authentication 查看验证过程

帧中继
点对点
(c)#enc frem
(c)#int s0
(c-if)#int s 0.101 po 点对点
(c-if)#ip add <IP> <MASK>
(c-if)#fram int 101
#dubeg fram lmi
点对多点
(c)int s1
(c-if)int s 0.2 multi
(c-if)ip add <ip>
(c-subif)frame map ip <ip> <dlci>
按需拨号路由ISDN
BRI接口
PRI接口:运营商广泛使用
协议:
E协议:电话网络的协议
I协议:线路标准、接口类型、拓扑
Q协议:Q.921:链路层 Q.931:网络层
B信道:64kb
D信道:16/64kb
T1:23B+D 美洲标准
E1:30B+D 欧洲标准,国内用标准
S/T口:需要加NT-1设备
U口:内置了NT-1,可以直接连ISDN交换机
TA:中断适配器
串口:连TA,再连NT-1
AT&T:美国
Nortel:加拿大
中国的标准:basic-net3
配置:
(c)#isdn switch-type <switch-type> 配置ISDN交换机类型
(c-if)#isdn switch-type <switch-type> 配置ISDN交换机类型
(c-if)#isdn spid1 <spid-number> [ldn]
(c-if)#isdn spid2 <spid-number> [ldn]
#show isdn active 看isdn当前状态
#show isdn status 看isdn状态
#debug isdn q921 看第二层
#debug isdn q931 看第三层
#dubug ppp authentication
#dubug ppp negotiation 看协议
#dubug ppp error   看错误
DDR(按需拨号路由)
建立在ISDN或PSND(公共电话交换网络)上。
通讯不连续,传输数据较小时使用DDR
操作:
1、目的地清楚,端口是BRI
2、对感兴趣的数据建立拨号
3、找到拨号信息
4、成功通讯
5、呼叫中断
配置DDR
1、定义静态路由
ip route <IP> <MASK> <IP/接口>
2、指定感兴趣的数据 建立访问控制列表
指定对某些数据感兴趣
   dialer-list 1 protocol ip perimit 对所有都感谢趣
           指定数据产生拨号
   dialer-list 1 protocol ip list 101
   access-list 101 deny tcp any any eq ftp   ftp不能
   access-list 101 deny tcp any any eq telnet telnet不能
   access-list 101 permit ip any any   其他能
3、配置拨号信息
(c-if)#dialer idle-timeout 180 线路空闲180秒自动挂断
(c-if)#dialer map ip <ip> name <name> <电话号> 指定拨号电话号码
(c-if)#dialer-group 1 把dialer-list和接口绑定
(c-if)#dialer load-threshold <load (最大255)> [outbound |inboud |either] 定义负载
(c-if)#dialer

例子:
(c)#isdn switch-type basic-net3
(c)#interface BRI0
(c-if)#ip address <ip> <mask>
(c-if)#enc ppp
(c-if)#dialer idle-timeout 180 线路空闲180秒自动挂断
(c-if)#dialer map ip <ip> name <name> <电话号> 指定拨号电话号码
(c-if)#dialer-group 1 把dialer-list和接口绑定
(c-if)#no fair-queue 放弃均权平衡
(c-if)#ppp authentication chap
(c)#router rip
(c-r)#network <ip>
(c-r)ip route <ip> <mask> <ip>
(c)#dialer-list 1 protocol ip permit

拨号原型:
中继:支持临选
定义虚拟接口
interface dialer1
ip address <ip> <mask>
enc ppp
dialer remote-name <name>
dialer string <电话号>
dialer idle-time 180
dialer pool 1 把端口放进池子1
dialer-group 1
ppp authentication chap
定义接口
interface bri0
enc ppp
dialer pool member 1
ppp authentication chap