引用
飞鹰八步是腾讯linuxQQ在红旗Linux桌面6.0上运行
 
准备工作:1.下载linuxqq.tar.gz(里面已经包含了  腾 讯的linuxqq_1.0-Preview2008_i386.tar.gz)到桌面;
                   [url]http://ifile.it/haq3zef/linuxqq.tar.gz[/url]
                                       2.用root身份登录系统.
默认情况下,红旗Linux桌面6.0的火狐浏览器会把linuxqq.tar.gz下载到桌面上,打开终端程序,开始工作:
第一步:cd  /tmp
第二步:tar –xvf  /root/Desktop/linuxqq.tar.gz
第三步:   cd ./linuxqq
第四步:chmod  777  ./install.sh
第五步:./install.sh
第六步:cp  /tmp/run-QQ.sh  /opt/QQ
第七步:cp  /tmp/libexpat.so.1  /usr/lib
第八步:/opt/QQ/run-QQ.sh
此处可能出现你没有权限运行,只需进行以下三步即可:
 cd /opt/QQ
chmod  777 ./run-QQ.sh
/opt/QQ/run-QQ.sh
以上八步均可通过鼠标完成这里就不再赘述了
以后只要在终端里输入: /opt/QQ/run-QQ.sh就可以上QQ了,或者只要在桌面上创建一个指向/opt/QQ/run-QQ.sh一个快捷方式就可以了,以后单击桌面上的快捷方式就可以登录了
 
 
参考文章:
 
算算时间,QQ For Linux 已经发布10几天了,但仍然有相当一部分朋友还在顶关于安装QQ For Linux的帖子,这说明他们还在为QQ For Linux的安装发愁;而这些人之中的大多数都是红旗Linux用户,确切的说大都是红旗Linux6.0用户。我用的也是红旗Linux6.0,有幸在QQ forlinux推出二三天后就看到的有人(红联:Power_By_RTL)提出了相关的解决方案,很容易就解决了QQ For Linux 安装后不能启动的问题。在前几帖中我也说到了,有时间一定发一篇专门针对红旗Linux6.0下的QQ for Linux不能使用的解决方案;下面我就根据Power_By_RTL提出的解决方案整理一下,一步步展示在红旗Linux6.0下如何正确安装并使用QQ forlinux。
还有需要说明的两点:
1.此方法只是在红旗Linux6.0下测试过
2.此方法只针对官方的tarball安装后启动出现以下的问题:
[root@liufenglinuxqq_1.0-Preview2008_i386]# ./QQ
preparefork engine....
Failedto execl autoupdate ....
QQEngine Running....
IPC_TCP_PORT=9053
./QQ:symbol lookup error: ./QQ: undefined symbol: g_once_init_enter_impl
[root@liufenglinuxqq_1.0-Preview2008_i386]# engine exit...
然后就一直停在那里不动了。 当然,只要你用的也是红旗Linux6.0,用 rpm 包安装后如果也不能启动,那么不能启动的原因应该和上面是一样的。
原因及解決:undefinedsymbol: g_once_init_enter_impl 是由於當前系統的libpangocairo-1.0.so.0版本過低造成的,安裝新版本的 pango 即可解決,当然最简单直接的方法就是下载我打包好的 QQ for Linux 文件linuxqq.tar.gz,你可以放心使用。
下载后先解压得到linuxqq.tar.gz文件备用。
好了,下面进正题。
首先在/root目录下新建一个mylinuxqq 目录,然后将我提供的附件linuxqq.tar.gz 压缩包下载到/root/mylinuxqq 目录下;如果你建立的目录名不是mylinuxqq,那么在运行下面的命令时,要注意把命令中出现此文件名的地方替换成你新建的那个目录名。
在此简单说一下linuxqq.tar.gz包里的内容,里面包含着官方提供的linuxqq_1.0-Preview2008_i386.tar.gz 和 一些用 于解决上面那种错误的文件(整理由Power_By_RTL提供的几个附件)。
[root@liufeng~]# cd mylinuxqq
[root@liufengmylinuxqq]# ls -l
总计 7298
-rw-r--r--1 root root 7441658 08-12 22:09 linuxqq.tar.gz
进入目录mylinuxqq,然后确认一下已经将linuxqq.tar.gz放入此目录。
[root@liufengmylinuxqq]# tar -zxvf linuxqq.tar.gz
linuxqq/
linuxqq/説明文件.txt
linuxqq/sha1sum
linuxqq/linuxqq_1.0-Preview2008_i386.tar.gz
linuxqq/QQ-ok.tar.bz2
linuxqq/md5sum
linuxqq/INSTALL
linuxqq/FAQ
linuxqq/README
linuxqq/install.sh
libexpat.so.1
run-QQ.sh
解压该 tarball.
[root@liufengmylinuxqq]# ls -l
总计 7643
-rwxr-xr-x1 root root 347141 08-12 22:03 libexpat.so.1
drwxr-xr-x2 root root 1024 08-12 21:46 linuxqq
-rw-r--r--1 root root 7441658 08-12 22:09 linuxqq.tar.gz
-rw-r--r--1 root root 453 08-02 00:44 run-QQ.sh
解压完成后你会发现在 /root/mylinuxqq 目录下多了三个文件:libexpat.so.1,linuxqq和run-QQ.sh;请记住这几个文件,后面就要用到它们解决问题,至于具体什么用,先别急,慢慢往下看你就会明白的。
[root@liufengmylinuxqq]# cd linuxqq
[root@liufenglinuxqq]# ls -l
总计 7173
-r--r--r--1 root root 2181 08-01 13:58 FAQ
lrwxrwxrwx1 root root 6 08-12 22:53 INSTALL -> README
-rw-r--r--1 root root 595 08-02 00:41 install.sh
-rw-r--r--1 root root 4918468 07-31 17:48 linuxqq_1.0-Preview2008_i386.tar.gz
-rw-r--r--1 root root 306 08-01 15:17 md5sum
-rw-r--r--1 root root 2385300 08-01 15:14 QQ-ok.tar.bz2
-r--r--r--1 root root 578 08-01 14:52 README
-rw-r--r--1 root root 362 08-01 15:17 sha1sum
-r--r--r--1 root root 578 08-01 14:15 説明文件.txt
[root@liufenglinuxqq]# chmod -v 555 install.sh
“install.sh”的权限模式已更改为 0555(r-xr-xr-x)
进入到 /root/mylinuxqq/linuxqq 目录下,你会发现有一个 install.sh 脚本文件,但是没有执行权限,所以将其权限修改为555,使得该脚本能够执行。接下来就是运行 install.sh 脚本:
[root@liufenglinuxqq]# ./install.sh
QQ/
QQ/etc/
QQ/etc/pango/
QQ/etc/pango/pango.modules
QQ/etc/pango/pangox.aliases
QQ/etc/gtk-2.0/
QQ/etc/gtk-2.0/gdk-pixbuf.loaders
QQ/etc/gtk-2.0/gtk.immodules
QQ/etc/gtk-2.0/im-multipress.conf
QQ/lib/
QQ/lib/libatk-1.0.so
QQ/lib/libcairo.so
QQ/lib/libgdk-x11-2.0.so
QQ/lib/libgdk_pixbuf-2.0.so
QQ/lib/libgio-2.0.so
QQ/lib/libglib-2.0.so
QQ/lib/libgmodule-2.0.so
QQ/lib/libgobject-2.0.so
QQ/lib/libgthread-2.0.so
QQ/lib/libgtk-x11-2.0.so
QQ/lib/libpango-1.0.so
QQ/lib/libpangocairo-1.0.so
QQ/lib/libpangoft2-1.0.so
QQ/lib/libpangox-1.0.so
QQ/lib/libpangoxft-1.0.so
QQ/lib/pango/
QQ/lib/pango/1.6.0/
QQ/lib/pango/1.6.0/modules/
QQ/lib/pango/1.6.0/modules/pango-arabic-fc.so
QQ/lib/pango/1.6.0/modules/pango-arabic-lang.so
QQ/lib/pango/1.6.0/modules/pango-basic-fc.so
QQ/lib/pango/1.6.0/modules/pango-basic-x.so
QQ/lib/pango/1.6.0/modules/pango-hangul-fc.so
QQ/lib/pango/1.6.0/modules/pango-hebrew-fc.so
QQ/lib/pango/1.6.0/modules/pango-indic-fc.so
QQ/lib/pango/1.6.0/modules/pango-indic-lang.so
QQ/lib/pango/1.6.0/modules/pango-khmer-fc.so
QQ/lib/pango/1.6.0/modules/pango-syriac-fc.so
QQ/lib/pango/1.6.0/modules/pango-thai-fc.so
QQ/lib/pango/1.6.0/modules/pango-tibetan-fc.so
QQ/lib/libgdk-x11-2.0.so.0.1200.11
QQ/lib/libgdk_pixbuf-2.0.so.0.1200.11
QQ/lib/libgtk-x11-2.0.so.0.1200.11
QQ/lib/glib-2.0/
QQ/lib/glib-2.0/include/
QQ/lib/glib-2.0/include/glibconfig.h
QQ/lib/gtk-2.0/
QQ/lib/gtk-2.0/2.10.0/
QQ/lib/gtk-2.0/2.10.0/engines/
QQ/lib/gtk-2.0/2.10.0/engines/libpixmap.so
QQ/lib/gtk-2.0/2.10.0/immodules/
QQ/lib/gtk-2.0/2.10.0/immodules/im-am-et.so
QQ/lib/gtk-2.0/2.10.0/immodules/im-cedilla.so
QQ/lib/gtk-2.0/2.10.0/immodules/im-cyrillic-translit.so
QQ/lib/gtk-2.0/2.10.0/immodules/im-inuktitut.so
QQ/lib/gtk-2.0/2.10.0/immodules/im-ipa.so
QQ/lib/gtk-2.0/2.10.0/immodules/im-multipress.so
QQ/lib/gtk-2.0/2.10.0/immodules/im-thai.so
QQ/lib/gtk-2.0/2.10.0/immodules/im-ti-er.so
QQ/lib/gtk-2.0/2.10.0/immodules/im-ti-et.so
QQ/lib/gtk-2.0/2.10.0/immodules/im-viqr.so
QQ/lib/gtk-2.0/2.10.0/immodules/im-xim.so
QQ/lib/gtk-2.0/2.10.0/loaders/
QQ/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-ani.so
QQ/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-bmp.so
QQ/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-gif.so
QQ/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-ico.so
QQ/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-jpeg.so
QQ/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-pcx.so
QQ/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so
QQ/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-pnm.so
QQ/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-ras.so
QQ/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-tga.so
QQ/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-tiff.so
QQ/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-wbmp.so
QQ/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-xbm.so
QQ/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-xpm.so
QQ/lib/gtk-2.0/2.10.0/printbackends/
QQ/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-file.so
QQ/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-lpr.so
QQ/lib/libatk-1.0.so.0
QQ/lib/libgdk-x11-2.0.so.0
QQ/lib/libgdk_pixbuf-2.0.so.0
QQ/lib/libgio-2.0.so.0
QQ/lib/libgio-2.0.so.0.0.0
QQ/lib/libglib-2.0.so.0
QQ/lib/libgmodule-2.0.so.0
QQ/lib/libgobject-2.0.so.0
QQ/lib/libgthread-2.0.so.0
QQ/lib/libgtk-x11-2.0.so.0
QQ/lib/libpango-1.0.so.0
QQ/lib/libpangocairo-1.0.so.0
QQ/lib/libpangoft2-1.0.so.0
QQ/lib/libpangox-1.0.so.0
QQ/lib/libpangoxft-1.0.so.0
QQ/lib/libatk-1.0.so.0.2209.1
QQ/lib/libcairo.so.2
QQ/lib/libpango-1.0.so.0.2002.3
QQ/lib/libpangocairo-1.0.so.0.2002.3
QQ/lib/libpangoft2-1.0.so.0.2002.3
QQ/lib/libpangox-1.0.so.0.2002.3
QQ/lib/libpangoxft-1.0.so.0.2002.3
QQ/lib/libglib-2.0.so.0.1600.5
QQ/lib/libgmodule-2.0.so.0.1600.5
QQ/lib/libgobject-2.0.so.0.1600.5
QQ/lib/libgthread-2.0.so.0.1600.5
QQ/lib/libcairo.so.2.11.6
QQ/run-QQ.sh
QQ/share/
QQ/share/locale/
QQ/share/locale/zh_CN/
QQ/share/locale/zh_CN/LC_MESSAGES/
QQ/share/locale/zh_CN/LC_MESSAGES/atk10.mo
QQ/share/locale/zh_CN/LC_MESSAGES/glib20.mo
QQ/share/locale/zh_CN/LC_MESSAGES/gtk20-properties.mo
QQ/share/locale/zh_CN/LC_MESSAGES/gtk20.mo
QQ/share/locale/zh_HK/
QQ/share/locale/zh_HK/LC_MESSAGES/
QQ/share/locale/zh_HK/LC_MESSAGES/atk10.mo
QQ/share/locale/zh_HK/LC_MESSAGES/glib20.mo
QQ/share/locale/zh_HK/LC_MESSAGES/gtk20-properties.mo
QQ/share/locale/zh_HK/LC_MESSAGES/gtk20.mo
QQ/share/locale/zh_TW/
QQ/share/locale/zh_TW/LC_MESSAGES/
QQ/share/locale/zh_TW/LC_MESSAGES/atk10.mo
QQ/share/locale/zh_TW/LC_MESSAGES/glib20.mo
QQ/share/locale/zh_TW/LC_MESSAGES/gtk20-properties.mo
QQ/share/locale/zh_TW/LC_MESSAGES/gtk20.mo
QQ/share/themes/
QQ/share/themes/Default/
QQ/share/themes/Default/gtk-2.0-key/
QQ/share/themes/Default/gtk-2.0-key/gtkrc
QQ/share/themes/Emacs/
QQ/share/themes/Emacs/gtk-2.0-key/
QQ/share/themes/Emacs/gtk-2.0-key/gtkrc
QQ/share/themes/Raleigh/
QQ/share/themes/Raleigh/gtk-2.0/
QQ/share/themes/Raleigh/gtk-2.0/gtkrc
./linuxqq_1.0-Preview2008_i386/
./linuxqq_1.0-Preview2008_i386/ImEngine.cfg
./linuxqq_1.0-Preview2008_i386/IMEngineClient
./linuxqq_1.0-Preview2008_i386/res.db
./linuxqq_1.0-Preview2008_i386/QQ
创建指向“/opt/QQ/run-QQ.sh”的符号链接“/usr/bin/run-QQ”
脚本执行完毕,注意看上面最后一行,创建指向“/opt/QQ/run-QQ.sh”的符号链接“/usr/bin/run-QQ”,也就是说QQ for Linux的启动脚本在什么位置。
接下来我们就进入到/opt/QQ目录下,然后执行 run-QQ.sh 脚本文件:
[root@liufenglinuxqq]# cd /opt/QQ
[root@liufengQQ]# ls -l
总计 7
drwxr-xr-x2 root root 1024 07-31 04:20 bin
drwxr-xr-x4 root root 1024 07-31 19:19 etc
drwxr-xr-x5 root root 3072 07-31 19:51 lib
-rwxr-xr-x1 root root 472 08-01 15:13 run-QQ.sh
drwxr-xr-x4 root root 1024 07-31 19:54 share
[root@liufengQQ]# ./run-QQ.sh
bash:./run-QQ.sh: cannot execute binary file
进入到/opt/QQ目录下后,先确认一下,发现的确有 run-QQ.sh 这个脚本文件,可是执行后却提示说“不能执行一个二进制文件”,别急,还记得先前linuxqq.tar.gz解压后还有另外二个文件吗?其中有一个就是run-QQ.sh,接下来就是用我提供的run-QQ.sh去替换/opt/QQ/run-QQ.sh.
[root@liufengQQ]# cp /root/mylinuxqq/run-QQ.sh /opt/QQ
cp:是否覆盖“/opt/QQ/run-QQ.sh”?Y
[root@liufengQQ]# ./run-QQ.sh
/opt/QQ/bin/QQ:error while loading shared libraries: libexpat.so.1: cannot openshared object file: No such file or directory
替换完成后,再次执行 run-QQ.sh,如果出现的是和上面一样的错误,那么就好办了;上面的错误大概是说“在加载共享库文件的时候没有找到libexpat.so.1这个文件”。
还记得linuxqq.tar.gz解压后还有一个叫libexpat.so.1的文件吧,现在它就派上用场了,不是说找不到libexpat.so.1这个文件吗,我们现在有了,就给它放进去好了,具体存放位置在 /usr/lib 目录下。
[root@liufengQQ]# cp /root/mylinuxqq/libexpat.so.1 /usr/lib
[root@liufengQQ]# ./run-QQ.sh
preparefork engine....
Failedto execl autoupdate ....
QQEngine Running....
IPC_TCP_PORT=9356
将libexpat.so.1文件由先前的 /root/mylinuxqq 下拷贝到 /usr/lib 目录下,然后再次执行脚本 run-QQ.sh,呵呵,你发现什么了,是不是久违的 QQ for Linux 登陆界面跳出来了,呵呵,那还等什么,赶紧登陆上去体验一下吧。
到这里, QQ for Linux的安装已经完成。你不想每次启动 QQ 都要在终端进入到/opt/QQ目录下然后执行 run-QQ.sh 脚本吧?那么就在桌面上为 QQ for Linux 建立一个链接,也就是我们熟悉的快捷方式。
在桌面空白处单击鼠标右键,点新建--应用程序链接,在常规一栏为链接取个名字,就叫QQ好了,接着点击应用程序一栏,描述和注释可填可不填,命令那里点浏览,找到/opt/QQ/run-QQ.sh然后点打开即可,工作路径选择/opt/QQ,点击确定完成。是不是在桌面上看到一个名叫QQ的小齿轮,呵呵,以后再启动QQ直接双击它就可以了。
好了,就写到这里,再次感谢Power_By_RTL,还有其它一些帮助解决此问题的朋友,谢谢你们!看完此帖后,红旗Linux6.0用户如果还有问题,请回帖,我们继续解决;此方法如果解决了你的问题,也请回由此支持一下,让更多的红旗Linux6.0下的还没有用上 QQ for Linux 的朋友看到这篇帖子,谢谢!
需要的附件点击此处下载,下载后先解压得到linuxqq.tar.gz文件备用。


QQ For Linux 不能启动的問題及解決方法(附安装教程)(8月4日更新)

首先要更正 TX 官方網站對於 QQ For Linux 的系統依賴關係
QQ For Linux 要求 Linux 的内核在 2.6.8 或更高, GNU C Library 要求 2.4 或更高, GTK2+ 要求 2.12.x 或更高
官方所列出的最低系統環境根本無法運行 QQ For Linux --!!!