刚学到,来练练手了。不足之处,望高人指正!!拓扑如下:
R2的配置:
R2#show run
Building configuration...
Current configuration : 1050 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
frame-relay switching
!
!
!
interface Serial0/0
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 128000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 103 interface Serial0/1 301
frame-relay route 104 interface Serial0/2 401
!         
interface Serial0/1
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 128000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 301 interface Serial0/0 103
!         
interface Serial0/2
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 128000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 401 interface Serial0/0 104
!         
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!         
ip classless
ip http server
!         
!         
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!         
end      

R1的配置:
R1#show run
Building configuration...
00:19:24: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 551 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
ip subnet-zero
!
!
!
!
!
!
interface Serial0/0
ip address 192.168.1.1 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
!
end
R3的配置:
R3#show run
Building configuration...
Current configuration : 551 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
!
ip subnet-zero
!
!
!
!
!
!
interface Serial0/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/1
ip address 192.168.1.3 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
!
end
R4的配置:
R4#show run
Building configuration...
Current configuration : 610 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R4
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
!
!
!
interface Serial0/0
no ip address
shutdown
serial restart-delay 0
!         
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
ip address 192.168.1.4 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
ip classless
ip http server
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
end
 
 
运行结果: