网络的高可用性

 

一.Linux下的双网卡绑定
网卡绑定技术有助于保证高可用性特性并提供其它优势以提高网络性能,Linux双网卡绑定实现就是使用两块网卡虚拟成为一块网卡,这个聚合起来的设备看起来是一个单独的以太网接口设备,通俗点讲就是两块网卡具有相同的IP地址而并行链接聚合成一个逻辑链路工作,以提供负载均衡或者冗余,增加带宽的作用,这样即使其中的一块物理网卡出现故障,也不会导致连接中断。这种技术被称作bonding。
以Redhat Linux Enterprise 5.4为例,主要步骤如下:
Linux系统有eth0,eth1 两个网卡
1.配置物理ifcfg-eth0和ifcfg-eth1

2.创建网卡配置文件,通过绑定获得的逻辑网卡名称为bond0

3.修改modprobe.conf文件,以使系统在在启动时候加载bonding模块定义别名加入以下内容:


4.编辑开机脚本


5.重新启动
init 6
6.查看状态

二.路由器链路
1.浮动静态路由
浮动静态路由是一种特殊的静态路由,通过配置一个比主路由的管理距离更大的静态路由,保证网络中主路由失效的情况下,提供备份路由。但在主路由存在的情况下它不会出现在路由表中。浮动静态路由主要用于拔号备份
案例
通过本实验可以掌握静态路由的原理,配置以及备份应用
拓扑图

 

实验步骤

R1

 

 

 

R2

 

 

 

结果测试

ping过程断开s0 ,发现先超时后又回复 

 

 

2.standby interface
在正常链路的接口上去指明备份接口就行了  (需要配置启用备份接口定时器,默认是立刻切换)
standby  timer enable-delay seconds 设置从主接口切换到备用接口的延时
standby  timer disable-delay seconds  设置从备用接口切换到主接口的延时
 
standby threshold  enable-threshold  disable-threshold负载分担配置
缺省情况下,没有使能接口的备份负载分担功能
案例
拓扑图

 

实验过程:

R1

 

 

R2

 

结果测试

 

 

3.MP多链路捆绑
原理知识:
PPP Multilink协议(MP)是PPP(点对点协议)的扩展,它具有绑定两条或多条同步并行连接的能力。所产生的虚拟连接拥有的带宽等于各条独立连接的带宽的总和。
在PPP协议中,可以将多个PPP链路捆绑起来,形成一条宽更大的PPP链路,成为PPP Multilink,即多链路PPP。
多链路PPP通常应用在用户原有的PPP链路带宽要够,然后又申请看一条新PPP链路的情况下。为了达到不对原有的配置进行的更改,而且两条PPP链路均能被利用的目的,可以使用多链路PPP技术。
当在路由器上配置了多链路PPP之后,相当于在路由器上形成了一个新的PPP多链路接口(Multilink-group Interface)。此接口包含看其他的普通PPP接口,关于PPP协议的各种配置。如IP地址等均在此PPP模板接口上配置即可。这样,对于路由器来说就相当于有人一个大带宽的PPP接口。
虽然目前数据链路的带宽越来越大,多链路PPP使用的范围也越来越窄,但多链路PPP还有自己的一些有点:
  (1)增加带宽
多条PPP链路捆绑起来,能够增加原有的PPP链路带快,同时使用一个IP地址,而不需要每条PPP链路都进行配置。如果同动态拨号结合起来,多链路PPP可以做到动态增加或减小带宽
  (2)负载分担
多链路PPP能够实现报文在不同PPP链路上的负载分担。对于想、速率高的PPP链路,传输的报文就要多谢,对于速率低的PPP链路,传输的报文就要小些。
  (3)利用分片降低时延
当报文在多链路PPP上传输时,通常会被划分成多个分片在多链路上同时传输。这样对于比较大的报文,。就可以降低传输的时延。
  (4)PPP Multilink协议它的最好的一个功能是,他可以多链路冗余,也就是说一条物理链路down或是损坏的话,不影响数据的传输。
案例
拓扑图

 

实验过程:

R1

 

R2

 

 

 

 

结果测试:

 

  三. 虚拟路由器冗余协议vrrp
虚拟路由器冗余协议(VRRP)是一种选择协议,它可以把一个虚拟路由器的责任动态分配到局域网上的 VRRP 路由器中的一台。控制虚拟路由器 IP 地址的 VRRP 路由器称为主路由器,它负责转发数据包到这些虚拟 IP 地址。一旦主路由器不可用,这种选择过程就提供了动态的故障转移机制,这就允许虚拟路由器的 IP 地址可以作为终端主机的默认第一跳路由器。使用 VRRP 的好处是有更高的默认路径的可用性而无需在每个终端主机上配置动态路由或路由发现协议。 VRRP 包封装在 IP 包中发送。
详细介绍及案例请参考
http://gaosc900926.blog.51cto.com/4449050/805203
四. 热备份路由协议HSRP
介绍
HSRP:热备份路由器协议(HSRP:Hot Standby Router Protocol),是cisco平台一种特有的技术,是cisco的私有协议。热备份路由器协议(HSRP)的设计目标是支持特定情况下 IP 流量失败转移不会引起混乱、并允许主机使用单路由器,以及即使在实际第一跳路由器使用失败的情形下仍能维护路由器间的连通性。换句话说,当源主机不能动态知道第一跳路由器的 IP 地址时,HSRP 协议能够保护第一跳路由器不出故障。
工作原理
负责转发数据包的路由器称之为活动路由器(Active Router)。一旦主动路由器出现故障,HSRP 将激活备份路由器(Standby Routers)取代主动路由器。HSRP 协议提供了一种决定使用主动路由器还是备份路由器的机制,并指定一个虚拟的 IP 地址作为网络系统的缺省网关地址。如果主动路由器出现故障,备份路由器(Standby Routers)承接主动路由器的所有任务,并且不会导致主机连通中断现象。
  HSRP 运行在 UDP 上,采用端口号1985。路由器转发协议数据包的源地址使用的是实际 IP 地址,而并非虚拟地址,正是基于这一点,HSRP 路由器间能相互识别.
案例

拓扑图

基本配置:
R1
interface Ethernet1/1
 ip address 123.123.123.1 255.255.255.0
!
ip default-gateway 123.123.123.123
!
ip route 6.6.6.0 255.255.255.0 123.123.123.123

R2
interface Serial0/2
 ip address 26.26.26.2 255.255.255.0
!
interface Ethernet1/1
 ip address 123.123.123.2 255.255.255.0
standby 1 ip 123.123.123.123

router rip
 version 2
 network 26.0.0.0
 network 123.0.0.0
R3
interface Serial0/3
 ip address 36.36.36.3 255.255.255.0
!
interface Ethernet1/1
 ip address 123.123.123.3 255.255.255.0
 half-duplex
 standby 1 ip 123.123.123.123
 standby 1 timers 5 15
 standby 1 priority 150
 standby 1 preempt

router rip
 version 2
 network 36.0.0.0
 network 123.0.0.0

R6
interface Serial0/2
 ip address 26.26.26.6 255.255.255.0
!
interface Serial0/3
 ip address 36.36.36.6 255.255.255.0
interface Loopback0
 ip address 6.6.6.6 255.255.255.0
!
router rip
 version 2
 network 6.0.0.0
 network 26.0.0.0
 network 36.0.0.0

实验验证:
当关闭R3的E1/1时,

R3(config)#int e1/1
R3(config-if)#shut
*Mar  1 03:42:15.515: %HSRP-5-STATECHANGE: Ethernet1/1 Grp 1 state Active -> Init
*Mar  1 03:42:17.531: %LINK-5-CHANGED: Interface Ethernet1/1, changed state to administratively down
*Mar  1 03:42:18.531: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet1/1, changed state to down

R2#
*Mar  1 03:42:15.967: %HSRP-5-STATECHANGE: Ethernet1/1 Grp 1 state Standby -> Active
R2#

R1#traceroute 6.6.6.6

Type escape sequence to abort.
Tracing the route to 6.6.6.6
  1 123.123.123.2 96 msec 84 msec 76 msec
  2 26.26.26.6 16 msec 32 msec *
当再次开启R3 的E1/1时:
R3(config-if)#no shutdown
*Mar  1 03:47:42.531: %LINK-3-UPDOWN: Interface Ethernet1/1, changed state to up
*Mar  1 03:47:43.531: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet1/1, changed state to up
*Mar  1 03:47:45.579: %HSRP-5-STATECHANGE: Ethernet1/1 Grp 1 state Listen -> Active


R2#
*Mar  1 03:47:46.055: %HSRP-5-STATECHANGE: Ethernet1/1 Grp 1 state Active -> Speak
R2#
*Mar  1 03:48:01.051: %HSRP-5-STATECHANGE: Ethernet1/1 Grp 1 state Speak -> Standby
R2#
五. 端口汇聚
TRUNK是端口汇聚的意思,就是通过配置软件的设置,将2个或多个物理端口组合在一起成为一条逻辑的路径从而增加在交换机和网络节点之间的带宽,将属于这几个端口的带宽合并,给端口提供一个几倍于独立端口的独享的高带宽。Trunk是一种封装技术,它是一条点到点的链路,链路的两端可以都是交换机,也可以是交换机和路由器,还可以是主机和交换机或路由器。基于端口汇聚(Trunk)功能,允许交换机与交换机、交换机与路由器、主机与交换机或路由器之间通过两个或多个端口并行连接同时传输以提供更高带宽、更大吞吐量, 大幅度提供整个网络能力。
基本命令
进入系统视图  system-view
创建汇聚组  link-aggregation group agg-id mode manual
进入以太网端口视图  interface interface-type interface-number
将以太网端口加入汇聚组  port link-aggregation group agg-id
显示所有汇聚组的摘要信息  display link-aggregation summary
显示端口的端口汇聚详细信息  display link-aggregation interface interface-type interface-number [ to interface-type interface-number ]
 
案例
组网需求
以太网交换机 Switch A使用 2个端口(Ethernet1/0/1~Ethernet1/0/2)汇聚接入以太网交换机 Switch B,实现出/入负荷在各成员端口中的负载分担。
拓扑图:


基本步骤:
Switch 1
#system-view
#link-aggregation group 1 mode manual 模式 手工聚合
#int e1/0/1
#port link-aggregation group 1 把端口1加入到聚合组1
#int e1/0/2
#port link-aggregation group 1
#display link-aggregation summary 查看所配置的聚合组信息
Switch 2
#system-view
#link-aggregation group 1 mode manual 模式 手工聚合
#int e1/0/1
#port link-aggregation group 1 把端口1加入到聚合组1
#int e1/0/2
#port link-aggregation group 1
#display link-aggregation summary 查看所配置的聚合组信息
六. MSTP
STP (Spanning Tree Protocol,生成树协议)不能使端口状态快速迁移,即使是在
点对点链路或边缘端口,也必须等待2 倍的Forward delay 的时间延迟,端口才能
迁移到转发状态。
RSTP(Rapid Spanning Tree Protocol,快速生成树协议)可以快速收敛,但是和
STP 一样存在以下缺陷:局域网内所有网桥共享一棵生成树,不能按 VLAN 阻塞冗
余链路,所有VLAN 的报文都沿着一棵生成树进行转发。
MSTP(Multiple Spanning Tree Protocol,多生成树协议)将环路网络修剪成为一
个无环的树型网络,避免报文在环路网络中的增生和无限循环,同时还提供了数据
转发的多个冗余路径,在数据转发过程中实现VLAN 数据的负载均衡。
MSTP 兼容 STP 和RSTP,并且可以弥补STP 和RSTP 的缺陷。它既可以快速收
敛,也能使不同VLAN 的流量沿各自的路径分发,从而为冗余链路提供了更好的负
载分担机制。
案例
拓扑图


 
Sw1配置:
#
 link-aggregation group 1 mode manual
#
 stp instance 1 root primary  
 stp enable
stp region-configuration
 region-name test   
 revision-level 1   
 instance 1 vlan 10 to 20 
 instance 2 vlan 30 to 40 
 active region-configuration 
#
vlan 1
#
vlan 10
#                                        
vlan 20
#
vlan 30
#
vlan 40
#
interface Ethernet1/0/1
 port link-type trunk做trunk端口
 port trunk permit vlan all 允许所有vlan经过turnk链路。
#
interface Ethernet1/0/2
 port link-type trunk
 port trunk permit vlan all
 port link-aggregation group 1
#
interface Ethernet1/0/3
 port link-type trunk
 port trunk permit vlan all
 port link-aggregation group 1
interface Ethernet1/0/4                  
 port link-type trunk
 port trunk permit vlan all
查看链路聚合:
[sw1]dis link-aggregation summary
Aggregation Group Type:D -- Dynamic, S -- Static , M -- Manual
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Actor ID: 0x8000, 000f-e242-8a41
  AL  AL   Partner ID            Select Unselect Share Master
  ID  Type                       Ports  Ports    Type  Port
--------------------------------------------------------------------------------
  1   M    none                  2      0        Shar  Ethernet1/0/2 

[sw1]dis stp instance 1
-------[MSTI 1 Global Info]-------
MSTI Bridge ID      :1.000f-e274-4920
MSTI RegRoot/IRPC   :1.000f-e274-4920 / 0
MSTI RootPortId     :0.0
MSTI Root Type      :PRIMARY root
Master Bridge       :32768.000f-e242-8a41
Cost to Master      :180
TC or TCN received  :47
 ----[Port1(Ethernet1/0/1)][FORWARDING]----
 Port Role           :Designated Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :1.000f-e274-4920 / 128.1
 Num of Vlans Mapped :2
 Port Times          :RemHops 20
 ----[Port2(Ethernet1/0/2)][FORWARDING]----
 Port Role           :Designated Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=180
 Desg. Bridge/Port   :1.000f-e274-4920 / 128.2
 Num of Vlans Mapped :2
 Port Times          :RemHops 20
                                         
 ----[Port4(Ethernet1/0/4)][DISCARDING]----
 Port Role           :Alternate Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :1.000f-e274-4920 / 128.4
 Num of Vlans Mapped :2
 Port Times          :RemHops 20
[sw1]dis stp instance 2
-------[MSTI 2 Global Info]-------
MSTI Bridge ID      :32770.000f-e274-4920
MSTI RegRoot/IRPC   :2.000f-e242-8a41 / 180
MSTI RootPortId     :128.2
Master Bridge       :32768.000f-e242-8a41
Cost to Master      :180
TC or TCN received  :51
 ----[Port1(Ethernet1/0/1)][FORWARDING]----
 Port Role           :Designated Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :32770.000f-e274-4920 / 128.1
 Num of Vlans Mapped :2
 Port Times          :RemHops 19
 ----[Port2(Ethernet1/0/2)][FORWARDING]----
 Port Role           :Root Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=180
 Desg. Bridge/Port   :2.000f-e242-8a41 / 128.2
 Num of Vlans Mapped :2
 Port Times          :RemHops 20
 ----[Port4(Ethernet1/0/4)][DISCARDING]----
 Port Role           :Alternate Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :32770.000f-e274-4920 / 128.4
 Num of Vlans Mapped :2
 Port Times          :RemHops 19
sw2的配置:
#
 link-aggregation group 1 mode manual
stp instance 2 root primary
 stp enable
stp region-configuration
 region-name test
 revision-level 1
 instance 1 vlan 10 to 20
 instance 2 vlan 30 to 40
 active region-configuration
#
vlan 1
#
vlan 10
#                                        
vlan 20                                  
#
vlan 30
#
vlan 40
#
#
interface Ethernet1/0/2
 port link-type trunk
 port trunk permit vlan all
 port link-aggregation group 1
#
interface Ethernet1/0/3
 port link-type trunk
 port trunk permit vlan all
 port link-aggregation group 1 #
interface Ethernet1/0/4
#
interface Ethernet1/0/5
 port link-type trunk                    
 port trunk permit vlan all
#
interface Ethernet1/0/6
 port link-type trunk
 port trunk permit vlan all
查看链路聚合的汇总信息:
[sw2]dis link-aggregation summary
Aggregation Group Type:D -- Dynamic, S -- Static , M -- Manual
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Actor ID: 0x8000, 000f-e242-8a41
  AL  AL   Partner ID            Select Unselect Share Master
  ID  Type                       Ports  Ports    Type  Port
--------------------------------------------------------------------------------
  1   M    none                  2      0        Shar  Ethernet1/0/2 
查看instance信息:
[sw2]dis stp instance 1
-------[MSTI 1 Global Info]-------
MSTI Bridge ID      :32768.000f-e242-8a41
MSTI RegRoot/IRPC   :0.000f-e274-4920 / 180  区域根桥。
MSTI RootPortId     :128.2
Master Bridge       :32768.000f-e242-8a41
Cost to Master      :0
TC or TCN received  :11
 ----[Port2(Ethernet1/0/2)][FORWARDING]----
 Port Role           :Root Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=180
 Desg. Bridge/Port   :0.000f-e274-4920 / 128.2
 Num of Vlans Mapped :2
 Port Times          :RemHops 20
 ----[Port5(Ethernet1/0/5)][FORWARDING]----
 Port Role           :Master Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :32768.000f-e242-8a41 / 128.5
 Num of Vlans Mapped :2
 Port Times          :RemHops 19
  ---- More ----
%Apr  2 02:01:20:182 2000 sw3 SHELL/5/LOGOUT:- 1 - user1(192.168.100.187) in unit1 logout
#Apr  2 02:01:24:549 2000 sw3 L2INF/2/PORT LINK STATUS CHANGE:- 1 -
 Trap 1.3.6.1.6.3.1.1.5.3: portIndex is 4227810, ifAdminStatus is 1, ifOperStatus is 2
%Apr  2 02:01:24:726 2000 sw3 L2INF/5/PORT LINK STATUS CHANGE:- 1 -
 Ethernet1/0/24: is DOWN
 ----[Port6(Ethernet1/0/6)][FORWARDING]----
 Port Role           :Designated Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :32768.000f-e242-8a41 / 128.6
 Num of Vlans Mapped :2
 Port Times          :RemHops 19
Sw3配置:
#
 stp enable
stp region-configuration
 region-name test
 revision-level 1
 instance 1 vlan 10 to 20
instance 2 vlan 30 to 40
 active region-configuration
#
vlan 1
#
vlan 10
#
vlan 20
vlan 30
vlan 40
interface Ethernet1/0/1
 port link-type trunk
 port trunk permit vlan all
interface Ethernet1/0/6
 port link-type trunk
 port trunk permit vlan all
#
[sw3]dis stp instance 1
-------[MSTI 1 Global Info]-------
MSTI Bridge ID      :32769.000f-e274-2158
MSTI RegRoot/IRPC   :32769.000f-e274-2158 / 0
MSTI RootPortId     :0.0
Master Bridge       :32768.000f-e274-2158
Cost to Master      :0
TC or TCN received  :0
 ----[Port1(Ethernet1/0/1)][DISCARDING]----
 Port Role           :Alternate Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :32769.000f-e274-2158 / 128.1
 Num of Vlans Mapped :2
 Port Times          :RemHops 20
 ----[Port6(Ethernet1/0/6)][FORWARDING]----
 Port Role           :Master Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :32769.000f-e274-2158 / 128.6
 Num of Vlans Mapped :2
 Port Times          :RemHops 20
Sw4的配置:
stp enable
stp region-configuration
 region-name test
 revision-level 1
instance 1 vlan 10 to 20
 instance 2 vlan 30 to 40
 active region-configuration
#
vlan 1
vlan 10
vlan 20
#
vlan 30
#
vlan 40
interface Ethernet1/0/4
 port link-type trunk
 port trunk permit vlan all 做trunk端口。
#
interface Ethernet1/0/5
 port link-type trunk
 port trunk permit vlan all
查看mst实例2的状态:
[sw4]display stp instance 2
-------[MSTI 1 Global Info]-------
MSTI Bridge ID      :32769.000f-e274-2158
MSTI RegRoot/IRPC   :32769.000f-e274-2158 / 0
MSTI RootPortId     :0.0
Master Bridge       :32768.000f-e274-2158
Cost to Master      :0
TC or TCN received  :0
 ----[Port1(Ethernet1/0/1)][FORWARDING]----
 Port Role           :Master Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :32769.000f-e274-2158 / 128.1
 Num of Vlans Mapped :2
 Port Times          :RemHops 20
 ----[Port6(Ethernet1/0/6)][DISCARDING]----
 Port Role           : Alternate Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :32769.000f-e274-2158 / 128.6
 Num of Vlans Mapped :2
 Port Times          :RemHops 20