在linux下安装rpm包时经常会遇到下面这个问题: 
error: Failed dependencies: 
       xxxxxxxxxxxxxxxxxxxxxx 


遇到此问题时可以在安装rpm包命令的后面加两个参数,如: 

rpm -ivh jdk-1_5_0_07-linux-i586.rpm 
改成: 
rpm -ivh jdk-1_5_0_07-linux-i586.rpm --nodeps --force 

加上那两个参数的意义就在于, 
安装时不再分析包之间的依赖关系而直接安装, 
也就不会再提示error: Failed dependencies:这样的错误了。