【参考】:

https://www.elastic.co/guide/en/marvel/current/installing-marvel.html


实施步骤(安装elk前一定要规划好,marvel是对ELK的elasticsearch和kinaba有版本要求的)


【我的安装版本是】 我的elasticsearch是rpm包安装的

Marvel 2.2.1 requires:

 

Elasticsearch 2.2.1.

Kibana 4.4.0.

A modern web browser - Supported Browsers.


【步骤】

cd /usr/share/elasticsearch

bin/plugin install file:///path/to/file/license-2.2.1.zip

bin/plugin install file:///path/to/file/marvel-agent-2.2.1.zip

bin/kibana plugin --install marvel --url file:///path/to/file/marvel-2.2.1.tar.gz

 

 

 

实际步骤:(主节点上含有kinaba的节点操作)

 cd /usr/share/elasticsearch/

 ./bin/plugin install file:///data1/elk/license-2.2.1.zip
 ./bin/plugin install file:///data1/elk/marvel-agent-2.2.1.zip
 ./data1/elk/kibana/bin/kibana plugin --install marvel --url file:///data1/elk/marvel-2.2.1.tar.gz



实际步骤:(其他ES节点上的操作)


 ./bin/plugin install file:///data1/elk/license-2.2.1.zip
 ./bin/plugin install file:///data1/elk/marvel-agent-2.2.1.zip



安装成功后:

重启kinaba

ES的各个节点都要重启

/etc/init.d/elasticsearch restart



【结果】

wKioL1c5uFbAQ9umAABhYMRJWVg444.png





【安装过程中可能遇到的错误及解决方法】



1版本不对

解决方法,参考官网安装对于适合marvel的ELK版本


wKiom1c5t9DQaYF3AADBy4Ogz0k062.png




2 没有任何数据,解决方法,你没有重启elasticsearch 和其他所有节点的elasticsearch

wKioL1c5uLiCNN_4AABi7TfAgF0609.png