如何允许外网用户telnet至pix的outside?
补充一下
licensed features:
***-des: enabled
***-3des: disabled

用ssh就可以。 telnet不可以!

对inside 倒dmz的访问,需要做nat配 cript language=javascript src="/cms/js/newsad.js"> 置,对于dmz到inside的访问,需要做static 与access-list的配置。

pix 515e连接adsl 路由modem!

想知道e0口上怎么配置与开启路由的modem的连接。让内网所有用户可以都通过这个modem上网。
adsl modem ip:192.168.1.1
pixfirwall(c group <组名> request dialout pppoe
pixfirwall(c group <组名> ppp auth pap/chap/mschap
pixfirwall(c group <组名> localname <拨号的用户名>
pixfirwall(c username <用户名> password <密码>
pixfirwall(c add <接口名称-随便定义> pppoe




我想通过在pix 515e 上进行设置使某些内网用户只能上一个特定的网站

当前配置如下:

pix version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100

hostname pixfirewall
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 61.155.88.82 255.255.255.252
ip address inside 10.10.3.253 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 3 interface
nat (inside) 3 10.10.1.1 255.255.255.255 0 0
nat (inside) 3 10.10.1.9 255.255.255.255 0 0
nat (inside) 3 10.10.1.81 255.255.255.255 0 0
nat (inside) 3 10.10.1.82 255.255.255.255 0 0
nat (inside) 3 10.10.1.113 255.255.255.255 0 0
nat (inside) 3 10.10.1.161 255.255.255.255 0 0
nat (inside) 3 10.10.1.162 255.255.255.255 0 0
nat (inside) 3 10.10.1.165 255.255.255.255 0 0
nat (inside) 3 10.10.1.240 255.255.255.255 0 0
nat (inside) 3 10.10.2.240 255.255.255.248 0 0
nat (inside) 3 10.10.1.240 255.255.255.240 0 0
route outside 0.0.0.0 0.0.0.0 61.155.88.81 1
route inside 10.0.0.0 255.0.0.0 10.10.3.254 1
timeout xlate 3:00:00
timeout c 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc

0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media

0:02:00
timeout uauth 0:05:00 absolute
aaa-server tacacs+ protocol tacacs+
aaa-server radius protocol radius
aaa-server local protocol local
no snmp-server location
no snmp-server c
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh timeout 5
c timeout 0
terminal width 80
cryptochecksum:72a261056ba18f4dbefab375fb871688
: end


是的,可以将针对这些主机的限制策略放在acl的最上端,应用在inside口的in的方向上。

你可以用支持时间的acl来做,也可以用tacacs来验证用户,定义downloaded acl


请教pix515 acl 如何屏蔽一个网段?

deny ip host 61.129.64.* any
61.129.64.*这样的网段该咋样屏蔽?


juechen70 (版主)
deny ip 61.129.64.0 255.255.255.0

csco10334975 (普通用户)
deny ip 61.129.64.0 255.255.255.0 any


mythis (普通用户)
access-list 100 deny ip 61.129.64.0 255.255.255.0 any


pix上启用了dhcp,不允许内网自动获取只允许dmz自动获如何做。

dhcpd address 192.118.0.5-192.118.0.254 dmz
dhcpd enable dmz
dhcpd dns 219.141.136.10 218.247.141.68
这样就可以了!


pix7.0 如何在routed 和 transparent 两种方式中切换?
我的pix 515e 升级到pix7.01 我想使用 transparent 模式, 请大家教如何做了?

firewall transparent
no firewall transparent

在515e中配置dhcp网关的命令是什么
dhcpd enable inside


pix能不能实现dmz和inside透明模式呢?

有客户想把服务器搬到dmz区,但是服务器地址不变,这样除了透明模式我还想不到其他办法,inside和outside的透明 模式我知道,但是

inside和dmz的透明模式怎么办?地址必须改变。透明桥模式下是没有dmz概念的。地址不变也可以.做地址映射的时候翻译 相同的地址就行了. 但是想搬到dmz区的机器和inside区的机器是同一网段的服务器和用户都是用一网段的,不改变地址怎么搞?

如何配置pix透明模式?

首先,需要升级pix os到7.0.1
直接输入firewall transparent 命令就可以让pix工作在透明模式下面。 工作在透明模式下时,pix相当于一条网线,故障切换由其它的三层设

备完成。
做防火墙的策略一般多是和端口对应的,外网在透明模式时怎样访问内网htti.https.pptp,tcp/udp-5060 /1270


有一点,透明模式下必须设置管理地址才会通
有所变化,以前用PIX515双机作failover,pix os版本好像是6.3就不支持透明模式.看来透明模式的应用还是挺多的,可以做网络分区之间的安全隔离,最重要的是可以让动态路 由协议穿过.


如何看用命令看这两台pix支持的最大连接数(不是使用中的最大连接数,而是license所限制的最大连接数)
show ver.

为什么ping不通515e的outside地址?
pix的版本是6.3(4),设置了515e的outside地址和inside地址后,用网线将笔记本和515e的outsi de端口联起来,本本的地址和outside地址在

一个网段内,但总是ping不通outside地址,但同样的配置在6.2版本的515e上使用时是没有问题的,好奇怪啊??

icmp pemit any outside

========================================================

pix ***设置好了,ddn方式可以上,为什么家里的adsl不行?

配置如下:pix520

pix version 6.3(3)
interface ethernet0 100full
interface ethernet1 100full
interface ethernet2 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 outside-dmz security50
enable password gybjrem5y/fijrzb encrypted
passwd eno4olec9w1amawd encrypted
hostname pix-yinhetech
domain-name test.cn
clock timez cst 8
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol ftp 2121
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
no fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 10.128.1.0 notebookpoolip
access-list n permit ip 10.10.0.0 255.255.0.0 notebookpoolip 255.255.255.0
access-list 101 permit ip 10.10.0.0 255.255.0.0 any
access-list notebookpc_splittunnelacl permit ip 10.10.0.0 255.255.0.0 any
access-list notebookpc_splittunnelacl permit ip notebookpoolip 255.255.255.0 any
access-list notebookpc_splittunnelacl permit ip host 10.6.4.11 any
access-list outside_cryptomap_dyn_20 permit ip any notebookpoolip 255.255.255.0
access-list outside_cryptomap_dyn_20 permit ip notebookpoolip 255.255.255.0 any
pager lines 24
logging on
logging standby
logging buffered debugging
logging trap notificati
icmp deny any outside
mtu outside 1500
mtu inside 1500
mtu outside-dmz 1500
ip address outside ***.***.***.** 255.255.255.240
ip address inside 10.127.1.253 255.255.255.0
ip address outside-dmz 172.18.3.254 255.255.255.0
ip verify reverse-path interface outside
ip verify reverse-path interface inside
ip audit info action alarm
ip audit attack action alarm
ip local pool notebookpool 10.128.1.1-10.128.1.250
no failover
failover timeout 0:00:00
failover poll 15
no failover ip address outside
no failover ip address inside
no failover ip address outside-dmz
pdm history enable
arp timeout 14400
global (outside) 1 ***.***.***.** netmask 255.255.255.240
global (outside-dmz) 1 172.18.3.200-172.18.3.250 netmask 255.255.255.0
nat (inside) 0 access-list n
nat (inside) 1 10.0.0.0 255.128.0.0 0 0
access-group 101 in interface inside
route outside 0.0.0.0 0.0.0.0 ***.***.***.** 1
route inside 10.0.0.0 255.128.0.0 10.127.1.254 1
timeout xlate 3:00:00
timeout c 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server tacacs+ protocol tacacs+
aaa-server radius protocol radius
aaa-server local protocol local
http server enable
http 10.10.10.74 255.255.255.255 inside
http 10.10.10.88 255.255.255.255 inside
snmp-server host inside 10.10.10.10
snmp-server host inside 10.10.10.74
snmp-server location soft_yuan_internet
snmp-server c bill
snmp-server community public
snmp-server enable traps
tftp-server inside 10.10.10.74 /
no floodguard enable
sysopt c permit-ipsec
crypto ipsec transform-set esp-des-md5 esp-des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set esp-des-md5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp identity address
isakmp keepalive 60 5
isakmp nat-traversal 120
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
***group notebookpc address-pool notebookpool
***group notebookpc dns-server 10.10.10.68 202.103.224.68
***group notebookpc default-domain yhgroup.cn
***group notebookpc split-tunnel notebookpc_splittunnelacl
***group notebookpc idle-time 1800
***group notebookpc password ********
telnet 10.0.0.0 255.128.0.0 inside
telnet 10.10.10.110 255.255.255.255 inside
telnet 10.10.10.110 255.255.255.255 outside-dmz
telnet timeout 31
ssh timeout 5
c timeout 0
terminal width 80
cryptochecksum:826ec1728f5df3bb3ecf0542790a4d35



surf_qj (普通用户)

对了,是使用cisco system *** client 4.01登录的,家里adsl可以连上***,但是不能访问,ddn就可以其实,不光是pix问题,我用2620做的和你的也一 样,用一般的adsl是不行的,但如果是用带路由功能adsl就可以。

isakmp nat-traversal 120
还有客户端nat打开,估计是nat穿透的问题吧。

========================================================

pix515的问题


具体现象是,dmz和inside各接一台单机,dmz的单机能用上网,其他不能,inside的机器什么都干不了。单机保证无 问题。请各位帮忙看看配置吧。 outside的地址和global的地址不同,有影响么?(没有空闲的连续地址了,只能用两个不同地址表示一下)
pix version 6.2(2)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 dmz security50
enable password o53fpnrghka6iesy encrypted
passwd twjti1emvjruv4sy encrypted
hostname jygatewall
domain-name 219.2.2.2
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sqlnet 1521
fixup protocol sip 5060
no fixup protocol skinny 2000
no fixup protocol smtp 25
names
access-list dmz_jygate_acl deny icmp any any
access-list dmz_jygate_acl permit udp any any eq domain
access-list dmz_jygate_acl permit tcp any any eq www
access-list dmz_jygate_acl permit udp any any eq 20
access-list dmz_jygate_acl permit tcp any host 219.150.1.1 eq 20817
access-list dmz_jygate_acl permit tcp any host 219.150.1..1eq 20820
access-list dmz_jygate_acl permit tcp any host 219.150.1.1 eq 8080
access-list dmz_jygate_acl permit tcp any host 219.150.1.1 eq 8383
access-list dmz_jygate_acl permit tcp any host 219.150.1.1 eq 32002
pager lines 24
interface ethernet0 100full
interface ethernet1 100full
interface ethernet2 100full
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip address outside 219.150.1.2 255.255.255.224
ip address inside 192.168.168.1 255.255.255.0
ip address dmz 172.172.172.1 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
no failover
failover timeout 0:00:00
failover poll 15
failover ip address outside 0.0.0.0
failover ip address inside 0.0.0.0
failover ip address dmz 0.0.0.0
pdm history enable
arp timeout 14400
global (outside) 1 219.150.1.2
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (dmz,outside) 219.150.1.2 172.172.172.101 netmask 255.255.255.255 0 0

static (inside,dmz) 192.168.168.0 192.168.168.0 netmask 255.255.255.0 0 0
access-group dmz_jygate_acl in interface outside
access-group dmz_jygate_acl in interface dmz
route outside 0.0.0.0 0.0.0.0 219.150.1.3 1
timeout xlate 3:00:00
timeout c 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si
p 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server tacacs+ protocol tacacs+
aaa-server radius protocol radius
aaa-server local protocol local
no snmp-server location
no snmp-server c
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt security fragguard
no sysopt route dnat
telnet timeout 5
ssh timeout 5
terminal width 80
cryptochecksum:594b9bbf77abf8a342afee1764e4f7cd
: end


nyb0319 (普通用户)

no static (inside,dmz) 192.168.168.0 192.168.168.0 netmask 255.255.255.0 0 0
改为static (inside,dmz) 172.172.172.1 192.168.168.0 netmask 255.255.255.0 0 0

加一条

static (inside,outside)
219.150.1.2 192.168.168.0
netmask 255.255.255.0 0 0

no access-group dmz_jygate_acl in interface dmz


crazytank (普通用户)


按照上面的提示改了,结果提示global address overlaps with mask 请各位大侠再帮忙看看啊


lcschina (活跃用户) ip address outside 219.150.1.2 255.255.255.224

global (outside) 1 219.150.1.2

地址重叠!!!
加上 global (outside) 1 interface 去掉你的那个global
如何允许外网用户telnet至pix的outside?
补充一下
licensed features:
***-des: enabled
***-3des: disabled

用ssh就可以。 telnet不可以!

对inside 倒dmz的访问,需要做nat配 cript language=javascript src="/cms/js/newsad.js"> 置,对于dmz到inside的访问,需要做static 与access-list的配置。

pix 515e连接adsl 路由modem!

想知道e0口上怎么配置与开启路由的modem的连接。让内网所有用户可以都通过这个modem上网。
adsl modem ip:192.168.1.1
pixfirwall(c group <组名> request dialout pppoe
pixfirwall(c group <组名> ppp auth pap/chap/mschap
pixfirwall(c group <组名> localname <拨号的用户名>
pixfirwall(c username <用户名> password <密码>
pixfirwall(c add <接口名称-随便定义> pppoe




我想通过在pix 515e 上进行设置使某些内网用户只能上一个特定的网站

当前配置如下:

pix version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100

hostname pixfirewall
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 61.155.88.82 255.255.255.252
ip address inside 10.10.3.253 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 3 interface
nat (inside) 3 10.10.1.1 255.255.255.255 0 0
nat (inside) 3 10.10.1.9 255.255.255.255 0 0
nat (inside) 3 10.10.1.81 255.255.255.255 0 0
nat (inside) 3 10.10.1.82 255.255.255.255 0 0
nat (inside) 3 10.10.1.113 255.255.255.255 0 0
nat (inside) 3 10.10.1.161 255.255.255.255 0 0
nat (inside) 3 10.10.1.162 255.255.255.255 0 0
nat (inside) 3 10.10.1.165 255.255.255.255 0 0
nat (inside) 3 10.10.1.240 255.255.255.255 0 0
nat (inside) 3 10.10.2.240 255.255.255.248 0 0
nat (inside) 3 10.10.1.240 255.255.255.240 0 0
route outside 0.0.0.0 0.0.0.0 61.155.88.81 1
route inside 10.0.0.0 255.0.0.0 10.10.3.254 1
timeout xlate 3:00:00
timeout c 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc

0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media

0:02:00
timeout uauth 0:05:00 absolute
aaa-server tacacs+ protocol tacacs+
aaa-server radius protocol radius
aaa-server local protocol local
no snmp-server location
no snmp-server c
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh timeout 5
c timeout 0
terminal width 80
cryptochecksum:72a261056ba18f4dbefab375fb871688
: end


是的,可以将针对这些主机的限制策略放在acl的最上端,应用在inside口的in的方向上。

你可以用支持时间的acl来做,也可以用tacacs来验证用户,定义downloaded acl


请教pix515 acl 如何屏蔽一个网段?

deny ip host 61.129.64.* any
61.129.64.*这样的网段该咋样屏蔽?


juechen70 (版主)
deny ip 61.129.64.0 255.255.255.0

csco10334975 (普通用户)
deny ip 61.129.64.0 255.255.255.0 any


mythis (普通用户)
access-list 100 deny ip 61.129.64.0 255.255.255.0 any


pix上启用了dhcp,不允许内网自动获取只允许dmz自动获如何做。

dhcpd address 192.118.0.5-192.118.0.254 dmz
dhcpd enable dmz
dhcpd dns 219.141.136.10 218.247.141.68
这样就可以了!


pix7.0 如何在routed 和 transparent 两种方式中切换?
我的pix 515e 升级到pix7.01 我想使用 transparent 模式, 请大家教如何做了?

firewall transparent
no firewall transparent

在515e中配置dhcp网关的命令是什么
dhcpd enable inside


pix能不能实现dmz和inside透明模式呢?

有客户想把服务器搬到dmz区,但是服务器地址不变,这样除了透明模式我还想不到其他办法,inside和outside的透明 模式我知道,但是

inside和dmz的透明模式怎么办?地址必须改变。透明桥模式下是没有dmz概念的。地址不变也可以.做地址映射的时候翻译 相同的地址就行了. 但是想搬到dmz区的机器和inside区的机器是同一网段的服务器和用户都是用一网段的,不改变地址怎么搞?

如何配置pix透明模式?

首先,需要升级pix os到7.0.1
直接输入firewall transparent 命令就可以让pix工作在透明模式下面。 工作在透明模式下时,pix相当于一条网线,故障切换由其它的三层设

备完成。
做防火墙的策略一般多是和端口对应的,外网在透明模式时怎样访问内网htti.https.pptp,tcp/udp-5060 /1270


有一点,透明模式下必须设置管理地址才会通
有所变化,以前用PIX515双机作failover,pix os版本好像是6.3就不支持透明模式.看来透明模式的应用还是挺多的,可以做网络分区之间的安全隔离,最重要的是可以让动态路 由协议穿过.


如何看用命令看这两台pix支持的最大连接数(不是使用中的最大连接数,而是license所限制的最大连接数)
show ver.

为什么ping不通515e的outside地址?
pix的版本是6.3(4),设置了515e的outside地址和inside地址后,用网线将笔记本和515e的outsi de端口联起来,本本的地址和outside地址在

一个网段内,但总是ping不通outside地址,但同样的配置在6.2版本的515e上使用时是没有问题的,好奇怪啊??

icmp pemit any outside

========================================================

pix ***设置好了,ddn方式可以上,为什么家里的adsl不行?

配置如下:pix520

pix version 6.3(3)
interface ethernet0 100full
interface ethernet1 100full
interface ethernet2 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 outside-dmz security50
enable password gybjrem5y/fijrzb encrypted
passwd eno4olec9w1amawd encrypted
hostname pix-yinhetech
domain-name test.cn
clock timez cst 8
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol ftp 2121
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
no fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 10.128.1.0 notebookpoolip
access-list n permit ip 10.10.0.0 255.255.0.0 notebookpoolip 255.255.255.0
access-list 101 permit ip 10.10.0.0 255.255.0.0 any
access-list notebookpc_splittunnelacl permit ip 10.10.0.0 255.255.0.0 any
access-list notebookpc_splittunnelacl permit ip notebookpoolip 255.255.255.0 any
access-list notebookpc_splittunnelacl permit ip host 10.6.4.11 any
access-list outside_cryptomap_dyn_20 permit ip any notebookpoolip 255.255.255.0
access-list outside_cryptomap_dyn_20 permit ip notebookpoolip 255.255.255.0 any
pager lines 24
logging on
logging standby
logging buffered debugging
logging trap notificati
icmp deny any outside
mtu outside 1500
mtu inside 1500
mtu outside-dmz 1500
ip address outside ***.***.***.** 255.255.255.240
ip address inside 10.127.1.253 255.255.255.0
ip address outside-dmz 172.18.3.254 255.255.255.0
ip verify reverse-path interface outside
ip verify reverse-path interface inside
ip audit info action alarm
ip audit attack action alarm
ip local pool notebookpool 10.128.1.1-10.128.1.250
no failover
failover timeout 0:00:00
failover poll 15
no failover ip address outside
no failover ip address inside
no failover ip address outside-dmz
pdm history enable
arp timeout 14400
global (outside) 1 ***.***.***.** netmask 255.255.255.240
global (outside-dmz) 1 172.18.3.200-172.18.3.250 netmask 255.255.255.0
nat (inside) 0 access-list n
nat (inside) 1 10.0.0.0 255.128.0.0 0 0
access-group 101 in interface inside
route outside 0.0.0.0 0.0.0.0 ***.***.***.** 1
route inside 10.0.0.0 255.128.0.0 10.127.1.254 1
timeout xlate 3:00:00
timeout c 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server tacacs+ protocol tacacs+
aaa-server radius protocol radius
aaa-server local protocol local
http server enable
http 10.10.10.74 255.255.255.255 inside
http 10.10.10.88 255.255.255.255 inside
snmp-server host inside 10.10.10.10
snmp-server host inside 10.10.10.74
snmp-server location soft_yuan_internet
snmp-server c bill
snmp-server community public
snmp-server enable traps
tftp-server inside 10.10.10.74 /
no floodguard enable
sysopt c permit-ipsec
crypto ipsec transform-set esp-des-md5 esp-des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set esp-des-md5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp identity address
isakmp keepalive 60 5
isakmp nat-traversal 120
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
***group notebookpc address-pool notebookpool
***group notebookpc dns-server 10.10.10.68 202.103.224.68
***group notebookpc default-domain yhgroup.cn
***group notebookpc split-tunnel notebookpc_splittunnelacl
***group notebookpc idle-time 1800
***group notebookpc password ********
telnet 10.0.0.0 255.128.0.0 inside
telnet 10.10.10.110 255.255.255.255 inside
telnet 10.10.10.110 255.255.255.255 outside-dmz
telnet timeout 31
ssh timeout 5
c timeout 0
terminal width 80
cryptochecksum:826ec1728f5df3bb3ecf0542790a4d35



surf_qj (普通用户)

对了,是使用cisco system *** client 4.01登录的,家里adsl可以连上***,但是不能访问,ddn就可以其实,不光是pix问题,我用2620做的和你的也一 样,用一般的adsl是不行的,但如果是用带路由功能adsl就可以。

isakmp nat-traversal 120
还有客户端nat打开,估计是nat穿透的问题吧。

========================================================

pix515的问题


具体现象是,dmz和inside各接一台单机,dmz的单机能用上网,其他不能,inside的机器什么都干不了。单机保证无 问题。请各位帮忙看看配置吧。 outside的地址和global的地址不同,有影响么?(没有空闲的连续地址了,只能用两个不同地址表示一下)
pix version 6.2(2)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 dmz security50
enable password o53fpnrghka6iesy encrypted
passwd twjti1emvjruv4sy encrypted
hostname jygatewall
domain-name 219.2.2.2
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sqlnet 1521
fixup protocol sip 5060
no fixup protocol skinny 2000
no fixup protocol smtp 25
names
access-list dmz_jygate_acl deny icmp any any
access-list dmz_jygate_acl permit udp any any eq domain
access-list dmz_jygate_acl permit tcp any any eq www
access-list dmz_jygate_acl permit udp any any eq 20
access-list dmz_jygate_acl permit tcp any host 219.150.1.1 eq 20817
access-list dmz_jygate_acl permit tcp any host 219.150.1..1eq 20820
access-list dmz_jygate_acl permit tcp any host 219.150.1.1 eq 8080
access-list dmz_jygate_acl permit tcp any host 219.150.1.1 eq 8383
access-list dmz_jygate_acl permit tcp any host 219.150.1.1 eq 32002
pager lines 24
interface ethernet0 100full
interface ethernet1 100full
interface ethernet2 100full
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip address outside 219.150.1.2 255.255.255.224
ip address inside 192.168.168.1 255.255.255.0
ip address dmz 172.172.172.1 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
no failover
failover timeout 0:00:00
failover poll 15
failover ip address outside 0.0.0.0
failover ip address inside 0.0.0.0
failover ip address dmz 0.0.0.0
pdm history enable
arp timeout 14400
global (outside) 1 219.150.1.2
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (dmz,outside) 219.150.1.2 172.172.172.101 netmask 255.255.255.255 0 0

static (inside,dmz) 192.168.168.0 192.168.168.0 netmask 255.255.255.0 0 0
access-group dmz_jygate_acl in interface outside
access-group dmz_jygate_acl in interface dmz
route outside 0.0.0.0 0.0.0.0 219.150.1.3 1
timeout xlate 3:00:00
timeout c 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si
p 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server tacacs+ protocol tacacs+
aaa-server radius protocol radius
aaa-server local protocol local
no snmp-server location
no snmp-server c
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt security fragguard
no sysopt route dnat
telnet timeout 5
ssh timeout 5
terminal width 80
cryptochecksum:594b9bbf77abf8a342afee1764e4f7cd
: end


nyb0319 (普通用户)

no static (inside,dmz) 192.168.168.0 192.168.168.0 netmask 255.255.255.0 0 0
改为static (inside,dmz) 172.172.172.1 192.168.168.0 netmask 255.255.255.0 0 0

加一条

static (inside,outside)
219.150.1.2 192.168.168.0
netmask 255.255.255.0 0 0

no access-group dmz_jygate_acl in interface dmz


crazytank (普通用户)


按照上面的提示改了,结果提示global address overlaps with mask 请各位大侠再帮忙看看啊


lcschina (活跃用户) ip address outside 219.150.1.2 255.255.255.224

global (outside) 1 219.150.1.2

地址重叠!!!
加上 global (outside) 1 interface 去掉你的那个global

 

 

如何允许外网用户telnet至pix的outside?
补充一下
licensed features:
***-des: enabled
***-3des: disabled

用ssh就可以。 telnet不可以!

对inside 倒dmz的访问,需要做nat配 cript language=javascript src="/cms/js/newsad.js"> 置,对于dmz到inside的访问,需要做static 与access-list的配置。

pix 515e连接adsl 路由modem!

想知道e0口上怎么配置与开启路由的modem的连接。让内网所有用户可以都通过这个modem上网。
adsl modem ip:192.168.1.1
pixfirwall(c group <组名> request dialout pppoe
pixfirwall(c group <组名> ppp auth pap/chap/mschap
pixfirwall(c group <组名> localname <拨号的用户名>
pixfirwall(c username <用户名> password <密码>
pixfirwall(c add <接口名称-随便定义> pppoe




我想通过在pix 515e 上进行设置使某些内网用户只能上一个特定的网站

当前配置如下:

pix version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100

hostname pixfirewall
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 61.155.88.82 255.255.255.252
ip address inside 10.10.3.253 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 3 interface
nat (inside) 3 10.10.1.1 255.255.255.255 0 0
nat (inside) 3 10.10.1.9 255.255.255.255 0 0
nat (inside) 3 10.10.1.81 255.255.255.255 0 0
nat (inside) 3 10.10.1.82 255.255.255.255 0 0
nat (inside) 3 10.10.1.113 255.255.255.255 0 0
nat (inside) 3 10.10.1.161 255.255.255.255 0 0
nat (inside) 3 10.10.1.162 255.255.255.255 0 0
nat (inside) 3 10.10.1.165 255.255.255.255 0 0
nat (inside) 3 10.10.1.240 255.255.255.255 0 0
nat (inside) 3 10.10.2.240 255.255.255.248 0 0
nat (inside) 3 10.10.1.240 255.255.255.240 0 0
route outside 0.0.0.0 0.0.0.0 61.155.88.81 1
route inside 10.0.0.0 255.0.0.0 10.10.3.254 1
timeout xlate 3:00:00
timeout c 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc

0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media

0:02:00
timeout uauth 0:05:00 absolute
aaa-server tacacs+ protocol tacacs+
aaa-server radius protocol radius
aaa-server local protocol local
no snmp-server location
no snmp-server c
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh timeout 5
c timeout 0
terminal width 80
cryptochecksum:72a261056ba18f4dbefab375fb871688
: end


是的,可以将针对这些主机的限制策略放在acl的最上端,应用在inside口的in的方向上。

你可以用支持时间的acl来做,也可以用tacacs来验证用户,定义downloaded acl


请教pix515 acl 如何屏蔽一个网段?

deny ip host 61.129.64.* any
61.129.64.*这样的网段该咋样屏蔽?


juechen70 (版主)
deny ip 61.129.64.0 255.255.255.0

csco10334975 (普通用户)
deny ip 61.129.64.0 255.255.255.0 any


mythis (普通用户)
access-list 100 deny ip 61.129.64.0 255.255.255.0 any


pix上启用了dhcp,不允许内网自动获取只允许dmz自动获如何做。

dhcpd address 192.118.0.5-192.118.0.254 dmz
dhcpd enable dmz
dhcpd dns 219.141.136.10 218.247.141.68
这样就可以了!


pix7.0 如何在routed 和 transparent 两种方式中切换?
我的pix 515e 升级到pix7.01 我想使用 transparent 模式, 请大家教如何做了?

firewall transparent
no firewall transparent

在515e中配置dhcp网关的命令是什么
dhcpd enable inside


pix能不能实现dmz和inside透明模式呢?

有客户想把服务器搬到dmz区,但是服务器地址不变,这样除了透明模式我还想不到其他办法,inside和outside的透明 模式我知道,但是

inside和dmz的透明模式怎么办?地址必须改变。透明桥模式下是没有dmz概念的。地址不变也可以.做地址映射的时候翻译 相同的地址就行了. 但是想搬到dmz区的机器和inside区的机器是同一网段的服务器和用户都是用一网段的,不改变地址怎么搞?

如何配置pix透明模式?

首先,需要升级pix os到7.0.1
直接输入firewall transparent 命令就可以让pix工作在透明模式下面。 工作在透明模式下时,pix相当于一条网线,故障切换由其它的三层设

备完成。
做防火墙的策略一般多是和端口对应的,外网在透明模式时怎样访问内网htti.https.pptp,tcp/udp-5060 /1270


有一点,透明模式下必须设置管理地址才会通
有所变化,以前用PIX515双机作failover,pix os版本好像是6.3就不支持透明模式.看来透明模式的应用还是挺多的,可以做网络分区之间的安全隔离,最重要的是可以让动态路 由协议穿过.


如何看用命令看这两台pix支持的最大连接数(不是使用中的最大连接数,而是license所限制的最大连接数)
show ver.

为什么ping不通515e的outside地址?
pix的版本是6.3(4),设置了515e的outside地址和inside地址后,用网线将笔记本和515e的outsi de端口联起来,本本的地址和outside地址在

一个网段内,但总是ping不通outside地址,但同样的配置在6.2版本的515e上使用时是没有问题的,好奇怪啊??

icmp pemit any outside

========================================================

pix ***设置好了,ddn方式可以上,为什么家里的adsl不行?

配置如下:pix520

pix version 6.3(3)
interface ethernet0 100full
interface ethernet1 100full
interface ethernet2 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 outside-dmz security50
enable password gybjrem5y/fijrzb encrypted
passwd eno4olec9w1amawd encrypted
hostname pix-yinhetech
domain-name test.cn
clock timez cst 8
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol ftp 2121
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
no fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 10.128.1.0 notebookpoolip
access-list n permit ip 10.10.0.0 255.255.0.0 notebookpoolip 255.255.255.0
access-list 101 permit ip 10.10.0.0 255.255.0.0 any
access-list notebookpc_splittunnelacl permit ip 10.10.0.0 255.255.0.0 any
access-list notebookpc_splittunnelacl permit ip notebookpoolip 255.255.255.0 any
access-list notebookpc_splittunnelacl permit ip host 10.6.4.11 any
access-list outside_cryptomap_dyn_20 permit ip any notebookpoolip 255.255.255.0
access-list outside_cryptomap_dyn_20 permit ip notebookpoolip 255.255.255.0 any
pager lines 24
logging on
logging standby
logging buffered debugging
logging trap notificati
icmp deny any outside
mtu outside 1500
mtu inside 1500
mtu outside-dmz 1500
ip address outside ***.***.***.** 255.255.255.240
ip address inside 10.127.1.253 255.255.255.0
ip address outside-dmz 172.18.3.254 255.255.255.0
ip verify reverse-path interface outside
ip verify reverse-path interface inside
ip audit info action alarm
ip audit attack action alarm
ip local pool notebookpool 10.128.1.1-10.128.1.250
no failover
failover timeout 0:00:00
failover poll 15
no failover ip address outside
no failover ip address inside
no failover ip address outside-dmz
pdm history enable
arp timeout 14400
global (outside) 1 ***.***.***.** netmask 255.255.255.240
global (outside-dmz) 1 172.18.3.200-172.18.3.250 netmask 255.255.255.0
nat (inside) 0 access-list n
nat (inside) 1 10.0.0.0 255.128.0.0 0 0
access-group 101 in interface inside
route outside 0.0.0.0 0.0.0.0 ***.***.***.** 1
route inside 10.0.0.0 255.128.0.0 10.127.1.254 1
timeout xlate 3:00:00
timeout c 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server tacacs+ protocol tacacs+
aaa-server radius protocol radius
aaa-server local protocol local
http server enable
http 10.10.10.74 255.255.255.255 inside
http 10.10.10.88 255.255.255.255 inside
snmp-server host inside 10.10.10.10
snmp-server host inside 10.10.10.74
snmp-server location soft_yuan_internet
snmp-server c bill
snmp-server community public
snmp-server enable traps
tftp-server inside 10.10.10.74 /
no floodguard enable
sysopt c permit-ipsec
crypto ipsec transform-set esp-des-md5 esp-des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set esp-des-md5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp identity address
isakmp keepalive 60 5
isakmp nat-traversal 120
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
***group notebookpc address-pool notebookpool
***group notebookpc dns-server 10.10.10.68 202.103.224.68
***group notebookpc default-domain yhgroup.cn
***group notebookpc split-tunnel notebookpc_splittunnelacl
***group notebookpc idle-time 1800
***group notebookpc password ********
telnet 10.0.0.0 255.128.0.0 inside
telnet 10.10.10.110 255.255.255.255 inside
telnet 10.10.10.110 255.255.255.255 outside-dmz
telnet timeout 31
ssh timeout 5
c timeout 0
terminal width 80
cryptochecksum:826ec1728f5df3bb3ecf0542790a4d35



surf_qj (普通用户)

对了,是使用cisco system *** client 4.01登录的,家里adsl可以连上***,但是不能访问,ddn就可以其实,不光是pix问题,我用2620做的和你的也一 样,用一般的adsl是不行的,但如果是用带路由功能adsl就可以。

isakmp nat-traversal 120
还有客户端nat打开,估计是nat穿透的问题吧。

========================================================

pix515的问题


具体现象是,dmz和inside各接一台单机,dmz的单机能用上网,其他不能,inside的机器什么都干不了。单机保证无 问题。请各位帮忙看看配置吧。 outside的地址和global的地址不同,有影响么?(没有空闲的连续地址了,只能用两个不同地址表示一下)
pix version 6.2(2)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 dmz security50
enable password o53fpnrghka6iesy encrypted
passwd twjti1emvjruv4sy encrypted
hostname jygatewall
domain-name 219.2.2.2
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sqlnet 1521
fixup protocol sip 5060
no fixup protocol skinny 2000
no fixup protocol smtp 25
names
access-list dmz_jygate_acl deny icmp any any
access-list dmz_jygate_acl permit udp any any eq domain
access-list dmz_jygate_acl permit tcp any any eq www
access-list dmz_jygate_acl permit udp any any eq 20
access-list dmz_jygate_acl permit tcp any host 219.150.1.1 eq 20817
access-list dmz_jygate_acl permit tcp any host 219.150.1..1eq 20820
access-list dmz_jygate_acl permit tcp any host 219.150.1.1 eq 8080
access-list dmz_jygate_acl permit tcp any host 219.150.1.1 eq 8383
access-list dmz_jygate_acl permit tcp any host 219.150.1.1 eq 32002
pager lines 24
interface ethernet0 100full
interface ethernet1 100full
interface ethernet2 100full
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip address outside 219.150.1.2 255.255.255.224
ip address inside 192.168.168.1 255.255.255.0
ip address dmz 172.172.172.1 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
no failover
failover timeout 0:00:00
failover poll 15
failover ip address outside 0.0.0.0
failover ip address inside 0.0.0.0
failover ip address dmz 0.0.0.0
pdm history enable
arp timeout 14400
global (outside) 1 219.150.1.2
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (dmz,outside) 219.150.1.2 172.172.172.101 netmask 255.255.255.255 0 0

static (inside,dmz) 192.168.168.0 192.168.168.0 netmask 255.255.255.0 0 0
access-group dmz_jygate_acl in interface outside
access-group dmz_jygate_acl in interface dmz
route outside 0.0.0.0 0.0.0.0 219.150.1.3 1
timeout xlate 3:00:00
timeout c 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si
p 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server tacacs+ protocol tacacs+
aaa-server radius protocol radius
aaa-server local protocol local
no snmp-server location
no snmp-server c
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt security fragguard
no sysopt route dnat
telnet timeout 5
ssh timeout 5
terminal width 80
cryptochecksum:594b9bbf77abf8a342afee1764e4f7cd
: end


nyb0319 (普通用户)

no static (inside,dmz) 192.168.168.0 192.168.168.0 netmask 255.255.255.0 0 0
改为static (inside,dmz) 172.172.172.1 192.168.168.0 netmask 255.255.255.0 0 0

加一条

static (inside,outside)
219.150.1.2 192.168.168.0
netmask 255.255.255.0 0 0

no access-group dmz_jygate_acl in interface dmz


crazytank (普通用户)


按照上面的提示改了,结果提示global address overlaps with mask 请各位大侠再帮忙看看啊


lcschina (活跃用户) ip address outside 219.150.1.2 255.255.255.224

global (outside) 1 219.150.1.2

地址重叠!!!
加上 global (outside) 1 interface 去掉你的那个global