1.静态NAT的配置:
Router(config)#hostname r1
r1(config)#interface fa 0/0
r1(config-if)#ip address 192.168.1.1 255.255.255.0
r1(config-if)#ip nat inside     //表明为内部端口
r1(config-if)#no shut
r1(config)#interface s 1/1
r1(config-if)#ip address 193.1.1.1 255.255.255.0
r1(config-if)#ip nat outside     //表明为外部端口
r1(config-if)#clock rate 64000
r1(config-if)#no shut
r1(config-if)#router rip
r1(config-router)#network 192.168.1.0
r1(config-router)#network 193.1.1.0
r1(config-router)#exit
r1(config)#ip nat inside source static 192.168.1.2 194.1.1.2    //以下三行为静态NAT的设置
r1(config)#ip nat inside source static 192.168.1.3 194.1.1.3
r1(config)#ip nat inside source static 192.168.1.4 194.1.1.4
r1(config)#exit
r1#show ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
--- 194.1.1.2          192.168.1.2        ---                ---
--- 194.1.1.3          192.168.1.3        ---                ---
--- 194.1.1.4          192.168.1.4        ---                ---
如上所示,可以看出我设定的静态NAT的翻译表信息
2.动态NAT的配置:
Router(config)#hostname r1
r1(config)#interface fa 0/0
r1(config-if)#ip address 192.168.1.1 255.255.255.0
r1(config-if)#ip nat inside
r1(config-if)#no shut
r1(config-if)#interface s1/1
r1(config-if)#ip address 193.1.1.1 255.255.255.0
r1(config-if)#ip nat outside
r1(config-if)#clock rate 64000
r1(config-if)#no shut
r1(config-if)#router rip
r1(config-router)#network 192.168.1.0
r1(config-router)#network 193.1.1.0
r1(config-router)#exit
r1(config)#ip nat pool p1 194.1.1.1 194.1.1.10 prefix-length 24   //定义内部全局地址池,命令格式为ip nat pool name start-ip end-ip {prefix-length }
r1(config)#ip nat inside source list 1 pool p1     //在内部和外部之间建立转换关系
r1(config)#access-list 1 permit 192.168.1.0 0.0.0.255    //建立标准acl来允许某些内部地址可以进行动态地址转换