1、jdk配置

配置3个 path,classpath,java_home

java_home:   c:\jdk1.6.x.x

path :   %java_home%\bin;%java_home%\jre\bin;

classpath:  .;%java_home%\lib\dt.jar;%java_home%\lib\tools.jar;

 

2、Unsupported major.minor version 48.0 49.0 50.0错误

当你在编译Java时,遇到Unsupported major.minor version类似如下问题提示:
Unsupported major.minor version 50.0
Unsupported major.minor version 49.0
Unsupported major.minor version 48.0

均属于Java版本问题,即JDK版本过低,只要选择相对应的JDK版本编译即可。

48,49,50是Java编译器内部的版本号

Unsupported major.minor version 50.0 对应于 JDK1.6(JRE1.6)
Unsupported major.minor version 49.0 对应于 JDK1.5(JRE1.5)
Unsupported major.minor version 48.0 对应于 JDK1.4(JRE1.4)

问题解决方法就是尝试其他jdk编译,并在JDK的环境下(包括修改JAVA_HOME,PATH,CLASSPATH)运行(可能造成Web应用程序失败)

 

适合快速排查错
当你在编译Java时,遇到Unsupported major.minor version类似如下问题提示:
Unsupported major.minor version 50.0
Unsupported major.minor version 49.0
Unsupported major.minor version 48.0

均属于Java版本问题,即JDK版本过低,只要选择相对应的JDK版本编译即可。

48,49,50是Java编译器内部的版本号

Unsupported major.minor version 50.0 对应于 JDK1.6(JRE1.6)
Unsupported major.minor version 49.0 对应于 JDK1.5(JRE1.5)
Unsupported major.minor version 48.0 对应于 JDK1.4(JRE1.4)

-------------------------------------------------------------------
java -version
javac -version
看看,版本不一致
-------------------------------------------------------------------
解决了,问题的原因是我先安装了JDK1.6,然后有安装了ORACL,最后PATH为:G:\oracle\product\10.1.0\Db_2\bin;G:\oracle\product\10.1.0\Db_2\jre\1.4.2\bin\client;G:\oracle\product\10.1.0\Db_2\jre\1.4.2\bin;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;G:\Program Files\QuickTime\QTSystem\;G:\Program Files\Common Files\Adobe\AGL;G:\Program Files\Java\jdk1.6.0_07\bin;G:\Program Files\Java\jre1.6.0_07\bin; 我把JAVA jdk的PATH提前,重启,问题解决了。不过没有测试ORACL有没有问题。


一般新装机子,先装jdk6再装个oracle旧版本的,就会有这种问题
所以先看看
java -version
javac -version
看看,版本不一致
再看环境变量中的PATH的jdk_home是否在最前