公司最近打算升级Vsphere 的系统到6.5版本,这样就可以使用最新的VMFS6的文件系统了。VMFS6的优点在于他可以支持自动回收Thin配置的LUN在通过Vmotion或者快照删除以后所释放的空间。在6.0的时代,每次我进行了存储方面的改动,都需要手动执行escli的命令来释放空间。

升级步骤不多说了,先升级Vcenter,然后升级update manager,然后升级host,然后升级相关的插件等等。

目前版本是6.0
ESXi 6 升级到ESXi 6.5VIB冲突问题

升级host的时候,遇见了一个不兼容的报错问题

报错如下

ESXi 6 升级到ESXi 6.5VIB冲突问题

ESXi 6 升级到ESXi 6.5VIB冲突问题

经过研究,发现这个是因为豆子使用了HP自定义的ESXi 6.5 ISO,解决方法很简单,删除冲突的VIB文件就行了

SSH登录ESXi主机,查看这些冲突的VIB的名字,然后删除即可

[root@sydesx2:~] esxcli software vib list | grep Emulex
scsi-lpfc820                   8.2.4.141.55-1OEM.500.0.0.472560       Emulex           VMwareCertified   2016-11-07
[root@sydesx2:~] esxcli software vib list | grep Mell
net-mst                        2.0.0.0-1OEM.550.0.0.472560            Mellanox         PartnerSupported  2016-11-07
[root@sydesx2:~] esxcli software vib remove -n scsi-lpfc820
Removal Result
   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
   Reboot Required: true
   VIBs Installed:
   VIBs Removed: Emulex_bootbank_scsi-lpfc820_8.2.4.141.55-1OEM.500.0.0.472560
   VIBs Skipped:
[root@sydesx2:~] esxcli software vib remove -n net-mst
Removal Result
   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
   Reboot Required: true
   VIBs Installed:
   VIBs Removed: Mellanox_bootbank_net-mst_2.0.0.0-1OEM.550.0.0.472560
   VIBs Skipped:

删除之后,重启主机,然后进入WebClient里面,在Update Manger里面重新加载baseline,扫描,状态从不兼容变成 non-compliant,意味着冲突已经清理掉,可以升级了。后面的步骤就不用赘述了

ESXi 6 升级到ESXi 6.5VIB冲突问题

最后上个成功升级以后的图

ESXi 6 升级到ESXi 6.5VIB冲突问题

ESXi 6 升级到ESXi 6.5VIB冲突问题