任务 8-1 配置通过点对点子接口利用帧中继连通总部与分公司网络

【主要设备】

Cisco 2811 路由器3台,计算机3台,模拟帧中继交换机1

【具体要求】

某公司网络总部Router1在广州,分公司Router2Router3分别在北京和上海,使用帧中继服务进行联网,试用子接口方式配置路由器连通网络。

wKioL1cLuz_Sw_naAAA3VMSLsM0914.png


配置R1

R1(config)#int lo0

R1(config-if)#ip add 192.168.10.1 255.255.255.0

R1(config-if)#exit

R1(config)#int s0/0

R1(config-if)#encapsulation frame-relay

R1(config-if)#no shut

 

R1(config)#int s0/0.102 point-to-point   //配置子接口

R1(config-subif)#ip add 1.1.1.1 255.255.255.252

R1(config-subif)#frame-relay interface-dlci 102

//指明该子接口连接虚电路DLCI 102

R1(config-subif)#frame-relay map ip 1.1.1.2 102 broadca

//配置与北京路由器的静态地址映射

R1(config)#int s0/0.103 point-to-point

R1(config-subif)#ip add 1.1.1.5 255.255.255.252

R1(config-subif)#frame-relay interface-dlci 103

//指明该子接口连接虚电路DLCI 103

R1(config-subif)#frame-relay map ip 1.1.1.6 103 broadca

//配置与上海路由器的静态地址映射

R1(config)#router ospf 1

R1(config-router)#router-id 1.1.1.1

R1(config-router)#network 1.1.1.0 0.0.0.3 area 0

R1(config-router)#network 1.1.1.4 0.0.0.3 area 0

R1(config-router)#network 192.168.10.0 0.0.0.255 area 0



配置R2

R2(config)#int   lo0

R2(config-if)#ip add 192.168.20.1 255.255.255.0

R2(config-if)#exit

R2(config)#int s0/0

R2(config-if)#encapsulation frame-relay

R2(config-if)#no shut

 

R2(config)#int s0/0.201 point-to-point   //配置子接口

R2(config-subif)#ip add 1.1.1.2 255.255.255.252

R2(config-subif)#frame-relay interface-dlci 201

//指明该子接口连接虚电路DLCI 201

R2(config-subif)#frame-relay map ip 1.1.1.1 201 broadca

//配置与广州路由器的静态地址映射

 

R2(config)#router ospf 1

R2(config-router)#router-id 2.2.2.2

R2(config-router)#network 1.1.1.0 0.0.0.3 area 0

R2(config-router)#network 192.168.20.0 0.0.0.255 area 0




配置R3

R3(config)#int   lo0

R3(config-if)#ip add 192.168.30.1 255.255.255.0

R3(config-if)#exit

R3(config)#int s0/2

R3(config-if)#encapsulation frame-relay

R3(config-if)#no shut

 

R3(config)#int s0/2.301point-to-point   //配置子接口

R3(config-subif)#ip add 1.1.1.6 255.255.255.252

R3(config-subif)#frame-relay interface-dlci 201

//指明该子接口连接虚电路DLCI 301

R3(config-subif)#frame-relay map ip 1.1.1.5 301 broadca

//配置与广州路由器的静态地址映射

 

R3(config)#router ospf 1

R3(config-router)#router-id 3.3.3.3

R3(config-router)#network 1.1.1.4 0.0.0.3 area 0

R3(config-router)#network 192.168.30.0 0.0.0.255 area 0




配置Frame

Frame(config)#frame-relay switching

Frame(config)#int s0/0

Frame(config-if)#clock rate 64000

Frame(config-if)#encapsulation frame-relay

Frame(config-if)#frame-relay  intf-type  dce

Frame(config-if)#frame-relay route 102  int  s0/1  201

Frame(config-if)#frame-relay route 103  int  s0/2  301

Frame(config-if)# no shut

 

Frame(config)#int s0/1

Frame(config-if)#clock rate 64000

Frame(config-if)#encapsulation frame-relay

Frame(config-if)#frame-relay  intf-type  dce

Frame(config-if)#frame-relay route 201  int  s0/0  102

Frame(config-if)# no shut

 

Frame(config)#int s0/2

Frame(config-if)#clock rate 64000

Frame(config-if)#encapsulation frame-relay

Frame(config-if)#frame-relay  intf-type  dce

Frame(config-if)#frame-relay route 301  int  s0/0  103

Frame(config-if)# no shut