Logo

  • minminmsn

    发布于:2016-11-16 18:50:00

    3

    排查logstash2.4升级到5.0版本后kafka不兼容问题
    排查logstash2.4升级到5.0版本后kafka不兼容问题参考文档:/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-kafka-5.0.5/CHANGELOG.md /usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstas...
    阅读 2785 评论 3 收藏 1
  • xsllqs

    发布于:2016-08-20 22:45:33

    2

    Centos6.5利用RubyGems的fpm制作zabbix_agent的rpm包,并使用ansible批量部署
    一、 搭建rpm包制作环境安装gcc[root@lvs1 ~]# yum install gcc安装make[root@lvs1 ~]# yum install make安装ruby源(ruby版本必须要在1.9.3以上,centos自带的是1.8的版本...
    阅读 1955 评论 7 收藏 3
  • dl528888

    发布于:2015-12-09 17:49:29

    11

    开源论坛之discourse搭建
    公司最近有个新项目,想弄个技术的问答论坛,挑选了半天,选择ruby语言的discourse,这个是完全开源的,界面简洁,支持中文,有管理后台,满足需求。
    阅读 4489 评论 7 收藏 4
  • 抚琴煮酒

    发布于:2015-01-09 16:39:09

    0

    Ruby和SHELL中如何遍历指定目录的文件
    在工作中我们有在Ruby和SHELL中如何遍历指定目录的文件的需求,这个应该如何来实现呢?网上的方法也非常之多,我们可以拿来参考参考,如下边的traverse.rb文件内容所示:
    阅读 2015 评论 0 收藏 0
  • 抚琴煮酒

    发布于:2014-12-22 14:51:38

    1

    人性化的Ruby计数取值
    Ruby由于吸收了Perl的正则表达式和Python的可读性,所以其中的计数取值方法,是非常人性化和灵活的,这里可以举例来说明下: 一、打印7次“hello,world”,如下:
    阅读 1622 评论 0 收藏 0
  • 抚琴煮酒

    发布于:2014-12-09 20:25:05

    0

    Ruby中写一个判断成绩分类的脚本
    需求为:从键盘输入分数,以此来判断,0-59为不及格,打印“您没有及格,请下次努力!”,60-79为及格,打印“您的成绩及格,请更加努力!”,80-100为成绩良,打印“您的成绩为优秀,请再接再厉!”,如果输入为0-100以外的分数,请打印“您的成绩为优秀,请再接再厉!”
    阅读 1655 评论 2 收藏 0
  • kinda22

    发布于:2014-11-23 17:35:33

    0

    ruby_expect模块的使用..
    通过ruby实现类expect功能的脚本..在ruby中有2两种实现方式:1. 利用标准库中的Pty基于io流的方式实现(较为复杂,涉及到输入输出io流).2. 通过rubygems利用扩展包实现. 本次主要介绍这个。首先通过gem安装软件包:&n...
    阅读 1717 评论 0 收藏 0
  • 西索oO

    发布于:2014-11-18 22:14:53

    0

    Centos系统搭建ror平台搭建
    本文系统Centos6.5 x64Ruby On Rails是一个用Ruby语言写的开源Web框架,和J2EE,PHP等类似。Ruby On Rails是一个非常优美的Web开发框架,并且融入了敏捷开发的精髓:约定大于配置。你会发现,它真的是一个非常优美的...
    阅读 1960 评论 0 收藏 0
  • 抚琴煮酒

    发布于:2014-11-18 16:44:22

    0

    Ruby中求50之内的素数方法
    ruby求50之内的素数的方法,感觉对比PHP和SHELL方法是最简单的,但SHELL中可以利用factor命令,而PHP中没有求素数的对应函数的,需要自己设计算法,三种方式大家对比学习下,应该还有更优更简单的方法的。
    阅读 2501 评论 0 收藏 0
  • Wz10000000000

    发布于:2014-10-20 18:14:18

    4

    Mac 升级10.10 Yosemite系统 brew 报错无法使用解决办法
    随着水果公司发布最新系统,想尝鲜的同学们相信早已经装上体验了一把吧,可能个别同学使用 brew 的时候会报这个错误:/usr/local/bin/brew: /usr/local/Library/brew.rb: /System/Library/Frameworks/Ruby.fr...
    阅读 3684 评论 6 收藏 0
写文章