wKiom1cvO3Tyv7XXAAKyALB41Xg503.jpg


背景:

某上市企业全国MPLS网络架构基础规划与整合,涉及城市深圳、重庆、武汉、北京、天津、上海、某POP点

 

需求:

1.整理全国专线接入,实现全网mpls-***通信,实现部分地区IP地址重叠。

2.使用双pop点完成冗余互联。

3.全网PE设备默认使用静态与CE设备互联

PS:此次为了大家都能理解不同的部署方式有不同的配置方法和注意细节,列举BGP/OSPF/STATIC三种方式

4.MPLS-zone以OSPF互联,多POP点接入保证P设备物理冗余

 

说俩句,目前个人所在的一家运营商负责合同额50W+的客户网络架构实施和维护。目前mpls的组网单子不多,更谈不上有全国性质的组网规划了。所以此次的单子,对个人实施经验是比较大的补充,所以相当重视这一次分享的机会。

 

不多说,直接上“菜”,全篇只聊简单的动态互联配置过程,静态互联、排错思路以及详细的配置注解将不会提及。将会另起篇章进行详细心得介绍。

 

总之,个人技术能力有限,不过把学习当作一种生活方式是每一位工程师必备的素质!!

 

配置思路:

先搞定P设备配置

   1.运行IGP====》OSPF

   2.运行MPLS===》LDP

接着搞定PE之间MP-BGP的配置

  3.Pe之间运行MP-IBGP

最后搞定PE和CE之间的VRF接入配置

   4.在PE设备上创建虚拟路由器(vrf),同时把PE和CE之间的接口放进VRF中。

   5.在PE和CE之间运行IGP(OSPF、Static)

  6.PE和CE之间的IGP和BGP双向重发布(BGP无需重发布)

 

P设备的关键配置:

IOU2:

mpls ldp router-id loopback0  设定 LDP router-ID

mpls label range 200 299     设置标签范围

mpls label protocol ldp       设置mpls使用的协议(有俩种LDP(标准)/TDP(思科私有))

 

interface Loopback0

 ipaddress 10.10.0.2 255.255.255.255

interface Ethernet0/0

 ipaddress 10.10.23.2 255.255.255.0

 mplsip

interface Ethernet0/3

 ipaddress 10.10.29.2 255.255.255.0

 mplsip 

(*May  8 19:01:59.524:%LDP-5-NBRCHG: LDP Neighbor 10.10.0.9:0 (1) is UP)

 

router ospf 10              

P-zone内运行的 OSPF,用于交互 mpls-backbone内的路由,为后面的MP-BGP建立邻接关系做前提,以及为后续的LDP服务

 router-id 10.10.0.2

 network 10.10.0.2 0.0.0.0 area 0

 network 10.10.23.0 0.0.0.255 area 0

 network 10.10.29.2 0.0.0.0 area 0

 

IOU3:

mpls ldp router-id loopback0

mpls label range 300 399  

mpls label protocol ldp    

 

interface Loopback0

 ipaddress 10.10.0.3 255.255.255.255

interface Ethernet0/0

 ipaddress 10.10.34.3 255.255.255.0

 mplsip

interface Ethernet0/1

 ipaddress 10.10.23.3 255.255.255.0

 mplsip

interface Ethernet0/2

 ipaddress 10.10.39.3 255.255.255.0

 mplsip

interface Ethernet0/3

 ipaddress 10.10.13.3 255.255.255.0

 mplsip

 

router ospf 10

 router-id 10.10.0.3

 network 10.10.0.3 0.0.0.0 area 0

 network 10.10.13.0 0.0.0.255 area 0

 network 10.10.23.0 0.0.0.255 area 0

 network 10.10.34.0 0.0.0.255 area 0

 network 10.10.39.3 0.0.0.0 area 0

 network 10.10.39.0 0.0.0.255 area 0

 

IOU4,IOU9(P)IOU5(PE)配置省略。

 

PE之间运行MP-BGP:

IOU2:

router bgp 10

 bgprouter-id 10.10.0.2

 bgplog-neighbor-changes

 nobgp default ipv4-unicast  

我们不需要 PE1-PE2 交互 IPv4 前缀,MPLS-***使用扩展的BGP协议,因此将默认就会自动建立 IPv4 的 BGP 邻接的开关关掉

 neighbor 10.10.0.5 remote-as 10

 neighbor 10.10.0.5 update-source Loopback0

配置 ***v4 的邻接,需要在进程中先指 neighbor,然后再去 ***v4 地址族内激活,注意这里 PE1-PE2 的邻接关系是建立在 Loopback 接口上的

 

 address-family ipv4

 exit-address-family

 

 address-family ***v4

 neighbor 10.10.0.5 activate   

激活与 IOU5 也就是 PE5 的 ***v4 连接

 neighbor 10.10.0.5 send-community extended 

思科会在激活 ***v4 邻接后自动添加这条命令,但是还是要养成好习惯,主动查看,若没有请添加

 exit-address-family

 

 

IOU5:

router bgp 10

 bgprouter-id 10.10.0.5

 bgplog-neighbor-changes

 nobgp default ipv4-unicast

 neighbor 10.10.0.2 remote-as 10

 neighbor 10.10.0.2 update-source Loopback0

 !

 address-family ipv4

 exit-address-family

 address-family ***v4

 neighbor 10.10.0.2 activate

 neighbor 10.10.0.2 send-community extended

 exit-address-family

 

PE-Router_sh005#show ip bgp ***v4 allsummary

查看MP-BGP的情况,若正常输出则配置成功,反之请检查配置。

 

因为分支较多,这里只聊深圳和北京的CE-PE间的OSPF互联配置,静态互联将在后面进行详细补充。

IOU2(PE2):

ip vrf ABC  建立虚拟路由转发表

 rd10:2      MP-BGP 运载 VRF 前缀时,确保这些前缀的唯一性

 route-target export 2:1    发布 2:1

 route-target import 5:6    导入 5:6

interface Ethernet0/1

 ipvrf forwarding ABC     接口放入VRF ABC当中

 ipaddress 172.10.12.2 255.255.255.0

 

router ospf 100 vrf ABC   在虚拟路由转发表ABC上启用 ospf100

 redistribute bgp 10 subnets

 network 172.10.12.0 0.0.0.255 area 0

 

router bgp 10

 bgprouter-id 10.10.0.2

 bgplog-neighbor-changes

 nobgp default ipv4-unicast

 neighbor 10.10.0.5 remote-as 10

 neighbor 10.10.0.5 update-source Loopback0

address-family ipv4 vrf ABC

OSPF 100 VRF ABC 中的路由注入到 BGP,从而形成 ***v4 的前缀

 redistribute ospf 100 match internal external 1 external 2

 exit-address-family

 

IOU1(深圳):

router ospf 100

 router-id 172.10.0.1

 redistribute connected subnets route-map lo1

 network 172.10.0.1 0.0.0.0 area 0

 network 172.10.12.0 0.0.0.255 area 0

 

route-map lo1 permit 10

 match interface Loopback1

 

interface Loopback0

 ipaddress 172.10.0.1 255.255.255.0

 

IOU5(PE5):

ip vrf ABC

 rd10:5

route-target export 5:6

route-target import 2:1

 

interface Ethernet0/2

 ipvrf forwarding ABC

 ipaddress 172.10.56.5 255.255.255.0

 

address-family ipv4 vrf ABC

 redistribute ospf 100 match internal external 1 external 2

 exit-address-family

 

IOU6(北京)

router ospf 100

 router-id 172.10.0.6

 redistribute connected subnets route-map lo1

 network 172.10.0.6 0.0.0.0 area 0

 network 172.10.56.0 0.0.0.255 area 0

 

 route-maplo1 permit 10

 match interface Loopback1

 

interface Loopback0

 ipaddress 172.10.0.6 255.255.255.255

 

深圳查看路由表:

O IA    172.10.0.6/32 [110/21] via 172.10.12.2, 03:04:46, Ethernet0/0

Traceroute:

Tracing the route to 172.10.0.6

VRF info: (vrf in name/id, vrf out name/id)

  1172.10.12.2 4 msec 4 msec 6 msec

  210.10.29.9 [MPLS: Labels 904/513 Exp 0] 6 msec 5 msec 5 msec

  3172.10.56.5 [MPLS: Label 513 Exp 0] 5 msec 5 msec 5 msec

  4172.10.56.6 6 msec 4 msec 4 msec 


北京查看路由表:

O IA     172.10.0.1/32 [110/21] via172.10.56.5, 03:05:26, Ethernet0/0

Tracing the route to 172.10.0.1

VRF info: (vrf in name/id, vrf out name/id)

  1172.10.56.5 1 msec 5 msec 5 msec

  210.10.59.9 [MPLS: Labels 907/213 Exp 0] 1 msec 0 msec 1 msec

  3172.10.12.2 [MPLS: Label 213 Exp 0] 0 msec 5 msec 5 msec

  4172.10.12.1 1 msec 0 msec 1 msec


截止目前,拓扑图左上和右上的俩台CE设备已经能实现互访,并在同一子网内。即实现L3-MPLS-***通信,此种实现方式在目前主流的二级运营商中应用极广,虽然技术出来很久了,不过仍然是主流技术。