今天早上起来,突然程序运行不起来了,昨天晚上还好好的,今天就报Unable to validate using XSD: Your JAXP provider [gnu.xml.dom.JAXPFactory@4d76b4] does not support XML Schema. Are you running on Java 1.4 with Apache Crimson?这个错,

自己吧jframechart的三个包全部删除,重启,没报错,然后删去了gunjaxp.jar包,只放入了,Unable <wbr>to <wbr>validate <wbr>using <wbr>XSD: <wbr>Your <wbr>JAXP <wbr>provider <wbr>[gnu.xm

重启,然后又可以运行了,上网查了,也有其他解决方法,我自己也没尝试,

网上查,是说

 网上搜索办法

          1.更换jdk。从1.5更换到1.6 ,我这里没有解决。

          2.jar包冲突, gnujaxp.jar 和 xerces.jar 冲突,删除gnujaxp.jar

            3.项目中添加xml-apis.jar、xercesImpl.jar

          4.通过把JAXP相关的jar包在classpath中的order提前,包括XercesImpl.jar,Xalan.jar,xml-api.jar。ps:这里不知道怎么提前。

          5.删除项目中的xerces.jar 

          6.在java启动参数中添加如下参数 -Djavax.xml.parsers.DocumentBuilderFactory=com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderFactoryImpl -Djavax.xml.parsers.SAXParserFactory=com.sun.org.apache.xerces.internal.jaxp.SAXParserFactoryImpl。