奠基计算机网络视频教程下载
 
下载网址
www.91xueit.com     CCNA视频教程50小时完整版
其中webex是播放软件,该软件也可以录制屏幕

2008-11-29
车辆厂网络拓扑展示
局域网
广域网
服务器
客户机
应用程序
服务  
OSI参考模型
     分层的好处
          数据通信的每个环节变化不影响其他环节
          各个厂商设备标准化
     应用层 能够产生网络流量的网络应用程序 QQ IE
     表示层 加密 压缩 二进制 ASCII码 IE浏览器出现乱码
     会话层 查木马 查看会话 netstat -nb
     传输层 可靠传输 不可靠传输 流量控制 滑动窗口技术面向连接(三次握手) 确认
     网络层 选择路径
     数据链路层 定义了如何标识网络设备
     物理层 发送和接收Bit流 电压 接口
   从排错来看OSI参考模型
     从底层向高层逐一排错
         物理层错误 连接是否正常
         数据链路层 ADSL拨号数据链路层通 网络层才能通
                   arp -s 192.168.1.1 00-1d-0f-68-42-fe
         网络层 选择路径出现的故障 计算机没有设置网关
         表示层 IE乱码
         应用层 IE 插件

   从安全角度来看OSI参考模型
         物理层安全
         数据链路层安全 在交换机上的端口绑定MAC地址
         网络层安全 网络层防火墙 在网络设备上指定ACL 控制数据包流量
         应用层安全 杀毒软件 应用层防火墙高级防火墙 ISA 2006 可以基于 源地址 目标地址 协议 端口号 时间 用户 文件类型 来控制网络流量
  
   网络设计三层模型
       接入层交换机 直接接用户计算机的交换机 接入层交换机 口多 10 or 100M
       汇集层交换机 接接入层交换机 端口带宽高 端口比接入层相对较少
       核心层交换机 连接汇聚成交换机
   网络设备
       MAC
       集线器 (HUB) 10M 100M 100米 不安全 是一个大的冲突域 30左右计算机
       交换机 基于MAC地址转发数据,安全 端口带宽独享 标准以太网10,快速以太网100,G 1000M 广播域
       路由器 基于IP地址转发数据 广域网接口 隔绝广播 ACL
       网线 双绞线 8根 4对 10M 100M 1236通信 1000M 8根全用
       直通线 交叉线 全反线 Console调路由器 10 100M 123 6 1000M 8
  
    半双工和全双工以太网
       HUB
       交换机 全双工
下午
   传输层协议
   TCP 协议 传输前 数据分段 编号 建立会话 可靠传输 netstat -n
   UDP 一个数据包就能完成任务 不可靠传输 不建立会话 数据不分段 编号
   应用层协议
   http=TCP+80
   ftp=TCP+21 or 20
   SMTP=TCP+25 发送电子邮件
   PoP3=TCP+110
   RDP=TCP+3389 远程桌面协议
   数据库=TCP+1433
   DNS=UDP or TCP +53
   1024端口
   端口用来标识服务器的服务 不同服务使用端口应该不同
   默认端口可以更改,客户端必须也得更改
  
   试验:
   给计算机安装DNS服务 DHCP服务 FTP服务 电子邮件服务 FTP Web 服务 流媒体服务
   客户端请求服务器上的服务
   查看本地服务器打开的端口 netstat -anb
   查看远程服务器打开的端口
   试验:
   启用Windows防火墙保护XP的安全
   在服务器上只打开必须的端口
   使用IPSec防止灰鸽子木马
   更改远程桌面服务端口 4000 mstsc
   网络层协议 IP (RIP EIGRP OSPF)
             ICMP 测试网络连通性 ping pathping tracert(路由器上使用)
             ping Ip -t ctrl +C 停止ping
             pathping
             IGMP 组播管理 点到点 广播 目标MAC 或IP地址全1 多播(组播)
             ARP IP-->MAC地址 广播 arp -s 192.168.1.1 32-32-32-32-23-32
  
   数据封装
   传输层 数据段 消息
   网络层 数据包
   数据链路层 数据帧
   物理层 Bit
  
   排错
   ipconfig /all
   ping 127.0.0.1 网卡驱动没问题
   ping 网关 和局域网是通的
   ping 202.99.160.68 Internet网络层通
   ping www.inhe.net 查看域名解析是否正常 网络层测试
   telnet www.inhe.net 80 应用层测试
   检查IE设置
   替换法
2008-11-30
    试验
    本地计算机打开的端口
    启用远程桌面 查看打开的端口 3389
    使用另外一台计算机 telnet Ip 3389 mstsc 连接服务器
    查看远程桌面回话
    设置Windows防火墙只打开TCP的3389端口
    ARP 欺骗 arp -s 192.168.1.1 22-21-21-21-12-12
    捕包工具 对于IP地址欺骗没有办法

   数据路由过程数据帧和数据包的变化
  
   IP地址
   IP地址的分类默认子网掩码
   A 0-127
   B 128-191
   C 192-223
   D 224-239 无子网掩码
   E 240-255 测试用

   公网地址
   保留的私有地址
   10.0.0.0
   172.16.0.0--172.31.0.0
   192.168.0.0--192.168.255.0
   169.254.0.0
   127.0.0.1
   广播地址
   第二层广播 MAC地址
   广播(第3层)
   单播
   组播

   NAT 省IP地址 内网安全 慢
   端口映射 允许外网访问内网
IP地址
二进制   十进制
       1   1
      10   2
     100   4
    1000   8
   10000   16
100000   32
1000000   64
10000000 128
10000000 128
11000000 192
11100000 224
11110000 240
11111000 248
11111100 252
11111110 254
11111111 255
IP地址的分类
A类 0-127
B类 128-191
C类 192-223
D类 224-239 多播地址 无子网掩码
E 类240-255   用于测试
00000000--01111111 A
10000000--10111111 B
11000000--11011111 C
11100000--11101111 D

子网划分
   子网掩码的作用
    等长子网
    变长子网
    超网
 
2008-12-6
路由器
模块化
固定模块
系列
IOS

telnet 192.168.1.200
R1
断开 ctrl+shift+6 X
查看会话 show session
断开会话 disconnect 1

路由配置常用命令
Router#
show interface 查看路由器的接口
show running-config 查看路由的配置 密码 接口IP地址 ACL NAT
show version 查看路由器版本 配置寄存器的值
show ip interface brief 查看和Ip相关的接口信息
show ip route 查看路由表
show ip protocal 查看路由器运行的动态路由协议
config t
Router(config)#
Router(config)#hostname Router1
Router1(config)#enable password aaa
Router1(config)#enable secret aaaa
配置Telnet密码 TCP 23
Router1(config)#line vty 0 4
Router1(config-line)#password aaa 设置Telnet密码
Router1(config-line)#login 要求必须登录
Telnet如果不需要密码执行以下命令
Router1(config)#line vty 0 4
Router1(config-line)#no login
Router1(config-line)#no password
配置路由器接口IP地址
Router1(config)#interface fastEthernet 0/0
Router1(config-if)#ip address 192.168.0.1 255.255.255.0
Router1(config-if)#no sh
Router1(config)#interface serial 2/0
Router1(config-if)#clock rate 64000 在DCE端配置时钟频率
Router1(config-if)#ip address 10.0.0.1 255.255.255.0
Router1(config-if)#no sh
管理Cisco互联网络
路由器的硬件
RAM 相当于计算机的内存 配置路由器的设置默认是RAM
NVRAM 相当于硬盘存放 startup-config
ROM    相当于计算机的BIOS , 不能删除 存放 Bootstarp POST 微型IOS
Flash 存放IOS
 

恢复路由器密码
Router#show version
Configuration register is 0x2102
重启路由器
Ctrl+breack 中断路由器正常启动
rommon 2 > confreg 0x2142
Router#copy startup-config running-config
Router(config)#enable secret aaaa
Router#copy running-config startup-config
Router(config)#config-register 0x2102
密码恢复成功

修改配置寄存器
在2600系列命令
Rommon 1 > confreg 0x2142
输入Reset
配置2500系列命令
产生中断后输入o,再输入o/r 0x2142
输入I(初始化)

备份和升级路由器IOS

r5#copy flash tftp 备份系统
r5#copy tftp flash 升级系统

Cisco发现协议 CDP 二层地址
Router(config)#cdp run
Router#show cdp neighbors
从路由器Telnet到其他路由器
从路由器telnet 其他路由器 临时退出会话
ctrl+shift+6
X
查看会话 show sessions
在路由器上查看连接过来的用户 show users

解析主机名
Router(config)#ip host Router0 172.16.5.1 添加名称和IP地址对应关系
RouterB(config)#ip domain-lookup 启用域名查找
RouterB(config)#ip name-server 202.99.160.68 配置DNS服务器
Router#telnet Router0
网络排错
ipconfig /all 查看计算机的IP配置,包括IP地址,子网掩码、网关 DNS服务器设置
ping 网关IP地址
ping 202.99.160.68 or 202.99.168.8 测试到Internet的网络层是否通
ping www.inhe.net 域名是否能解析成IP地址
telnet www.inhe.net 80 测试应用层是否畅通 23默认端口
pathping www.inhe.net 跟踪数据包路径和计算丢包情况
tracert ip 类似与计算机上的pathping 能够跟踪数据包路径不计算机丢包情况
Router#debug ip packet
Router#debug ip ?
icmp     ICMP transactions
nat      NAT events
ospf     OSPF information
packet   Packet information
rip      RIP protocol transactions
routing Routing table events
Router#undebug all
路由
不同网段计算机通信就叫路由
对路由器的要求,必须知道到网络中各个网段如何转发

静态路由 管理员告诉路由器到各个网段如何转发
Router(config)#ip route 192.168.6.0 255.255.255.0 192.168.1.2 ?(可以更改管理距离AD)
路由汇总
ip route 192.168.0.0 255.255.252.0 19
默认路由 代表大多数网段的路由
优先级最低
末端网络路由器使用默认路由减少路由表项
骨干网路由器通过路由汇总减少路由表项
动态路由 路由器自己来学习到各个网段如何转发
 
 
2008-12-7
下午
静态路由不能自动根据网络变换而变化 规模小 没有环
在计算机上添加路由表
route add 192.168.2.0 mask 255.255.255.0 192.168.1.2 添加路由表
route print 显示计算机上的路由表
netstat -r
动态路由
网络规模较大 or 具有网状结构的网络
RIP 周期性广播路由表 30秒 度量值是跳数 15跳 16跳认为不可到达
RIPv1 广播传播路由信息 支持等长子网 不支持变长子网和不连续子网
RIPv2 多播传播路由信息 支持变长子网 和 不连续子网(关闭自动汇总)传播路由信息中包含了子网掩码信息
EIGRP 相当于RIPv2 支持变长子网 关掉汇总,支持不连续子网。
Router#config t
Router(config)#router rip
Router(config-router)#network 172.16.0.0
Router(config-router)#network 10.0.0.0
Router(config-router)#version 2
Router(config-router)#no auto-summary
EIGRP协议 非周期性更新路由信息,Hello报文发现和跟踪邻居 以太网5秒,T1或更低的速率 Hello报文以单播方式60秒发送一次,3倍时间确认失效,使用224.0.0.10用户邻居发现和回复,邻居使用单播地址确认 度量值默认带宽和延迟 支持大的网络默认100跳 最大255跳 必须是统一自制区域才能交换路由信息 支持变长子网和不连续子网(关闭自动汇总) 收敛速度块(有备用路径) Cisco专有协议
度量值 可以包括 跳数 带宽 延迟 负载 可靠性 代价(cost)
Router#show ip protocols 显示配置的所有动态路由协议

Router(config)#router eigrp 10
Router(config-router)#network 192.168.0.0
Router(config-router)#no auto-summary
查看备用路径
Router#show ip eigrp topology
路由信息可信度 值越低优先级越高
    直连的网络 0
    静态路由   1   ip route 10.0.0.0 255.0.0.0 192.168.1.1 121
    EIGRP      90
    OSPF       110
    RIP        120

2008-12-13
OSPF 路由表 由路由根据链路状态数据库算出来的,不出现环路,路由器之间更新的是链路状态,度量值带宽。触发式更新。
路由器三个表 邻居表,链路状态表,路由表
特性
    有地区和自制系统组成
    最小化路由更新流量
    可扩展
    支持变长子网
    跳数不受限
    标准 开放的标准
DR 指定路由器
BDR 备用的指定路由器

OSPF配置
Router(config)#router ospf 110 进程号
Router(config-router)#network 172.16.0.0 0.0.255.255 area 0 区域号 只有同一个区域的接口才能交换链路状态信息
Router(config-router)#network 172.16.0.1 0.0.0.0 area 0
查看路由表
show ip route
查看链路状态数据库
Router#show ip ospf databases
查看邻居
Router#show ip ospf neighbor
 
更改DR BDR选举优先级
Router(config-if)#ip ospf priority 2
 

交换
   交换机MAC地址表是通过数据帧的源MAC地址构造的
   交换机端口可以实现安全
   交换机端口上实现安全
可以控制交换机端口连接计算机数量
在交换机端口绑定MAC地址 MAC和IP
Switch(config-if)#switchport mode access 配置该接口为访问接口
Switch(config-if)#switchport port-security
Switch(config-if)#switchport port-security violation shutdown
Switch(config-if)#switchport port-security maximum 1
Switch(config-if)#switchport port-security mac-address 0090.0CD7.65C8
生成树(STP)
   交换机的端口状态
      阻断 监听 学习 转发 禁用
   Hello 时间 BPDU 默认 2S
选根交换机(根网桥) 网桥ID=优先级+MAC 网桥ID小的优先成为根
非根网桥 选根端口 到根交换机近的端口
    1.最顶的网桥ID
    2.最低的到达根网桥的路径开销
    3.最低的发送方网桥ID
    4.最低的端口优先级
    5.最低的端口ID

每根网线两端确定一个指定端口,到根交换机近的为指定端口
确定根网桥
Switch#show spanning-tree
更改网桥优先级
Switch(config)#spanning-tree vlan 1 priority 4096
 

关闭生成树
Switch(config)#no spanning-tree
配置PortFast 连接计算机和服务器的端口可以配置成portFast端口,立即进入转发状态,而避免监听状态和学习状态
Switch(config)#spanning-tree portfast
虚拟局域网VLAN
查看VLAN命令
Switch#show vlan
创建VLAN
Switch#config t
Switch(config)#vlan 2
Switch(config-vlan)#ex
Switch(config)#interface range fastEthernet 0/11 - 24
Switch(config-if-range)#switchport access vlan 2

Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.0.100 255.255.255.0
Switch(config-if)#no sh
Switch(config-if)#exit
Switch(config)#ip default-gateway 192.168.0.1
Switch(config)#enable password aaa
Switch(config)#line vty 0 ?
Switch(config)#line vty 0 15
Switch(config-line)#password aaa
Switch(config-line)#login
 
VLAN间路由

Switch(config-if)#switchport mode trunk

Router(config)#interface gigabitEthernet 6/0
Router(config-if)#no sh
Router(config)#interface gigabitEthernet 6/0.1
Router(config-subif)#encapsulation dot1Q 1
Router(config-subif)#ip address 192.168.0.1 255.255.255.0
带路由模块的交换机实现VLAN间路由

VTP实现VLAN的添加 删除在一个交换机上统一配置
Switch(config)#vtp domain todd
Switch(config)#vtp password aaa
Switch(config)#vtp mode client

三层交换解决了VLAN间路由速度问题
 
网络层安全--ACL
安全
非军事区 Internet 内网
三向外围王
背靠背防火墙
网络攻击
Dos DDos分布式拒绝服务攻击
后门程序

IP欺骗
捕获数据包
中间人攻击
标准访问控制列表
    基于源IP地址过滤数据包

扩展访问控制列表
    基于源IP地址 目标IP地址 协议(TCP UDP IP(TCP UDP ICMP) ICMP)目标端口 来控制
定义标准ACL
Router#config t
Router(config)#access-list 10 deny host 192.168.2.2
Router(config)#access-list 10 permit 192.168.2.0 0.0.0.255
ACL 默认隐含拒绝所有
查看ACL
Router#show ip access-lists
将ACL绑定到接口
Router#config t
Router(config)#interface serial 3/0
Router(config-if)#ip access-group 10 out

删除ACL
Router(config)#no access-list 10
ACL项 从上到下依次检查,添加ACL时应该将具体IP地址或较为具体的网段放到ACL上面
调整ACL顺序,删除ACL,再创建
将ACL在记事本中编辑好,粘贴到CLI
access-list 10 deny host 192.168.2.2
access-list 10 permit 192.168.2.0 0.0.0.255

先写拒绝的项,其余都允许
access-list 10 deny host 192.168.2.2
access-list 10 permit 192.168.2.0 0.0.0.255
access-list 10 permit any 最后写
ACL等价的写法
access-list 10 deny host 192.168.2.2 ==
access-list 10 deny 192.168.2.2 0.0.0.0
access-list 10 permit any ==
access-list 10 permit 0.0.0.0 255.255.255.255

定义扩展ACL
Router(config)#access-list 110 permit tcp 192.168.2.0 0.0.0.255 host 10.0.0.2 eq 80
Router(config)#interface serial 3/0
Router(config-if)#ip access-group 110 out
Router(config)#access-list 110 permit icmp 192.168.2.0 0.0.0.255 any
Router(config)#access-list 110 permit ip 192.168.0.0 0.0.0.255 any
访问控制列表位置
标准的ACL放到距离目标网络近的路由器上
扩展的ACL放到距离源地址较近的路由器上
网络地址转换 NAT
静态NAT
动态NAT
PAT
端口映射
 
 
安全 内网受保护
访问内网必须配置端口映射
代理软件 ccproxy
VPN
路由环境中IP地址自动分配方法
Router(config-if)#ip helper-address 192.168.0.199
2008-12-27
广域网
专线 安全 带宽有保证
电路交换 电话
包交换 类似以太网

铜线 x.25 光线 帧中继
广域网 封装
PPP协议 工业标准 HDLC 链路控制协议LCP 网络控制协议(NCP)