多角色主机存在的 意义,是为了让某而个***中的站点,可能是属于某个特定VRF的一个CE接口,下所连的用户即可访问VRFA又可以访问VRFB,起先这样的方式可以使用灵活的RT实现,但主要不安全,并不是基于主机的。而是整个VRF都整合了。
1 我们使用策略路由,优先于传统路由在CE相关接口处重定向数据到其他的VRF中。主要数据就可以跨VRF出去了
2 使用静态路由强行选路,在返回的***B中引入这个静态路由发布到***B的其他站点即可。
#
sysname RT1
#
router id 1.1.1.1
#
mpls lsr-id 1.1.1.1
#
radius scheme system
#
mpls
#
mpls ldp
#
ip ***-instance ***a
route-distinguisher 100:1
***-target 100:1 export-extcommunity
***-target 100:1 import-extcommunity
#
ip ***-instance ***b
route-distinguisher 200:1
***-target 200:1 export-extcommunity
***-target 200:1 import-extcommunity
#
domain system
#                                         
acl number 3000              /指定多角色主机的地址,用于策略路由中使用/
rule 0 permit ip ***-instance ***a source 192.168.11.2 0
#
interface Ethernet1/0/0
ip binding ***-instance ***a
ip address 192.168.11.1 255.255.255.0
ip policy route-policy multi-role           
/在接口上应用策略路由,实现多角色主机功能/
#
interface Serial2/0/0
link-protocol ppp
ip address 10.0.0.1 255.255.255.252
mpls
mpls ldp enable
#
interface NULL0
#
interface LoopBack0
ip address 1.1.1.1 255.255.255.255
#
interface LoopBack21
ip binding ***-instance ***b
ip address 192.168.21.1 255.255.255.0
#
bgp 100
undo synchronization                     
group inter internal                     
peer 2.2.2.2 group inter                 
peer 2.2.2.2 connect-interface LoopBack0
#
ipv4-family ***-instance ***a
   import-route direct
   undo synchronization
#
ipv4-family ***-instance ***b
   import-route direct
  import-route static                       /***b中引入静态路由/
   undo synchronization
#
ipv4-family ***v4
   peer inter enable
   peer 2.2.2.2 group inter
#
ospf 1
area 0.0.0.0
   network 1.1.1.1 0.0.0.0
   network 10.0.0.0 0.0.0.3
#
route-policy multi-role permit node 10       
/定义策略路由,实现多角色主机在***b中查找路由/
if-match acl 3000                            /引用ACL 3000/
apply access-*** ***-instance ***b           /实现多角色主机在***b中查找路由/
#                                         
ip route-static ***-instance ***b 192.168.11.2 255.255.255.255 ***-instance ***a 192.168.11.2   preference 60
/***b中添加一条访问PC1的静态路由,保证***b的返回报文可以转发给PC1 /
#                                         
user-interface con 0
user-interface vty 0 4