分层PE,是个很好的节约技术,可以节约PE设备的投资,当然本人不多做介绍了,要了解她是做什么的,可以去下个文档补一补。在这里要指出几个问题
1 ,如果配置了HOVPE,之后SPE上不可不配相关的***,否则默认路由发送不出去,实际上配置都配置不进去,从原理角度考虑到,如果没有相关***存在,则RT列表无法构建,因此无法学习周围的***路由。除非你在MBGP中配置UNDO POLICY-***TAG。即取消RT过滤,这样路由确实学到了,但是默认路由还是发送不出去,因为不知道该吧默认路由发送到那一个***实例里,所以最后还是必须配置一个***实例,即使你只需要配置出方向的RT,用于封装默认路由。一般建议不要这样做,切记SPE上必须有2端PE的所有***以及路由,否则将导致路径不通,因此必须要配置双向RT。
2 配置HOVPE的时候,SPE成为了UPE的RR,注意这个时候本RR是自动的,而且是单向的,只允许UPE的路由反射给其他PE,绝对不允许其他PE的路由反射给UPE,只给UPE扔一条默认路由带标签的。但是注意,如果是SPE的***实例里自己写一条聚合的路由,然后通过MBGP发送给UPE这个是可以的。这个符合RR的特性,RR自己的路由是不需要经过反射久可以发给自己的IBGP邻居的。其实书里曾说过,UPE只会维护自己的***站点路由,以及SPE给的默认路由,不是很标准,应该还有SPE给的汇总路由,SPE---MPE---UPE 3层结构嵌套中就存在SPE给MPE发送SPE自己的汇总路由,这个可以人为制造。只要了解原理即可。
3 原本反射的路由下以跳是不改变的,但是在MBGP中,***的路由下一跳必须变成自己的BGP接口地址。但是如果是HOVPE,在SPE上,可以将***中学到的路由做一次中继发送,就是让SPE,自己在BGP的实例中发布***中的路由。让MBGP发给UPE,其实自己的***中的路由也是从对方学习到的,但是SPE不会反射到UPE上,因此只好让SPE自己发布***中的路由。
废话说了一大堆了,这里要说明下,网络之路里确实提到了可以向UPE发送汇总路由,但是我们的设备上好像没有实现,而是完全毒杀了所有去往UPE的路由,只给他默认路由,比如SPE发给UPE的,UPE也收不到
下面来看一下本人的试验,图接本上很简单,自己构思下吧
PE----SPE---UPE--CE。CE我一般使用LOOPBACK了。如果看不懂配置的话,希望先看一看操作手册。不然图画的累人。
这个试验证明了1个问题 1 SPE在UPE方向上除了公布默认路由以外所有的路由都封杀了,报过他自己的路由。只有默认路由可以下去。当然希望以后能够改进理论上完全是可行的。
另外再次声明自动汇总是只能汇总起源于自己的引入路由,network注入的都不能自动汇总。
-----------------------------------------------------------------------------------
附上配置:
<UPE>   dis cur
#
sysname UPE
#
cpu-usage cycle 1min
#
mpls lsr-id 11.11.11.11
#
radius scheme system
#
mpls
#
mpls ldp
#
ip ***-instance A
route-distinguisher 1:1
***-target 1:1 export-extcommunity
***-target 1:1 import-extcommunity
#
domain system
#
local-user admin
password cipher .]@USE=B,53Q=^Q`MAF4<1!!
service-type telnet terminal
level 3
service-type ftp                         
#
interface Aux0
async mode flow
#
interface GigabitEthernet0/0/0
ip address 1.1.1.1 255.255.255.252
mpls
mpls ldp enable
#
interface GigabitEthernet0/0/1
ip address dhcp-alloc
#
interface GigabitEthernet0/0/2
ip address dhcp-alloc
#
interface NULL0
#
interface LoopBack1
ip address 11.11.11.11 255.255.255.255
#
interface LoopBack2
ip binding ***-instance A
ip address 111.111.111.1 255.255.255.252
#                                         
bgp 1
undo synchronization
group ibgp internal
peer 22.22.22.22 group ibgp
peer 22.22.22.22 connect-interface LoopBack1
#
ipv4-family ***-instance A
   import-route direct
   undo synchronization
#
ipv4-family ***v4
   peer ibgp enable
   peer 22.22.22.22 group ibgp
#
ospf 1
area 0.0.0.0
   network 1.1.1.1 0.0.0.0
   network 11.11.11.11 0.0.0.0
#
FTP server enable
#
user-interface con 0
user-interface aux 0
user-interface vty 0 4                    
authentication-mode scheme
#
return
<UPE>
------------------------------------------------------------------------------------------------
[SPE-bgp]dis cur
#
sysname SPE
#
cpu-usage cycle 1min
#
mpls lsr-id 22.22.22.22
#
radius scheme system
#
mpls
#
mpls ldp
#
ip ***-instance A
route-distinguisher 1:1
***-target 1:1 export-extcommunity
***-target 1:1 import-extcommunity
#
domain system
#
local-user admin
password cipher .]@USE=B,53Q=^Q`MAF4<1!!
service-type telnet terminal
level 3
service-type ftp                         
#
interface Aux0
async mode flow
#
interface Ethernet0/0
ip address 1.1.1.2 255.255.255.252
mpls
mpls ldp enable
#
interface Ethernet0/1
ip address dhcp-alloc
#
interface Serial0/0
link-protocol ppp
ip address 1.1.1.5 255.255.255.252
mpls
mpls ldp enable
#
interface NULL0
#
interface LoopBack1
ip address 22.22.22.22 255.255.255.255
#
interface LoopBack3                       
ip binding ***-instance A
ip address 20.20.20.20 255.255.255.0
#
bgp 1
undo synchronization
group ibgp internal
peer 33.33.33.33 group ibgp
peer 33.33.33.33 connect-interface LoopBack1
group upe internal
peer 11.11.11.11 group upe
peer 11.11.11.11 connect-interface LoopBack1
#
ipv4-family ***-instance A
   aggregate 10.0.0.0 255.0.0.0 detail-suppressed
   summary
   network 20.20.20.0 255.255.255.0
   undo synchronization
#
ipv4-family ***v4
   undo policy ***-target
   peer ibgp enable
   peer 33.33.33.33 group ibgp
   peer upe enable
   peer 11.11.11.11 group upe              
   peer 11.11.11.11 upe
   peer 11.11.11.11 default-route-advertise ***-instance A
#
ospf 1
area 0.0.0.0
   network 0.0.0.0 255.255.255.255
#
FTP server enable
#
user-interface con 0
user-interface aux 0
user-interface vty 0 4
authentication-mode scheme
#
return
[SPE-bgp]
--------------------------------------------------------------------------------
<PE>dis cur
#
sysname PE
#
cpu-usage cycle 1min
#
mpls lsr-id 33.33.33.33
#
radius scheme system
#
mpls
#
mpls ldp
#
ip ***-instance A
route-distinguisher 1:1
***-target 1:1 export-extcommunity
***-target 1:1 import-extcommunity
#
domain system
#
local-user admin
password cipher .]@USE=B,53Q=^Q`MAF4<1!!
service-type telnet terminal
level 3
service-type ftp                         
#
interface Aux0
async mode flow
#
interface Ethernet0/0
ip address dhcp-alloc
#
interface Ethernet0/1
ip address dhcp-alloc
#
interface Serial0/0
clock DTECLK1
link-protocol ppp
ip address 1.1.1.6 255.255.255.252
mpls
mpls ldp enable
#
interface NULL0
#
interface LoopBack1
ip address 33.33.33.33 255.255.255.255
#
interface LoopBack2
ip binding ***-instance A                
ip address 10.10.10.10 255.255.255.0
#
interface LoopBack3
ip binding ***-instance A
ip address 10.11.11.11 255.255.255.0
#
bgp 1
undo synchronization
group ibgp internal
peer 22.22.22.22 group ibgp
peer 22.22.22.22 connect-interface LoopBack1
#
ipv4-family ***-instance A
   import-route direct
   undo synchronization
#
ipv4-family ***v4
   peer ibgp enable
   peer 22.22.22.22 group ibgp
#
ospf 1
area 0.0.0.0
   network 1.1.1.4 0.0.0.3
   network 33.33.33.33 0.0.0.0             
#
FTP server enable
#
user-interface con 0
user-interface aux 0
user-interface vty 0 4
authentication-mode scheme
#
return
<PE>     
--------------------------------------------------------------------
附上结果
UPE上VRF路由表
<UPE> dis ip routing-table ***-instance A
   A    Route Information
Routing Table:   A    Route-Distinguisher:    1:1
Destination/Mask    Protocol Pre   Cost         Nexthop          Interface
0.0.0.0/0           BGP       256   0            22.22.22.22      InLoopBack0
111.111.111.0/30    DIRECT    0     0            111.111.111.1    LoopBack2
111.111.111.1/32    DIRECT    0     0            127.0.0.1        InLoopBack0
---------------------------------------------------------------------------------------
[SPE-bgp]dis ip routing-table ***-instance A
   A    Route Information
Routing Table:   A    Route-Distinguisher:    1:1
Destination/Mask    Protocol Pre   Cost         Nexthop          Interface
10.0.0.0/8          AGGRE     130   0            127.0.0.1        InLoopBack0
10.10.10.0/24       BGP       256   0            33.33.33.33      InLoopBack0
10.11.11.0/24       BGP       256   0            33.33.33.33      InLoopBack0
20.20.20.0/24       DIRECT    0     0            20.20.20.20      LoopBack3
20.20.20.20/32      DIRECT    0     0            127.0.0.1        InLoopBack0
111.111.111.0/30    BGP       256   0            11.11.11.11      InLoopBack0
-------------------------------------------------------------------------------------
<PE>dis ip routing-table ***-instance A
   A    Route Information
Routing Table:   A    Route-Distinguisher:    1:1
Destination/Mask    Protocol Pre   Cost         Nexthop          Interface
10.0.0.0/8          BGP       256   0            22.22.22.22      InLoopBack0
10.10.10.0/24       DIRECT    0     0            10.10.10.10      LoopBack2
10.10.10.10/32      DIRECT    0     0            127.0.0.1        InLoopBack0
10.11.11.0/24       DIRECT    0     0            10.11.11.11      LoopBack3
10.11.11.11/32      DIRECT    0     0            127.0.0.1        InLoopBack0
20.20.20.0/24       BGP       256   0            22.22.22.22      InLoopBack0
111.111.111.0/30    BGP       256   0            22.22.22.22      InLoopBack0
<PE>
---------------------------------------------------------------------------------
结果:
<UPE>ping -***-instance A -A 111.111.111.1 10.10.10.10   
   PING 10.10.10.10: 56   data bytes, press CTRL_C to break
     Reply from 10.10.10.10: bytes=56 Sequence=1 ttl=255 time=28 ms
     Reply from 10.10.10.10: bytes=56 Sequence=2 ttl=255 time=27 ms
     Reply from 10.10.10.10: bytes=56 Sequence=3 ttl=255 time=27 ms
     Reply from 10.10.10.10: bytes=56 Sequence=4 ttl=255 time=27 ms
     Reply from 10.10.10.10: bytes=56 Sequence=5 ttl=255 time=27 ms
   --- 10.10.10.10 ping statistics ---
     5 packet(s) transmitted
     5 packet(s) received
     0.00% packet loss
     round-trip min/avg/max = 27/27/28 ms
<UPE>ping -***-instance A -A 111.111.111.1 10.11.11.11
   PING 10.11.11.11: 56   data bytes, press CTRL_C to break
     Reply from 10.11.11.11: bytes=56 Sequence=1 ttl=255 time=28 ms
     Reply from 10.11.11.11: bytes=56 Sequence=2 ttl=255 time=27 ms
     Reply from 10.11.11.11: bytes=56 Sequence=3 ttl=255 time=27 ms
     Reply from 10.11.11.11: bytes=56 Sequence=4 ttl=255 time=27 ms
     Reply from 10.11.11.11: bytes=56 Sequence=5 ttl=255 time=27 ms
   --- 10.11.11.11 ping statistics ---
     5 packet(s) transmitted
     5 packet(s) received
     0.00% packet loss
     round-trip min/avg/max = 27/27/28 ms