Unsupported major.minor version 52.0: 看到Unsupported你是不是会想到jdk高版本能兼容低版本,但是低版本不能兼容高版本,不错,猜对了,其实就是这个意思。这个错误意思是你项目用JDK1.8运行过,现在又在本地的eclipse等开发工具或者本地环境变量为低版本的jdk1.7或者jdk1.6下运行,eclipse会说:“本地jdk版本太低,不支持这个jdk1.8编译过的项目运行”。
你看看你本地是报52还是51或者其他的错。

64位系统可以和32位系统的JDK兼容,只要是同版本JDK编译过的项目系统就都可以运行。