(3)vrrp技术实现网络高可用性:

vrpp协议简介:

VRRP是一种容错协议它为具有组播或广播能力的局域网如以太网设计它保证当局域网内主机的下一跳路由器出现故障时可以及时的由另一台路由器来代替从而保持通讯的连续性和可靠性为了使VRRP工作要在路由器上配置虚拟路由器号和虚拟IP地址同时产生一个虚拟MAC地址这样在这个网络中就加入了一个虚拟路由器而网络上的主机与虚拟路由器通信无需了解这个网络上物理路由器的任何信息一个虚拟路由器由一个主路由器和若干个备份路由器组成主路由器实现真正的转发功能当主路由器出现故障时一个备份路由器将成为新的主路由器接替它的工作。

VRRP 工作方式:

1.主备备份
主备备份方式需要建立一个备份组,该备份组包括一个Master 路由器和若干Backup 路由器。
正常情况下,业务全部由 Master 路由器承担。
Master 出现故障时,Backup 路由器接替工作。

2. 负载分担
负载分担方式是指多台路由器同时承担业务,因此需要建立两个或更多的备份组。
负载分担方式的备份组具有以下特点。
每个备份组都包括一个 Master 路由器和若干Backup 路由器。
各备份组的 Master 路由器可以不同。
同一台路由器可以加入多个备份组,在不同备份组中有不同的优先级。

vrrp实例应用:

实验要求:

R5为vlan10的主路由,为vlan20的备份路由。R9为vlan20的主路由,为vlan10的备份路由。R10为外网,现要求vlan10的的请求都经过S13从R5向服务器发出请求。vlan20的请求都经过S11从R9向服务器发出请求。当一条路由出故障时,都任然能从另一条路由通信。

配置信息:

R5配置信息:

[r5]dis cur
  Now create configuration...
  Current configuration
  !
    version 1.74
    sysname r5
    firewall enable
    aaa-enable
    aaa accounting-scheme optional
    vrrp ping-enable
  !
  acl 2000 match-order auto
    rule normal permit source 192.168.10.0 0.0.0.255
    rule normal permit source 192.168.20.0 0.0.0.255
  !
  interface Aux0
    async mode flow
    link-protocol ppp
  !
  interface Ethernet0
  !
  interface Ethernet0.10
    vlan-type dot1q vid 10
    ip address 192.168.10.1 255.255.255.0
    vrrp vrid 10 virtual-ip 192.168.10.254
    vrrp vrid 10 priority 120
  !
  interface Ethernet0.20
    vlan-type dot1q vid 20
    ip address 192.168.20.1 255.255.255.0
    vrrp vrid 20 virtual-ip 192.168.20.254
  !
  interface Ethernet1
  !
  interface Serial0
    link-protocol ppp
  !
  interface Serial1
    link-protocol ppp
    ip address 192.168.30.2 255.255.255.0
    nat outbound 2000 interface
  !
   voice-setup
    !
    subscriber-line 0
    !
    subscriber-line 1
    !
    quit
  !
  quit
  ip route-static 0.0.0.0 0.0.0.0 192.168.30.1 preference 60
  !
  return

image

image

source 192.168.10.1 0.0.0.255
    rule normal permit source 192.168.20.1 0.0.0.255
  !
  interface Aux0
    async mode flow
    link-protocol ppp
  !
  interface Ethernet0
    ip address 192.168.100.9 255.255.255.0
  !
  interface Ethernet0.10
    vlan-type dot1q vid 10
    ip address 192.168.10.2 255.255.255.0
    vrrp vrid 10 virtual-ip 192.168.10.254
  !
  interface Ethernet0.20
    vlan-type dot1q vid 20
    ip address 192.168.20.2 255.255.255.0
    vrrp vrid 20 virtual-ip 192.168.20.254
    vrrp vrid 20 priority 120
    vrrp vrid 20 track Serial1 reduced 30
  !
  interface Ethernet1
  !
  interface Serial0
    link-protocol ppp
  !
  interface Serial1
    clock DTECLK1
    link-protocol ppp
    ip address 192.168.40.2 255.255.255.0
    nat outbound 2000 interface
    !
  quit
  ip route-static 0.0.0.0 0.0.0.0 192.168.40.1 preference 60
  !
  return

image

image

R10配置信息:

[r10]dis cur
  Now create configuration...
  Current configuration
  !
    version 1.74
    local-user user1 service-type administrator password simple 123
    sysname r10
    firewall enable
    aaa-enable
    aaa accounting-scheme optional
  !
  interface Aux0
    async mode flow
    link-protocol ppp
  !
  interface Ethernet0
    ip address 192.168.100.10 255.255.255.0
  !
  interface Ethernet1
  !
  interface Serial0
    link-protocol ppp
    ip address 192.168.40.1 255.255.255.0
  !
  interface Serial1
    clock DTECLK1
    link-protocol ppp
    ip address 192.168.30.1 255.255.255.0
  !
  interface LoopBack1
    ip address 2.2.2.2 255.255.255.0
  !
  return

image

SW13配置信息:

[SW13]dis cur
#
sysname SW13
#
radius scheme system
server-type huawei
primary authentication 127.0.0.1 1645
primary accounting 127.0.0.1 1646
user-name-format without-domain

domain system
radius-scheme system
access-limit disable
state active
vlan-assignment-mode integer
idle-cut disable
self-service-url disable
messenger time disable

domain default enable system
#
local-server nas-ip 127.0.0.1 key huawei

local-user user1
password simple 123
service-type telnet level 3
#
stp enable
#
vlan 1
#
vlan 10
#
vlan 20
#
interface Vlan-interface1
ip address 192.168.100.33 255.255.255.0
#
interface Aux0/0
#
interface Ethernet0/1
port link-type trunk
port trunk permit vlan all
#
interface Ethernet0/2
port link-type trunk
port trunk permit vlan all
#
interface Ethernet0/10
port access vlan 10
#
#
interface Ethernet0/24
port link-type trunk
port trunk permit vlan all
#
interface NULL0
#
user-interface aux 0
user-interface vty 0 4
authentication-mode scheme
#
return

image

image

SW11配置信息:

<sw11>dis cur
#
sysname sw11
#
radius scheme system
server-type huawei
primary authentication 127.0.0.1 1645
primary accounting 127.0.0.1 1646
user-name-format without-domain

domain system
radius-scheme system
access-limit disable
state active
idle-cut disable
self-service-url disable
messenger time disable

domain default enable system
#
local-server nas-ip 127.0.0.1 key huawei

local-user user1
password simple 123
service-type telnet level 3
#
stp enable
#
vlan 1
#
vlan 10
#
vlan 20
#
interface Vlan-interface1
ip address 192.168.100.41 255.255.255.0
#
interface Aux0/0
#
interface Ethernet0/1
port link-type trunk
port trunk permit vlan all
#
interface Ethernet0/2
port link-type trunk
port trunk permit vlan all
#
interface Ethernet0/10
port access vlan 10
#
interface Ethernet0/20
port access vlan 20
#
interface Ethernet0/21
#
interface Ethernet0/22
#
interface Ethernet0/23
#
interface Ethernet0/24
port link-type trunk
port trunk permit vlan all
#
interface NULL0
#

image

验证信息:

192.168.10.x主机:

image

当vlan10的主路由R5出现故障时,vlan10备份路由R9启用:

image

 

(4)备份中心实现网络高可用性:

备份中心是VRP 中管理备份功能的模块,它为路由器的接口提供备份。没有运用备份中心时,一旦接口上的线路发生故障,数据传输就中断了。运用备份中心后,当主接口上的线路发生故障Down 掉后,备份中心根据用户配置的延迟时间启动备份接口上的线路进行通讯,数据传输又可以继续进行了。因此运用备份中心可以提高网络的可靠性,增强网络的可用性。

Standby threshold 命令需要在备份中心的主接口上配置。当备份中心中所有主接口的流量达到设定的门限上限时,启动一个优先级最高的可用备份接口;当备份中心所有活动接口的流量小于设定的门限下限时,关闭一个优先级别最低的备份接口。

应用实例:

实验要求:

RA 的ethernet 0/0 口IP 地址为:1.1.1.1,RB 的ethernet 0/0 口IP地址为2.2.2.1 。在本配置中,Serial1/0 接口配置为PPP 封装,作为主接口。Serial1/1 接口配置成拨号口,作为备份接口。主接口down 掉后备份接口自动开始拨号建立连接,主接口恢复后从备份接口切换回主接口。

实验拓扑:

image

配置步骤:

RA配置:

int eth0/0

ip add 1.1.1.1 255.255.255.0

int s1/0

ip add 4.4.4.1 255.255.255.0

link-protocol ppp

ppp authentication-mode pap

standby interface s1/1

int s1/1

ip add 3.3.3.1 255.255.255.0

dialer enable-circular

dialer-group 1

dialer route ip 3.3.3.2 3.3.3.4

quit

dialer-rule 1 ip permit

ip route-static 1.1.1.0 255.255.255.0 4.4.4.1

ip route-static 1.1.1.0 255.255.255.0 3.3.3.1

RB配置:

int eth0/0

ip add 2.2.2.1 255.255.255.0

int s1/0

ip add 4.4.4.2 255.255.255.0

link-protocol ppp

ppp authentication-mode pap

int s1/1

ip add 3.3.3.2 255.255.255.0

dialer enable-circular

dialer-group 1

dialer route ip 3.3.3.1 3.3.3.3

quit

dialer-rule 1 ip permit

ip route-static 2.2.2.0 255.255.255.0 4.4.4.2

ip route-static 2.2.2.0 255.255.255.0 3.3.3.2

Internet配置:

 

int s1/0

ip add 3.3.3.3 255.255.255.0

int s1/1

ip add 3.3.3.4 255.255.255.0

 

(5)链路聚合实现网络高可用性:

链路聚合的作用:

链路聚合是将多个物理以太网端口聚合在一起形成一个逻辑上的聚合组,使用链路聚合服务的上层实体把同一聚合组内的多条物理链路视为一条逻辑链路。
链路聚合可以实现出/入负荷在聚合组中各个成员端口之间分担,以增加带宽。同时,同一聚合组的各个成员端口之间彼此动态备份,提高了连接可靠性。

链路聚合的基本概念:

1. 聚合接口
聚合接口是一个逻辑接口,它可以分为二层聚合接口和三层聚合接口。

2. 聚合组
聚合组是一组以太网接口的集合,聚合组是随着聚合接口的创建而自动生成的。
根据聚合组中可以加入以太网接口的类型,可以将聚合组分为两类:
二层聚合组:随着二层聚合接口的创建而自动生成,只能包含二层以太网接口。
三层聚合组:随着三层聚合接口的创建而自动生成,只能包含三层以太网接口。

链路聚合的模式:

1. 静态聚合模式
静态聚合模式中,成员端口的 LACP 协议为关闭状态。系统按照以下原则设置成员
端口处于Selected 或者Unselected 状态:

2. 动态LACP 聚合模式
当聚合组配置为动态 LACP 聚合模式后,聚合组中成员端口的LACP 协议自动使能。
在动态 LACP 聚合模式中,端口处于不同状态时对协议报文的处理方式如下:
Selected 端口可以收发LACP 协议报文。
处于 up 状态的Unselected 端口如果配置和对应的聚合接口配置相同,可以收发LACP 协议报文。

聚合组的负载分担类型:

聚合组可以分为两种类型:负载分担聚合组和非负载分担聚合组。系统按照以下原则设置聚合组的负载分担类型:
当存在聚合资源时,如果聚合组中有两个或两个以上的 Selected 端口,则系统创建的聚合组为负载分担类型;如果聚合组中只有一个Selected 端口,则系统创建的聚合组的负载分担类型与设备的型号有关,请以设备的实际情况为准。
当聚合资源分配完后,创建的聚合组将为非负载分担类型。

应用实例:

 

image

1. 如果图中是二层以太网接口,则配置二层聚合组实现负载分担

采用静态聚合模式:

# 创建二层聚合接口1。
<DeviceA> system-view
[DeviceA] interface bridge-aggregation 1
[DeviceA-Bridge-Aggregation1] quit
# 将二层以太网接口Ethernet1/1 至Ethernet1/3 加入聚合组1。
[DeviceA] interface ethernet 1/1
[DeviceA-Ethernet1/1] port link-aggregation group 1
[DeviceA-Ethernet1/1] interface ethernet 1/2
[DeviceA-Ethernet1/2] port link-aggregation group 1
[DeviceA-Ethernet1/2] interface ethernet 1/3
[DeviceA-Ethernet1/3] port link-aggregation group 1

2. 如果图中是三层以太网接口,则配置三层聚合组实现负载分担

(2) 采用动态LACP 聚合模式
# 创建三层聚合接口1,并配置成动态LACP 聚合模式。
<DeviceA> system-view
[DeviceA] interface route-aggregation 1
[DeviceA-Route-Aggregation1] link-aggregation mode dynamic
[DeviceA-Route-Aggregation1] quit
# 将三层以太网接口Ethernet1/1 至Ethernet1/3 加入聚合组1。
[DeviceA] interface ethernet 1/1
[DeviceA-Ethernet1/1] port link-aggregation group 1
[DeviceA-Ethernet1/1] interface ethernet 1/2
[DeviceA-Ethernet1/2] port link-aggregation group 1
[DeviceA-Ethernet1/2] interface ethernet 1/3
[DeviceA-Ethernet1/3] port link-aggregation group 1