本人想做一个6to4隧道实验,但是配置到最后的时候,在隧道一端可以ping通隧道另一端,但是在隧道一端不能ping通对端隧道路由器的另一个借口,R3也不能ping通R6.

希望能有高手帮我找下到底哪里出错了,谢谢!!

用的是GNS3模拟器中的3700系列,实验图如下:

 

命令如下:

4.2.1 R1路由器基本配置

R1>enable #进入特权模式
R1#configure terminal #进入全局配置模式
R1(config)#interface s1/1 #进入R1路由器串口1/1
R1(config-if)#ip address 172.16.12.3 255.255.255.0 #给串口增加IPv4的地址 R1(config-if)#clock rate 64000 #设置时钟模式
R1(config-if)#no shutdown #打开串行端口
R1(config-if)#interface FastEthernet0/0 #切换到快速以太口0/0
R1(config-if)#ipv6 address 13::1/64 #给快速以太口增加IPv6地址
R1(config-if)#no shutdown #打开快速以太口
R1(config-if)#exit #退出端口配置模式
R1(config)#ipv6 unicast-routing #开启IPv6的单播路由
R1(config)#interface loopback 103 #设置一个虚拟环路端口编号为103
R1(config-if)#ip address 172.16.101.1 255.255.255.0 #给虚拟环路端口增加IPv4地址 R1(config-if)#exit #退出虚拟环路端口设置
R1(config)#
4.2.2 R5 路由器基本配置
R5>enable #进入特权模式
R5#configure terminal #进入全局配置模式
R5(config)#interface s1/0 #进入R5路由器串口1/0
R5(config-if)#ip address 172.16.12.4 255.255.255.0 #给串口增加IPv4的地址 R5(config-if)#no shutdown #打开串行端口
R5(config-if)#interface FastEthernet0/0 #切换到快速以太口0/0
R5(config-if)#ipv6 address 34::34:4/64 #给快速以太口增加IPv6地址
R5(config-if)#no shutdown #打开快速以太口
R5(config-if)#exit #退出端口配置模式
R5(config)#ipv6 unicast-routing #开启IPv6的单播路由
R5(config)#interface loopback 104 #设置一个虚拟环路端口编号为104 R5(config-if)#ip address 172.16.102.1 255.255.255.0 #给虚拟环路端口增加IPv4地址
R5(config-if)#exit #退出虚拟环路端口设置
R5(config)#
4.2.3 R1路由器启用RIPv2协议
R1(config)#router rip #启动rip设置协议
R1(config-router)#version 2 #设置Rip协议版本
R1(config-router)#network 172.16.12.3 #宣告R1路由器上现有的IPv4网络 R1(config-router)#network 172.16.101.1 #宣告R1路由器上现有的IPv4网络 R1(config-router)#exit #退出Rip设置协议
R1(config)#end #退到特权模式
R1#
4.2.4 R5路由器启用RIPv2协议
R5(config)#router rip #启动rip设置协议
R5(config-router)#version 2 #设置Rip协议版本
R5(config-router)#network 172.16.12.4 #宣告R5路由器上现有的IPv4网络 R5(config-router)#network 172.16.102.1 #宣告R5路由器上现有的IPv4网络 R5(config-router)#exit #退出Rip设置协议
R5(config)#end #退到特权模式
R5#
4.2.5 配置自动隧道 在路由器R1和R5之间创建一条自动隧道
R1>enable #进入特权模式
R1#configure terminal #进入全局配置模式
R1(config)#interface tunnel 13 #创建一条隧道,编号为13
R1(config-if)#no ip address #由于隧道接口不需要IPv4地址,因此配置了no ip address 命令
R1(config-if)#ipv6 address 2002:AC10:6501::/128 #给隧道配置IPv6地址
R1(config-if)#tunnel source loopback 103 #设置隧道的源接口为前面步骤配置的IPv4环回端口
R1(config-if)#tunnel mode ipv6ip 6to4 #设置ipv6隧道封装数据包的模式
R1(config-if)#end #退出隧道配置模式
R1#
R5>enable #进入特权模式
R5#configure terminal #进入全局配置模式
R5(config)#interface tunnel 13 #创建一条隧道,编号为13
R5(config-if)#no ip address #由于隧道接口不需要IPv4地址,因此配置了no ip address 命令
R5(config-if)#ipv6 address 2002:AC10:6601::/128 #给隧道配置IPv6地址
R5(config-if)#tunnel source loopback 104 #设置隧道的源接口为前面步骤配置的IPv4环回端口
R5(config-if)#tunnel mode ipv6ip 6to4 #设置ipv6隧道封装数据包的模式
R5(config-if)#end #退出隧道配置模式
R5#
4.2.6 由于隧道的两端地址属于不同的子网,所以此时从R5 ping R1,调试输出会显示没有找到路由。为解决这个问题,应在R5上配置一条前往R1的静态路由,并在R1上配置一条前往R5的静态路由。
R5(config)#ipv6 route 2002::/16 tunnel 13 #配置一条静态路由,使2002打头的所有分组都将通过隧道传输
R5(config)#
R1(config)#ipv6 route 2002::/16 tunnel 13 #配置一条静态路由,使2002打头的所有分组都将通过隧道传输
R1(config)#
4.2.7 继续配置RIPng,在R3和R1之间,R5和R6之间以及R1和R5之间的6to4隧道上启用RIPng进程RIPtoTU与其它IPv6链路一样,隧道接口也可能与路由选择,与前面一样,RIPng将运行在隧道上,而IPv4RIP运行在物理接口上,以便在环回接口的IPv4地址之间提供连接性。
R3>enable #进行特权模式
R3#configure terminal #进入全局配置模式
R3(config)#interface fastethernet0/0 #进入快速以太口
R3(config-if)#ipv6 address 13::3/64 #给快速以太口配置IPv6地址
R3(config-if)#exit #退出端口配置模式
R3(config)#ipv6 unicast-routing #开启IPv6的单播路由
R3(config)#interface fastethernet0/0 #进入快速以太口配置模式
R3(config-if)#ipv6 rip RIPoTU enable #启动IPv6的RIPoTU模式
R3(config-if)#no shutdown #打开端口
R3(config-if)#exit #退出端口配置模式
R3(config)#
R6>enable #进行特权模式
R6#configure terminal #进入全局配置模式
R6(config)#interface fastethernet0/0 #进入快速以太口
R6(config-if)#ipv6 address 34::34:3/64 #给快速以太口配置IPv6地址
R6(config-if)#exit #退出端口配置模式
R6(config)#ipv6 unicast-routing #开启IPv6的单播路由
R6(config)#interface fastethernet0/0 #进入快速以太口配置模式
R6(config-if)#ipv6 rip RIPoTU enable #启动IPv6的RIPoTU模式
R6(config-if)#no shutdown #打开端口
R6(config-if)#exit #退出端口配置模式
R6(config)#
R1(config)#interface tunnel 13 #进行隧道链路
R1(config-if)#ipv6 rip RIPoTU enable #启动IPv6的RIPoTU模式 R1(config-if)#interface fastethernet0/0 #切换到快速以太口
R1(config-if)#ipv6 rip RIPoTU enable #启动IPv6的RIPoTU模式
R1(config-if)#end #退出端口配置模式
R1#
R5(config)#interface tunnel 13 #进行隧道链路
R5(config-if)#ipv6 rip RIPoTU enable #启动IPv6的RIPoTU模式 R5(config-if)#interface fastethernet0/0 #切换到快速以太口
R5(config-if)#ipv6 rip RIPoTU enable #启动IPv6的RIPoTU模式
R5(config-if)#end #退出端口配置模式
R5#
4.2.8 为达到比隧道另一端更远的地方,必须添加其他的静态路由。
R1(config)#ipv6 route 24::/64 2002:AC10:6601::