route1的配置:
router>en
route#conf t
router(config)#interface s0                           //进入S0接口
router(config-if)#ip address 11.11.1.1 255.255.255.0  //设置S0接口的IP地址
router(config-if)#clock rate 64000                     //设置时钟频率
router(config-if)#no shutdown                         //开启端口
router(config-if)#exit
router(config)#interface e0                          //进入LAN接口
router(config-if)#ip address 10.10.1.1 255.255.255.0 //设置LAN接口的IP地址与客户机IP是同一段网
router(config-if)#no shutdown
router(config-if)#exit
router(config)#ip route 12.12.1.0 255.255.255.0 11.11.1.2 //手动设置下一跳网络地址
router(config)#ip route 13.13.1.0 255.255.255.0 11.11.1.2  //手动设置下一跳网络地址(因为R1有二个不同的网段)
                           
Router2的配置:
router>en
router#conf t
router(config)#interface s0                      //进入S1(与R1的S0连接)接口
router(config-if)#ip address 11.11.1.2 255.255.255.0  //设置S1的IP地址(与R1的S0的IP是同一网段)
router(config-if)#no shutdown             //开启S1的端口
router(config-if)#exit
router(config)#interface s1                          //进入S0的接口
router(config-if)#ip address 12.12.1.1 255.255.255.0  //设置S0的IP地址(这里可以随便设)
router(config-if)#clock rate 64000                   //设置时钟频率
router(config-if)#no shutdown                        //开启S0的端口
router(config-if)#exit
router(config)#ip route 10.10.1.0 255.255.255.0 11.11.1.1 //手动设置下一跳网络地址
router(config)#ip route 13.13.1.0 255.255.255.0 12.12.1.2 //手动设置下一跳网络地址(因为R2有二个不同的网段)
Router3的配置:
router>en
router#conf t
router(config)#interface s1                          //进入S1(与R2的S0连接)接口
router(config-if)#ip address 12.12.1.2 255.255.255.0  //设置S1的IP地址(与R2的S0的IP是同一网段)
router(config-if)#clock rate 64000                     //设置时钟频率
router(config-if)#no shutdown                         //开启端口
router(config-if)#no shutdown                         //开启S1的端口
router(config-if)#exit
router(config)#interface e0                            //进入LAN接口
router(config-if)#ip address 13.13.1.1 255.255.255.0   //设置IP地址(与客户机的IP地址是同一网段)
router(config-if)#no shutdown                          //开启端口
router(config)#ip route 11.11.1.0 255.255.255.0 12.12.1.1  //手动设置下一跳网络地址
router(config)#ip route 10.10.1.0 255.255.255.0 12.12.1.1  //手动设置下一跳网络地址(因为R3有二个不同的网段)
 
两个PC的IP分配在各自的网段
PC0 的IP可设为10.10.1.2 255.255.255.0
PC1 的IP可设为13.13.1.2 255.255.255.0