一、网络拓扑图:
通过MSTP和VRRP实现网关备份,以及负载均衡
二、环境搭建:三层交换机、二层交换机、各两台,路由器一台,PC机三台。
三、实验原理:现实生活中,为了资源的充分利用,往往备份的交换机或者路由器,不只单单充当备份的角色。而是也要承载数据的传输功能。通过MSTP和VRRP技术,将同vlan的根交换机与主网关配置到同一个三层交换机上,将所有的vlan交叉配置,最终实现交换机和网关的备份,以及负载均衡
四、实验步骤:
1、搭建网络拓扑图:
通过MSTP和VRRP实现网关备份,以及负载均衡
2、将交换机之间以及交换机与路由器之间相连的链路,都配成trunk,命令如下:
[Huawei]port-group v10 //创建一个端口组v10
[Huawei-port-group-v10]group-member Ethernet 0/0/2 to Ethernet 0/0/4 //将端口Ethernet 0/0/2到0/0/4加入到端口组
[Huawei-port-group-v10]undo shutdown //开启端口组的所有端口
[Huawei-port-group-v10]port link-type trunk //配置端口组为trunk模式
[Huawei-port-group-v10]port trunk allow-pass vlan all //配置端口组的端口允许通过的vlan为所有vlan
按照上述命令,将将交换机之间以及交换机与路由器之间相连的链路,都配成trunk。
3、在LSW1交换机上配置vlan 10和vlan 20,并将Ethernet 0/0/1加入vlan 1中。命令如下:
[Huawei]vlan batch 10 20 //创建vlan 10,vlan 20
[Huawei]interface Ethernet 0/0/1 //进入端口Ethernet 0/0/1
[Huawei-Ethernet0/0/1]undo shutdown //开启端口
[Huawei-Ethernet0/0/1]port link-type access //设置端口模式为access模式
[Huawei-Ethernet0/0/1]port default vlan 10 //设置端口允许通过vlan 10
按照上述命令,在其余的交换机上创建vlan 10,vlan 20,并将LSW4上的Ethernet 0/0/1加入到vlan 20。
4、配置vlan 10和vlan 20 的根交换机网桥
[Huawei]stp region-configuration //配置MST域
[Huawei-mst-region]region-name 10 //配置region名字
[Huawei-mst-region]instance 10 vlan 10 //配置关联的vlan
[Huawei-mst-region]active region-configuration //激活region的配置
[Huawei-mst-region]quit //退回系统视图
[Huawei]stp region-configuration //配置MST域
[Huawei-mst-region]region-name 20 //配置region名字
[Huawei-mst-region]instance 20 vlan 20 //配置关联的vlan
[Huawei-mst-region]active region-configuration //激活region的配置
配置以上命令后,在LSW2上输入[Huawei]stp instance 10 priority 0 //将此交换机配置为vlan 10 的根网桥
在LSW3上输入[Huawei]stp instance 20 priority 0 //将此交换机配置为vlan 20 的根网桥
在LSW2上输入:[Huawei]display stp instance 10
在LSW3上输入:[Huawei]display stp instance 20
通过MSTP和VRRP实现网关备份,以及负载均衡
通过MSTP和VRRP实现网关备份,以及负载均衡
根据上图得知,LSW2,LSW3分别是vlan 10和vlan 20 的根网桥
5、配置备份网关,
LSW2上输入以下命令:
[Huawei]interface vlanif 10 //进入虚端口 vlanif 10
[Huawei-Vlanif10]ip address 192.168.1.251 255.255.255.0 //配置虚拟端口的IP
[Huawei-Vlanif10]vrrp vrid 10 virtual-ip 192.168.1.250 //开启VRRP并配置虚拟网关
[Huawei-Vlanif10]vrrp vrid 10 priority 200 //配置VRRP主设备的优先级
[Huawei-Vlanif10]vrrp vrid 10 track interface GigabitEthernet 0/0/4 reduced 150 //跟踪端口GigabitEthernet 0/0/4
[Huawei-Vlanif10]quit //退回系统视图
[Huawei]interface vlanif 20
[Huawei-Vlanif20]ip address 192.168.2.251 255.255.255.0 //配置虚拟端口的IP
[Huawei-Vlanif10]vrrp vrid 10 virtual-ip 192.168.2.250 //开启VRRP并配置虚拟网关
LSW2上输入以下命令:
[Huawei]interface vlanif 20 //进入虚端口 vlanif 20
[Huawei-Vlanif20]ip address 192.168.2.252 255.255.255.0 //配置虚拟端口的IP
[Huawei-Vlanif20]vrrp vrid 20 virtual-ip 192.168.2.250 //开启VRRP并配置虚拟网关
[Huawei-Vlanif20]vrrp vrid 20 priority 200 //配置VRRP主设备的优先级
[Huawei-Vlanif20]vrrp vrid 20 track interface GigabitEthernet 0/0/4 reduced 150 //跟踪端口GigabitEthernet 0/0/4
[Huawei-Vlanif20]quit //退回系统视图
[Huawei]interface vlanif 10 //进入虚端口 vlanif 10
[Huawei-Vlanif10]ip address 192.168.1.252 255.255.255.0 //配置虚拟端口的IP
[Huawei-Vlanif10]vrrp vrid 10 virtual-ip 192.168.1.250 //开启VRRP并配置虚拟网关
在LSW2和LSW3上输入以下命令: [Huawei]display vrrp brief
通过MSTP和VRRP实现网关备份,以及负载均衡
通过MSTP和VRRP实现网关备份,以及负载均衡
由上图可知,LSW2和LSW3分别是VLAN 10和VLAN20的主设备
6、配置三层交换机与路由器之间的IP,由于华为三层交换机不能直接在端口上配置IP,所以需要在三层交换机上新建一个vlan,且将连接路由器上的端口设置为access模式,且只允许同过新建的vlan,
LSW2命令如下:
[Huawei]vlan 30 //创建vlan 30
[Huawei]interface GigabitEthernet0/0/4 //进入端口GigabitEthernet0/0/4
[Huawei-GigabitEthernet0/0/4]undo port trunk allow-pass vlan all //取消端口设置的trunk模式
[Huawei-GigabitEthernet0/0/4]port trunk allow-pass vlan 1 //允许端口通过vlan 1
[Huawei-GigabitEthernet0/0/4]quit //退回系统视图
[Huawei]interface vlanif 30 //进入虚拟端口
[Huawei-Vlanif20]ip address 192.168.3.2 255.255.255.0 //给虚拟端口配置IP
然后将路由器与LSW3相连的端口设置IP为192.168.3.2 /24 ,然后在路由上设置静态路由表指向192.168.1.0 和192.168.2.0
下一跳均为192.168.3.2,在交换机上配置一个缺省路由,下一跳为192.168.3.1,LSW2上执行与上面相同的命令,创建vlan 40,ip地址为192.168.4.2,路由器端为192.168.4.1 /24,同样在路由器上设置静态路由表指向192.168.1.0和192.168.2.0,下一跳为192.168.4.2,交换机上配置缺省路由下一跳:192.168.4.1。路由器连接PC3端口设置IP192.168.5.254
用[Huawei]display ip routing-table 查看三层交换机与路由器的路由表
通过MSTP和VRRP实现网关备份,以及负载均衡

通过MSTP和VRRP实现网关备份,以及负载均衡
通过MSTP和VRRP实现网关备份,以及负载均衡
7、配置PC机的IP及网关
PC1:ip192.168.1.1 网关192.168.1.250
PC2:ip192.168.2.1 网关192.168.2.250
PC3:ip192.168.5.1 网关192.168.5.254
8、验证1
PC1和PC2分别pingPC3,并在路由器GigabitEthernet0/0/0和GigabitEthernet0/0/1口抓包分析
PC2在GigabitEthernet0/0/0口抓包结果如下:
通过MSTP和VRRP实现网关备份,以及负载均衡
通过MSTP和VRRP实现网关备份,以及负载均衡
通过MSTP和VRRP实现网关备份,以及负载均衡

由上结果可知PC1发的数据都是从GigabitEthernet0/0/0发出去的,
PC2在GigabitEthernet0/0/1抓包结果如下:
通过MSTP和VRRP实现网关备份,以及负载均衡
由上结果可知,PC1和PC2与外部通信时,不是在同一个三层交换机上进行的,验证了网关的负载均衡。
验证2
当LSW2GigabitEthernet0/0/4于关闭状态PC1和PC2能否ping通PC3
通过MSTP和VRRP实现网关备份,以及负载均衡
当LSW3GigabitEthernet0/0/4于关闭状态PC1和PC2能否ping通PC3
通过MSTP和VRRP实现网关备份,以及负载均衡

由上结果可知,无论哪个三层交换机与外部的链路发生故障,都不影响PC1和PC2与PC3的通信。验证了网关的备份。