一、网络拓扑图
思科设备不同vlan之间通过单臂路由通信
二、环境:交换机、路由器各一台,PC机两台
思路:利用路由器上接口的虚拟子接口,分别配置vlan 2和vlan 3的网关,然后使两个不同vlan之间可以互通
1、先配置交换机的配置,交换机与路由器之间的链路设为trunk,命令如下:
Switch>enable //进入特权模式
Switch#configure terminal //进入全局模式
Switch(config)#vlan 2 //创建vlan 2
Switch(config-vlan)#vlan 3 //创建vlan 3
Switch(config-vlan)#exit //退回全局模式
Switch(config)#interface FastEthernet 0/1 //进入端口 FastEthernet 0/1
Switch(config-if)#no shutdown //开启端口
Switch(config-if)#switchport access vlan 2 //将端口加入vlan 2
Switch(config-if)#exit //退回全局模式
Switch(config)#interface fastEthernet 0/2 //进入端口 fastEthernet 0/2
Switch(config-if)#no shutdown //开启端口
Switch(config-if)#switchport access vlan 3 //将端口加入vlan 3
Switch(config-if)#exit //退回全局模式
Switch(config)#interface fastEthernet 0/3 //进入端口 fastEthernet 0/3
Switch(config-if)#no shutdown //开启端口
Switch(config-if)#switchport mode trunk //将端口配置为trunk模式
思科设备不同vlan之间通过单臂路由通信
2、配置路由器,命令如下:
Router>enable //进入特权模式
Router#configure terminal //进入全局模式
Router(config)#interface fastEthernet 0/0 //进入端口fastEthernet 0/0
Router(config-if)#no ip address //删除端口fastEthernet 0/0的IP
Router(config-if)#no shutdown //开启fastEthernet 0/0端口
Router(config-if)#exit //退回全局模式
Router(config)#interface fastEthernet 0/0.1 //进入fastEthernet 0/0的第一个子端口
Router(config-subif)#encapsulation dot1Q 2 //使用802.1Q协议封装Vlan2
Router(config-subif)#ip address 192.168.1.254 255.255.255.0 //给子接口配置IP
Router(config-subif)#no shutdown //开启子端口
Router(config-subif)#exit //退回全局模式
Router(config)#interface fastEthernet 0/0.2 //进入fastEthernet 0/0的第二个子端口
Router(config-subif)#encapsulation dot1Q 3 //使用802.1Q协议封装Vlan3
Router(config-subif)#ip address 192.168.2.254 255.255.255.0 ////给子接口配置IP
Router(config-subif)#no shutdown ////开启子端口
Router(config-subif)#end //退回特权模式
Router#show ip route //查看路由表
思科设备不同vlan之间通过单臂路由通信
3、配置PC机,按下图配置:
思科设备不同vlan之间通过单臂路由通信思科设备不同vlan之间通过单臂路由通信
4、验证PC2与PC3能否ping通
思科设备不同vlan之间通过单臂路由通信