一、网络拓扑图
思科交换机和路由器设备实现DHCP功能
二、思路:
1、先在交换机上配置vlan 2,3.然后开启交换机上的路由功能。
2、将vlan 2,3加入端口后在对应的端口配置对应vlan的网关地址,再配置路由器与交换机相连的端口的IP。
3、在路由器上配置连接交换机接口的IP地址。并配置去往两网关的路由表。
4、在路由器上配置两个地址池,每个vlan对应一个地址池。
5、回到交换机上,在两个网关端口配置DHCP中继。
6、验证不同vlan通过DHCP获取的地址是否是地址池对应的地址
三、配置,按照上述思路,先配置交换机,命令如下:
Switch>enable //进入特权模式
Switch#configure terminal //进入全局模式
Switch(config)#vlan 2 //创建vlan 2
Switch(config)#vlan 3 //创建vlan 3
Switch(config)#exit //退回全局模式
Switch#interface fastEthernet 0/1 //进入端口fastEthernet 0/1
Switch(config-if)#no shutdown //开启端口
Switch(config-if)#switchport mode access //配置端口模式为access
Switch(config-if)#switchport access vlan 2 //将vlan 2放入端口
Switch(config-if)#no switchport //进入配置vlan 2ip地址
Switch(config-if)#ip address 192.168.1.254 255.255.255.0 //配置ip地址
Switch(config-if)#ip helper-address 192.168.3.254 //配置中继
Switch(config-if)#eixt //退回全局模式
Switch#interface fastEthernet 0/2 //进入端口fastEthernet 0/2
Switch(config-if)#no shutdown //开启端口
Switch(config-if)#switchport mode access //配置端口模式为access
Switch(config-if)#switchport access vlan 3 //将vlan 3放入端口
Switch(config-if)#no switchport //进入配置vlan 2ip地址
Switch(config-if)#ip address 192.168.2.254 255.255.255.0 //配置ip地址
Switch(config-if)#ip helper-address 192.168.3.254 //配置中继
Switch(config-if)#eixt //退回全局模式
Switch#interface fastEthernet 0/3 //进入端口 fastEthernet 0/3
Switch(config-if)#no shutdown //开启端口
Switch(config-if)#ip address 192.168.3.1 255.255.255.0 //配置ip地址

四、配置路由器,配置路由器地址,路由表、DHCP地址池
Router>enable //进入特权模式
Router#configure terminal //进入全局模式
Router(config)#interface fastEthernet 0/0 //进入端口fastEthernet 0/0
Router(config-if)#no shutdown //开启端口
Router(config-if)#ip address 192.168.3.254 255.255.255.0 //配置端口IP地址
Router(config-if)#exit //退回全局模式
Router(config)#ip dhcp pool fwq //新建地址池fwq
Router(dhcp-config)#network 192.168.1.0 255.255.255.0 //配置地址池网段
Router(dhcp-config)#default-router 192.168.1.254 //配置地址池网关
Router(dhcp-config)#dns-server 8.8.8.8 //配置地址池DNS服务器
Router(dhcp-config)#exit //退回全局模式
Router(config)#ip dhcp pool fwq2 新建地址池fwq2
Router(dhcp-config)#network 192.168.2.0 255.255.255.0 //配置地址池网段
Router(dhcp-config)#default-router 192.168.2.254 //配置地址池网关
Router(dhcp-config)#dns-server 114.114.114.114 //配置地址池DNS服务器
Router(dhcp-config)#exit //退回全局模式
Router(config)#service dhcp //开启DHCP功能
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.3.1 //配置去往192.168.1.0网段的路由表
Router(config)#ip route 192.168.2.0 255.255.255.0 192.168.3.1 //配置去往192.168.2.0网段的路由表
五、验证。开启PC机的DHCP功能,验证是否能获得IP地址
思科交换机和路由器设备实现DHCP功能思科交换机和路由器设备实现DHCP功能
由上结果可知,PC机成功获取了属于自己网关的IP地址。