一、网络拓扑图
二、思路:
将同部门的PC机规划到同一个VLAN中,然后通过MSTP技术对交换机上的vlan进行优先级划分。
三、构建网络拓扑图,将所需的网络设备添加到拓扑图中,并连上网线。
通过MSTP技术实现小型制造工厂的网络链路备份以及负载均衡
四、配置PC机的IP地址及子网掩码,标识出所属的VLAN、IP地址、所属车间。以及vlan 代表的部门。
通过MSTP技术实现小型制造工厂的网络链路备份以及负载均衡
五、配置交换机
1、先配置连接车间PC机的交换机。创建vlan 2、vlan 3、vlan 4。并将连接PC机的端口全部设置为Access端口。
交换机相连的端口设置为trunk端口。命令如下:
<Huawei> system-view //用户视图下输入system-view进入系统视图
[Huawei]vlan batch 2 to 4 //创建vlan 2、vlan 3、vlan 4
[Huawei]interface GigabitEthernet 0/0/1 //进入接口GigabitEthernet 0/0/1
[Huawei-GigabitEthernet0/0/1]undo shutdown //开启端口
[Huawei-GigabitEthernet0/0/1]port link-type access //设置端口为access
[Huawei-GigabitEthernet0/0/1]port default vlan 2 //将vlan 2添加到端口
[Huawei]interface GigabitEthernet 0/0/2 //进入接口GigabitEthernet 0/0/2
[Huawei-GigabitEthernet0/0/2]undo shutdown //开启端口
[Huawei-GigabitEthernet0/0/2]port link-type access //设置端口为access
[Huawei-GigabitEthernet0/0/2]port default vlan 3 //将vlan 3添加到端口
[Huawei]interface GigabitEthernet 0/0/3 //进入接口GigabitEthernet 0/0/3
[Huawei-GigabitEthernet0/0/3]undo shutdown //开启端口
[Huawei-GigabitEthernet0/0/3]port link-type access //设置端口为access
[Huawei-GigabitEthernet0/0/3]port default vlan 4 //将vlan 4添加到端口
[Huawei-GigabitEthernet0/0/3]quit //退回系统视图
[Huawei]port-group 1 //创建端口组
[Huawei-port-group-1]group-member GigabitEthernet 0/0/4 GigabitEthernet 0/0/5 //将GigabitEthernet 0/0/4和0/0/5加入端口组
[Huawei-port-group-1]undo shutdown //开启端口
[Huawei-port-group-1]port link-type trunk //设置端口组的接口模式为trunk
[Huawei-port-group-1]port trunk allow-pass vlan all //允许所有vlan通过
在交换机LSW 1、2、3上配置以上命令,其中LSW 2中的端口组成员是GigabitEthernet 0/0/4、0/0/5、0/0/6
2、配置 交换机LSW 4和LSW 6,创建VLAN 2、3、4。将两台交换机上的接口都设置为trunk。命令如下:
LSW 4
<Huawei> system-view //用户视图下输入system-view进入系统视图
[Huawei]vlan batch 2 to 4 //创建vlan 2、vlan 3、vlan 4
[Huawei]port-group 1 //创建端口组
[Huawei-port-group-1]group-member GigabitEthernet 0/0/1 GigabitEthernet 0/0/2 Gi
gabitEthernet 0/0/3 GigabitEthernet 0/0/4 GigabitEthernet 0/0/5
//将GigabitEthernet 0/0/1~0/0/5加入端口组
[Huawei-port-group-1]undo shutdown //开启端口
[Huawei-port-group-1]port link-type trunk //设置端口组的接口模式为trunk
[Huawei-port-group-1]port trunk allow-pass vlan all //允许所有vlan通过
LSW 6
<Huawei> system-view //用户视图下输入system-view进入系统视图
[Huawei]vlan batch 2 to 4 //创建vlan 2、vlan 3、vlan 4
[Huawei]port-group 1 //创建端口组
[Huawei-port-group-1]group-member GigabitEthernet 0/0/1 GigabitEthernet 0/0/2 //将GigabitEthernet 0/0/1~0/0/2加入端口组
[Huawei-port-group-1]undo shutdown //开启端口
[Huawei-port-group-1]port link-type trunk //设置端口组的接口模式为trunk
[Huawei-port-group-1]port trunk allow-pass vlan all //允许所有vlan通过
3、配置交换机LSW 5 命令如下:
<Huawei> system-view //用户视图下输入system-view进入系统视图
[Huawei]vlan batch 2 to 4 //创建vlan 2、vlan 3、vlan 4
[Huawei]interface GigabitEthernet 0/0/3 //进入接口GigabitEthernet 0/0/3
[Huawei-GigabitEthernet0/0/3]undo shutdown //开启端口
[Huawei-GigabitEthernet0/0/3]port link-type access //设置端口为access
[Huawei-GigabitEthernet0/0/3]port default vlan 2 //将vlan 2添加到端口
[Huawei]interface GigabitEthernet 0/0/4 //进入接口GigabitEthernet 0/0/4
[Huawei-GigabitEthernet0/0/4]undo shutdown //开启端口
[Huawei-GigabitEthernet0/0/4]port link-type access //设置端口为access
[Huawei-GigabitEthernet0/0/4]port default vlan 3 //将vlan 3添加到端口
[Huawei]interface GigabitEthernet 0/0/5 //进入接口GigabitEthernet 0/0/5
[Huawei-GigabitEthernet0/0/5]undo shutdown //开启端口
[Huawei-GigabitEthernet0/0/5]port link-type access //设置端口为access
[Huawei-GigabitEthernet0/0/5]port default vlan 4 //将vlan 4添加到端口
[Huawei-GigabitEthernet0/0/5]quit //退回系统视图
[Huawei]port-group 1 //创建端口组
[Huawei-port-group-1]group-member GigabitEthernet 0/0/1 GigabitEthernet 0/0/2 //将GigabitEthernet 0/0/1~0/0/2加入端口组
[Huawei-port-group-1]undo shutdown //开启端口
[Huawei-port-group-1]port link-type trunk //设置端口组的接口模式为trunk
[Huawei-port-group-1]port trunk allow-pass vlan all //允许所有vlan通过
4、配置交换机的MSTP
命令如下:
[Huawei]stp region-configuration //进入MSTP域视图
[Huawei-mst-region]region-name gongsi //配置MSTP域的域名
[Huawei-mst-region]instance 1 vlan 2 //配置vlan 2的映射
[Huawei-mst-region]instance 2 vlan 3 //配置vlan 3的映射
[Huawei-mst-region]instance 3 vlan 4 //配置vlan 4的映射
[Huawei-mst-region]active region-configuration //激活MSTP域
每个交换机都输入以上命令
5、配置vlan 2、3、4对应的根网桥,以及修改交换机vlan对应的优先级的值。
vlan 2的根网桥以及各交换机的优先级的值,如下图:
通过MSTP技术实现小型制造工厂的网络链路备份以及负载均衡
命令为:
[Huawei]stp instance 1 priority 0
对应的交换机设置对应的priority值
vlan 3、4的根网桥以及各交换机的优先等级值如下图
通过MSTP技术实现小型制造工厂的网络链路备份以及负载均衡
命令为:
[Huawei]stp instance 2 priority 0
[Huawei]stp instance 3 priority 0
六、验证:
在下图圈红点出进行抓包,然后分别用PC1pingPC10,PC2pingPC11,PC3pingPC12
通过MSTP技术实现小型制造工厂的网络链路备份以及负载均衡
经过抓包分析
车间一的VLAN 2的数据流向图为:
通过MSTP技术实现小型制造工厂的网络链路备份以及负载均衡
车间一的VLAN 3、4的数据流向图为:
通过MSTP技术实现小型制造工厂的网络链路备份以及负载均衡

将LSW 3与LSW 2之间的网线取掉,再用PC1pingPC10
通过MSTP技术实现小型制造工厂的网络链路备份以及负载均衡通过MSTP技术实现小型制造工厂的网络链路备份以及负载均衡
以上结果证明实现了网络链路的备份以及负载均衡