思路先配置直连路由,然后再配置静态路由,最后配置浮动路由
一、配置直连路由
1)新建拓扑图,添加需要用到的设备,并连接网线,启动设备。
eNSP中浮动路由的配置

2)对PC机进行配置:
PC1 ip 192.168.1.1 子网掩码:255.255.255.0 网关:192.168.1.254
PC2 ip 192.168.4.1 子网掩码:255.255.255.0 网关:192.168.4.254
并标识出PC机的IP地址
eNSP中浮动路由的配置

3)配置直连路由,配置路由器AR1接口的ip地址,命令如下:
system-view //进入系统视图
interface GigabitEthernet 0/0/1 //进入端口GE 0/0/1
ip address 192.168.1.254 24 //设置接口ip地址为192.168.1.254和默认子网掩码
undo shutdown //开启当前端口
interface GigabitEthernet 0/0/0 //进入端口GE 0/0/0
ip address 192.168.2.1 24 //设置端口ip地址为192.168.2.1和默认子网掩码
undo shutdown //开启当前端口
配置完之后,标识出端口的ip地址
eNSP中浮动路由的配置

4)按照以上命令,依次配置AR2,AR3接口的ip地址,并标识出接口对应的ip
其中AR2的GE 0/0/0 ip为192.168.2.2
GE 0/0/2 ip为192.168.3.1
其中AR3的GE 0/0/2 ip为192.168.3.2
GE 0/0/1 ip为192.168.4.254
eNSP中浮动路由的配置
二、配置静态路由
给路由器AR1,AR3配置静态缺省路由,AR1命令如下:
system-view //进入系统视图
ip route-static 0.0.0.0 0.0.0.0 192.168.2.2 //配置缺省路由,下一跳地址选择192.168.2.2
AR2命令如下:
system-view //进入系统视图
ip route-static 0.0.0.0 0.0.0.0 192.168.3.1 //配置缺省路由,下一跳地址选择192.168.3.1
AR2不能配置静态缺省路由,只能配静态路由。命令如下:
system-view //进入系统视图
ip route-static 192.168.1.0 255.255.255.0 192.168.2.1 //配置去往192.168.1.0网段的路由表
ip route-static 192.168.4.0 255.255.255.0 192.168.3.2 //配置去往192.168.4.0网段的路由表
执行以上命令后,验证PC1与PC2能否互通
eNSP中浮动路由的配置
eNSP中浮动路由的配置
结果证明两台PC机可以互通
三、下面开始配置浮动静态路由
1)先在AR1与AR2之间,再连接一根网线。然后将AR1的缺省路由改为普通的静态路由
system-view //进入系统视图
undo ip route-static 0.0.0.0 0.0.0.0 192.168.2.2 //删除缺省路由
ip route-static 192.168.4.0 255.255.255.0 192.168.2.2 //建立静态路由
eNSP中浮动路由的配置
2)为新开的两个接口设置IP
AR1 ip 192.168.5.1
AR2 ip 192.168.5.2
标识出接口对应的IP
eNSP中浮动路由的配置
3)为AR1添加一个静态路由,命令如下:
system-view //进入系统视图
ip route-static 192.168.4.0 255.255.255.0 192.168.5.2 //设置静态路由
当接口GE 0/0/0发生故障时
路由器通过GE 0/0/1进行通信